Download it now!
Bug 93064 - START CENTER: Icon sizes in breeze cause help and extensions buttons not to be visible
Summary: START CENTER: Icon sizes in breeze cause help and extensions buttons not to b...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-01 16:18 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-08-23 12:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
breeze icons in start center (57.94 KB, image/png)
2015-08-01 16:18 UTC, Yousuf Philips (jay) (retired)
Details
UI is sitting below the lower panel, impossible to get to this area. (166.45 KB, image/png)
2015-08-14 12:46 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-08-01 16:18:25 UTC
Created attachment 117583 [details]
breeze icons in start center

With a 1280x768 screen resolution, the large breeze icons in the start center no longer provide sufficient space to show the help and extension buttons at the bottom of the launch panel since 'Open Remote File' was added to the panel in 5.1.

I would recommend fixing this by reducing the sizes of the non-launch applications icons like open file, templates, etc.
Comment 1 V Stuart Foote 2015-08-01 22:01:40 UTC
Confirming.

Currently the minimum StartCenter size is 800 pixels in the Y-axis.

So, another way to fix this would be to set the StartCenter minimum height to 768 pixels and reduce the spacing between buttons and icons.

And, I guess something to consider would be an Expert Configuration, to control minimum sizes of the StartCenter panel. So that rather than HiDPI and "default", we can adjust the GUI instance to "consume" the real-estate by comon screen pixel sizes, as the user prefers. E.g. 1024x768, 1280x768, 1920x1080, 1920x1200, etc.
Comment 2 Dave Richards 2015-08-14 12:44:33 UTC
Earliest version is actually 5.0.2 daily build.  This one is greatly affecting us, users in 1024x768 cannot see the bottom of their documents and there is no way to resize it down.

LO pushes itself to sit physically below the panel at the bottom, obscuring part of the canvas.
Comment 3 Dave Richards 2015-08-14 12:46:37 UTC
Created attachment 117913 [details]
UI is sitting below the lower panel, impossible to get to this area.
Comment 4 Alex Thurgood 2015-08-14 13:04:22 UTC

*** This bug has been marked as a duplicate of bug 92242 ***
Comment 5 Yousuf Philips (jay) (retired) 2015-08-14 14:47:57 UTC
(In reply to Dave Richards from comment #2)
> Earliest version is actually 5.0.2 daily build.  This one is greatly
> affecting us, users in 1024x768 cannot see the bottom of their documents and
> there is no way to resize it down.

The minimum height for 5.0 with breeze is 757px, so if you have panels that take up any of the area, it would be covering up portions of LO.

> LO pushes itself to sit physically below the panel at the bottom, obscuring
> part of the canvas.

Quick fix for you - take the breeze.zip file from 5.0.2 and add it to 5.0.5. :D

(In reply to Dave Richards from comment #3)
> Created attachment 117913 [details]
> UI is sitting below the lower panel, impossible to get to this area.

Just so you know, LO's minimum target resolution has been set to 1280x768 in the HIG and various UI elements will be optimized for that resolution, like the improved toolbar buttons in 5.0. So if you have users with 1024x768 screens, i'd recommend you upgrade their screens.
Comment 6 Alex Thurgood 2015-08-16 13:39:36 UTC
(In reply to Yousuf (Jay) Philips from comment #5)


Hi Jay,

> Just so you know, LO's minimum target resolution has been set to 1280x768 in
> the HIG and various UI elements will be optimized for that resolution, like
> the improved toolbar buttons in 5.0. So if you have users with 1024x768
> screens, i'd recommend you upgrade their screens.

When Dave and I discussed this on IRC, we discovered that the problem also affects users 1366x768 resolution monitors, i.e. standard 19" screens.

The problem is that the new LO HIG resolution you mention in your reply fails to take into account the smaller area available on OSX when the Dock is present/visible, which is the default in the majority of OSX installations. 
Currently, LibreOffice is the only application that I know of, whether proprietary or open source) not to respect the presence of the Dock.
Comment 7 Yousuf Philips (jay) (retired) 2015-08-16 17:44:33 UTC
Hi Alex,

(In reply to Alex Thurgood from comment #6)
> When Dave and I discussed this on IRC, we discovered that the problem also
> affects users 1366x768 resolution monitors, i.e. standard 19" screens.

Yes this issue affects all resolutions with a height of 768 or less. To my recollection, standard 19" monitor have a resolution of 1280x1024 and a widescreen 19" is 1440x900. 1366x768 is the standard resolutions on laptops these days.

> The problem is that the new LO HIG resolution you mention in your reply
> fails to take into account the smaller area available on OSX when the Dock
> is present/visible, which is the default in the majority of OSX
> installations. 

The target resolution mentioned in the HIG is the user's screen resolution, irrespective of the panels/docks they have in their desktop environment. When dealing with issues that affect height (e.g. the sidebar), i cater to the assumption that a user has 1 horizontal panel in their desktop environment (windows, ubuntu's unity, gnome 3, kde, lxde, cinnamon). If a user has more than 1 panel, it it wont look as great for them (e.g. a scrollbar appears), but it shouldnt make it unusable.

> Currently, LibreOffice is the only application that I know of, whether
> proprietary or open source) not to respect the presence of the Dock.

Yes this bug does cause LO not to respect the panels on any OS, which is why i reported this, as i saw it on my 1280x768 laptop and knew it would arise months back when Andreas decided to go with larger icons for breeeze than with any other icon theme.
Comment 8 Commit Notification 2015-08-18 06:25:27 UTC
andreask committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9eec11735cf929cbb5da72bc500e9ad1735c4bf3

Breeze: StartCenter icon size fixed to 32px tdf#93064 tdf#92242

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-08-18 15:11:28 UTC
andreask committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a23d5bc8bb3c43f31d2d66fcac0d28e273d948a8&h=libreoffice-5-0

Breeze: StartCenter icon size fixed to 32px tdf#93064 tdf#92242

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-08-21 08:48:04 UTC
andreask committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c66224c161b930427f6ae8544abe08b881ab200&h=libreoffice-5-0-1

Breeze: StartCenter icon size fixed to 32px tdf#93064 tdf#92242

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.