Bug 93244 - Widescreen aspect ratio (16:9) by default in Impress
Summary: Widescreen aspect ratio (16:9) by default in Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Templates Impress-UX
  Show dependency treegraph
 
Reported: 2015-08-07 14:35 UTC by Bastián Díaz
Modified: 2018-03-20 09:40 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2015-08-07 14:35:19 UTC
Since long ago, the widescreen format is in most electronic devices. Especially monitors, television screens and projectors that are used today to make presentations.
MS PowerPoint delivery this default setting from version 2013 and adds to other applications for presentation as GDrive, ZOHO, keynote, etc. in desktop version and mobile.
I think this change important because it affects the decision to volunteer designers and users to create new templates for Impres, considering that the distribution of objects changes and converting templates 4: 3-16: 9, requires many changes.

https://blogs.office.com/2013/01/24/powerpoint-2013-widescreen-presentations/

Thanks
Comment 1 Yousuf Philips (jay) (retired) 2015-08-09 15:59:43 UTC
I had asked this question not so long ago (both for impress and draw) and from checking of other presentation apps, the majority of them havent shifted over to widescreen yet, but provide in their template selector dialog an easy means of seeing 4:3 and 16:9 templates to choose from. We presently dont have any 16:9 templates, so that is another reason not to go to that ratio presently.

In the upcoming 5.1 release, users will have easy access to change the slide ratio in the sidebar (bug 89466).
Comment 2 Bastián Díaz 2015-08-29 16:57:57 UTC
(In reply to Yousuf (Jay) Philips from comment #1)
> presently dont have any 16:9 templates, so that is another reason not to go
> to that ratio presently.

From my point of view, switching to 16: 9 motivate users to create templates that format screen. (ideally all template should be in both formats 16:9 and 4:3).
I'm working on some contributions that I hope to share in a week.


> 
> In the upcoming 5.1 release, users will have easy access to change the slide
> ratio in the sidebar (bug 89466).

Great!

Cheers.
Comment 3 Robinson Tryon (qubit) 2016-08-25 05:39:30 UTC Comment hidden (obsolete)
Comment 4 Heiko Tietze 2017-07-21 09:08:18 UTC
+1 to switch the default to 16:9
Comment 5 Yousuf Philips (jay) (retired) 2017-07-21 20:44:45 UTC
-1 for me, as

1. 16:9 leaves less space to work with when both the slide pane and the sidebar are open
2. users have easy access to switch to it in the sidebar
3. most of our templates arent 16:9
4. most other presentation apps havent switch over to it
5. users who prefer 16:9 can easily create a 16:9 template as their default

Stuart, Cor, Samuel, Regina, Sophie: what is your take?
Comment 6 Bastián Díaz 2017-07-21 23:28:46 UTC
(In reply to Yousuf Philips (jay) from comment #5)
> -1 for me, as
> 
> 1. 16:9 leaves less space to work with when both the slide pane and the
> sidebar are open

True, but the side panel can be easily hidden, in addition, it is not the only available interface layout and many more come in (MUFFIN!).
On the other hand, if a user uses the 16: 9 format it is because it is the most useful, practical and that gives him more space to present the content and in the end that is what is important.

> 2. users have easy access to switch to it in the sidebar

The same if default is 16:9 and you want to use another page format.

> 3. most of our templates arent 16:9

How could this be solved? Means that each template must have a file for each page format (eg 4:3, 16:9, 16:10, etc.). Whatever the decision, the most popular formats for users should be offered IMHO.

> 4. most other presentation apps havent switch over to it

As I mentioned above when opening the report, most other presentation applications changed to 16:9 by default.

> 5. users who prefer 16:9 can easily create a 16:9 template as their default

That's right, but I do not think it's the way to see the problem. Why keep the 4: 3 format by default? More than being the most popular or used format (it is not already) is a legacy format and in my case, I have a template 4.3 for these cases (contrary to what you propose).
Comment 7 V Stuart Foote 2017-07-22 05:02:35 UTC
Agree 4:3 should be replaced with a 16:9 default. Also believe existing library of 4:3 templates should be scaled and adjusted as needed. Any new template submissions should be at 16:9 

From a practical side, 4:3 projectors are increasingly rare. I moved my classrooms to 16:9 FullHD projectors years ago, and faculty laptops and workstations have been 16:9 almost as long.

So the UI authoring default should evolve to match common presentation equipment and avoid distortion of slide when scaled. The loss of horizontal space to the UI is negligible as the Sidebar deck can be collapsed, while emerging MUFFIN interfaces provide alternative(s) to the Sidebar.
Comment 8 Yousuf Philips (jay) (retired) 2017-07-24 15:04:20 UTC
(In reply to Bastián Díaz from comment #6)
> True, but the side panel can be easily hidden, in addition, it is not the
> only available interface layout and many more come in (MUFFIN!).

Well this discussion would only focus on the default interface layout, but even if we include the other interface layouts, all but the tabbed notebookbar utilize the sidebar.

> As I mentioned above when opening the report, most other presentation
> applications changed to 16:9 by default.

As mentioned above in comment 1, "... the majority of them havent shifted over to widescreen yet, but provide in their template selector dialog an easy means of seeing 4:3 and 16:9 templates to choose from." This statement is true for iwork keynote, calligra stage, corel presentation x7, and used to also be true for GDrive when i made that comment.

The simplest solution is to do the same and create a black 4:3 and 16:9 templates that the users can select from when the template manager appears.

(In reply to V Stuart Foote from comment #7)
> The loss of horizontal
> space to the UI is negligible as the Sidebar deck can be collapsed, while
> emerging MUFFIN interfaces provide alternative(s) to the Sidebar.

As the sidebar contains all formatting, transition and animation options, collapsing the sidebar isnt an option. Even with new UI layouts, most will rely on the sidebar.
Comment 9 Bastián Díaz 2017-07-24 19:17:08 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> 
> Well this discussion would only focus on the default interface layout, but
> even if we include the other interface layouts, all but the tabbed
> notebookbar utilize the sidebar.
> 

why? You say it as if the interfaces in LO were something static, even the default layout is dynamic. There are elements that are only found in the sidebar or will follow that path. 
If only showing the tab bar of sidebar by default, you gain more space by showing a 16:9 slide than a 4:3 slide. https://cloud.woelkli.com/s/z13YdEk4RImhjee

On the other hand, it is not a real problem using different configurations of the default layout using a 16:9 page format (note: the size of the sidebar is the one that brings by default LO). https://cloud.woelkli.com/s/amf5az6HWlCtwtm

I don't think you should not use a new page format simply because the default layout has less space to work, but instead, adapt the elements of the default layout to embrace the new format is the way. As I said earlier 4:3 formats are legacy and so other presentation applications offer templates for this, although currently the default format is 16:9. Also consider Apple Keynote, MS Power Point and other presentations apps also have a slide pane and a sidebar using the 16:9 format by default for years.

> 
> As mentioned above in comment 1, "... the majority of them havent shifted
> over to widescreen yet, but provide in their template selector dialog an
> easy means of seeing 4:3 and 16:9 templates to choose from." This statement
> is true for iwork keynote, calligra stage, corel presentation x7, and used
> to also be true for GDrive when i made that comment.
> 

On the template selector I agree, but it is not so on the default page format. The dialog for selecting templates is optional and shows both options, however, the default format remains 16:9 if nothing is selected. 

> The simplest solution is to do the same and create a black 4:3 and 16:9
> templates that the users can select from when the template manager appears.
> 

IMHO I think it is not good to show templates of different formats on one page. For example, Apple Keynote shows a set of common templates and a combobox that allows you to select the resolution of these (changing the aspect ratio), even if the resolution is changed, the same set of templates is displayed.

LibreOffice could display a limited set of templates (including a blank layout) available in 16:9 and 4:3 aspect ratio.
Comment 10 Yousuf Philips (jay) (retired) 2017-07-25 23:00:08 UTC
(In reply to Bastián Díaz from comment #9)
> why? You say it as if the interfaces in LO were something static, even the
> default layout is dynamic. There are elements that are only found in the
> sidebar or will follow that path. 
> If only showing the tab bar of sidebar by default, you gain more space by
> showing a 16:9 slide than a 4:3 slide.
> https://cloud.woelkli.com/s/z13YdEk4RImhjee

Not a usable default layout, as the user would have to open up the sidebar to get any real work done.

> On the other hand, it is not a real problem using different configurations
> of the default layout using a 16:9 page format (note: the size of the
> sidebar is the one that brings by default LO).
> https://cloud.woelkli.com/s/amf5az6HWlCtwtm

Cropping the elements in the open sidebar or having the sidebar only show the tab bar arent usable default layouts.

> I don't think you should not use a new page format simply because the
> default layout has less space to work, but instead, adapt the elements of
> the default layout to embrace the new format is the way.

If there is a feasible means to adjust the default layout that would permit a 16:9 template to appear good, i'd be more than glad to accept it, but i havent seen one.

> Also
> consider Apple Keynote, MS Power Point and other presentations apps also
> have a slide pane and a sidebar using the 16:9 format by default for years.

Powerpoint doesnt have a sidebar, it has an optional/advanced formatting pane, and when the pane appears or is resized, it dynamically shrinks the slide pane. Keynote has a fixed size sidebar (270px), while Impress' sidebar needs a minimum of 20% more width to appear with non-cropped controls.

> On the template selector I agree, but it is not so on the default page
> format. The dialog for selecting templates is optional and shows both
> options, however, the default format remains 16:9 if nothing is selected. 

These apps require you to select a template before you can enter the apps and it isnt optional.

> IMHO I think it is not good to show templates of different formats on one
> page. For example, Apple Keynote shows a set of common templates and a
> combobox that allows you to select the resolution of these (changing the
> aspect ratio), even if the resolution is changed, the same set of templates
> is displayed.

Yes ideally we should filter templates by their aspect ratio in the future. We can replace the disabled 'Filter by Application' control.

No need for us to go back and forth any more. Lets hear from others who have been CCed for their opinions.
Comment 11 Bastián Díaz 2017-07-26 03:17:11 UTC
(In reply to Yousuf Philips (jay) from comment #10)
 
> Not a usable default layout, as the user would have to open up the sidebar
> to get any real work done.
> 

That is the idea, since 4.4 (Bug 67627) it is possible to open and close desks easily from the tab bar.

> 
> Cropping the elements in the open sidebar or having the sidebar only show
> the tab bar arent usable default layouts.
> 

As I mentioned above, I use the default Impress view (it looks like a bug from properties -slides- deck). I remember opening a report on that to set a minimum and a maximum width for all sidebar decks, but it was rejected.

> 
> If there is a feasible means to adjust the default layout that would permit
> a 16:9 template to appear good
>

You mentioned space issues, but I showed you with screen captures that even with the sidebar open -with the default values- on a small monitor (11'- 1366x768) such space problems don't make a 16:9 page format unusable.

>
>, i'd be more than glad to accept it, but i
> havent seen one.
> 

Currently there is not if there is no agreement on making some changes. 
For example, open the deck contextually and hide it again when you deselect or select another item, or that all the deck doesn't cut the content with the default width, etc.

> 
> Powerpoint doesnt have a sidebar, it has an optional/advanced formatting
> pane, and when the pane appears or is resized, it dynamically shrinks the
> slide pane. Keynote has a fixed size sidebar (270px), while Impress' sidebar
> needs a minimum of 20% more width to appear with non-cropped controls.
> 

I don't see a real problem of lack of space, but if you see it you can't do much if you don't expect to make some changes.

> 
> These apps require you to select a template before you can enter the apps
> and it isnt optional.
> 

Only the first time you open these apps. Then it is totally optional.

> 
> No need for us to go back and forth any more. Lets hear from others who have
> been CCed for their opinions.
>

I'm sorry, but it's always good to take the opportunity to exchange ideas. I respect that you don't agree with the proposed change, but I discuss the arguments you use to defend.

If you don't want to continue defending your point of view, you can refrain from continuing to respond and I doubt that our discussion prevents others from giving their opinion.
Comment 12 Cor Nouws 2017-07-26 09:02:29 UTC
Let's set 16:9 as default yes.
Comment 13 Yousuf Philips (jay) (retired) 2017-07-26 16:46:39 UTC
(In reply to Bastián Díaz from comment #11)
> That is the idea, since 4.4 (Bug 67627) it is possible to open and close
> desks easily from the tab bar.

Didnt follow.

> As I mentioned above, I use the default Impress view (it looks like a bug
> from properties -slides- deck).

Regression bug filed for this issue (bug 109385).

> I remember opening a report on that to set a
> minimum and a maximum width for all sidebar decks, but it was rejected.

Heiko and I have also filed similar bugs about the minimum size that havent been resolved yet, but the maximum width is already a set thing.

> You mentioned space issues, but I showed you with screen captures that even
> with the sidebar open -with the default values- on a small monitor (11'-
> 1366x768) such space problems don't make a 16:9 page format unusable.

Never said it was unusable, only said it was non-optimal because of the space issues as tested on my laptop (1366x768) and desktop (1440x900).

> Currently there is not if there is no agreement on making some changes. 

Seems most UX people are in agreement and i'm the lone hold out.

> For example, open the deck contextually and hide it again when you deselect
> or select another item, or that all the deck doesn't cut the content with
> the default width, etc.

Opening and hiding the deck contextually is bad UX.

> Only the first time you open these apps. Then it is totally optional.

Completely incorrect from my testing of the apps i mentioned.

> I'm sorry, but it's always good to take the opportunity to exchange ideas. I
> respect that you don't agree with the proposed change, but I discuss the
> arguments you use to defend.
> 
> If you don't want to continue defending your point of view, you can refrain
> from continuing to respond and I doubt that our discussion prevents others
> from giving their opinion.

I'll refrain from any more comments and wait for the discussion to be brought to a future design meeting.
Comment 14 Heiko Tietze 2017-08-03 17:00:51 UTC
We talked about the request in the design meeting. After a quick poll on G+ where the majority of >70% voted for the change. Removing UX.
Comment 15 Commit Notification 2017-08-07 12:49:24 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22d5927000a32c54b0ba0355ca9c0999d3b00fb7

tdf#93244 Widescreen format

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Ulrich Windl 2017-12-27 09:41:39 UTC
(In reply to Bastián Díaz from comment #0)
[...]
> designers and users to create new templates for Impres, considering that the
> distribution of objects changes and converting templates 4: 3-16: 9,
> requires many changes.
[...]

Sorry for joining in late, but I feel the correct fix to that would be templates that would work for any aspect proportion (dimension). So maybe the important question would be: Which elements need a change and why? Obviously bitmap backgrounds need a change, but non-scaleable backgrounds seems to be a bad idea anyway.
Also: Why 19:9, and not 16:10, or 19:10? I mean: Using universal templates is preferrable over having fixed (aspect, dimension) ones.
Comment 17 Heiko Tietze 2017-12-27 09:56:53 UTC
(In reply to Ulrich Windl from comment #16)
> ... the correct fix to that would be
> templates that would work for any aspect proportion (dimension).

Sounds like the preferable solution. But it's not only the background image- slide caption may be designed in a certain way, the text boxes could be arranged in multiple columns for wider resolutions etc. The simple stretching works out of the box right now.
Comment 18 Timur 2018-03-20 09:40:48 UTC
In order to verify Bug 116386 I put in See also, please explain this change with paper in mind. 
Impress slide was 280x210 mm (screen 4:3) before (A4/Letter) and 280x157,5 mm after (B5 or ?). 
What's the intended slide size for print and what printers should recognize?