Bug 93327 - Can't open document with webdav(s) url (dav:// or davs://)
Summary: Can't open document with webdav(s) url (dav:// or davs://)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 96069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-10 15:14 UTC by francois.creach
Modified: 2016-02-22 05:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description francois.creach 2015-08-10 15:14:28 UTC
Hello,

Libreoffice don't recognize the webdav(s) protocol when i clic on a link into a browser.
In firefox, the association of ldap and Loo 4.x works but note with Loo 5.x.
The problem is the same when i open a document with is url directly into Loo (file > Open). 

With LOo 4.2.8 a the comportement is the same with the url (the file opens) :
http://192.168.100.235:8080/alfresco/webdav/xxx
or 
dav://192.168.100.255:8080/alfresco/xxx

With LOo 5.0.0.5 the behavior is the same with both url : splash screen appera a few second and nothing else.

This is the same with windows 7 and LOo 32 and windows 10 and LOo 64.

Thanks
Comment 1 Giuseppe Castagno (aka beppec56) 2015-08-25 18:38:15 UTC
François, can you confirm if the Alfresco you are working on has this:

http://addons.alfresco.com/addons/edit-online-libreoffice-openoffice

installed?
Comment 2 francois.creach 2015-08-26 06:53:26 UTC
Hello

No, this plugin is to long to connect, it's use CMIS protocol.

We deployed "zk-online-edition-0.2.jar" (https://code.google.com/p/alfresco-share-online-edition-addon/downloads/list).

It uses the webdav protocol to establish the connection between libreoffice and alfresco.
Comment 3 francois.creach 2015-09-05 08:01:58 UTC
Hello,

The problem is the same with the 5.1.2.
Comment 4 Giuseppe Castagno (aka beppec56) 2015-09-05 14:06:31 UTC
François:

I'am afraid that the dav/davs association with WebDAV protocol does not work in Windows in LO branch 5.0.x.x.

Only http or https work in LO 5.0.x.x

It was removed, since It was not meant to be used for WebDAV direct protocol, but for file system mounted
WebDAV.

See comment of commit:

(1) http://cgit.freedesktop.org/libreoffice/core/commit/?id=51e0d789c344547956764c3b5f0ef5a304f4e0aa

for an exhaustive explanation.

From version 5.1 there will be a new reserved scheme for that: vnd.sun.star.webdav/vnd.sun.star.webdavs for http amd https respectively.

vnd.sun.star.webdav is already working for standard http connection vnd.sun.star.webdavs was added with this commit:

(2) http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3de490437df4c9093f32e97fc185066d64c0f46

this mail thread (pointed to in the comment of commit):

http://lists.freedesktop.org/archives/libreoffice/2015-August/069929.html

sums things up.

Julien:
Added you because you followed the beginning of this, tdf#93225.

I'm not sure if this is a regression or not, from my POV this should be, but I'd defer to you about how to set the BZ since I don't know exactly how this work.
FTTB I set it to new, since it's comfirmed.

Removed tdf#92268 because has nothing to do with this.
Comment 5 Julien Nabet 2015-09-05 15:44:41 UTC
Let's put regression then if it worked before 5.0.

If I'm wrong the keyword can be removed anyway.
Comment 6 francois.creach 2015-09-10 11:21:11 UTC
Hello,
How to know if this change is wanted or if it is a bug?
Thank you !
Comment 7 Cor Nouws 2015-11-25 19:41:18 UTC
feature for in professional environments, regressions IMO should be marked major at the least
Comment 8 Giuseppe Castagno (aka beppec56) 2015-11-26 15:34:39 UTC
*** Bug 96069 has been marked as a duplicate of this bug. ***
Comment 9 Robinson Tryon (qubit) 2015-12-14 05:32:41 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]
Comment 10 Giuseppe Castagno (aka beppec56) 2016-02-16 10:33:59 UTC
Found some time to comment, sorry for the delay.

Since the bug originate in the interaction of LO with an Alfresco external addon, I recently contacted the original addon developer.

The Alfresco addon repository moved from Google code to Github, here you find the instruction:

<https://github.com/CesarCapillas/alfresco-share-online-edition-addon/wiki>

Where it's clearly stated the addon supports only up to LO 4.2.8.2.
See comment 2 for old Google code link.

To add support for 5.1, the developer opened an issue on the problem, here:
<https://github.com/CesarCapillas/alfresco-share-online-edition-addon/issues/6>
and he's working to solve it.
Comment 11 Julien Nabet 2016-02-17 21:15:37 UTC
(In reply to Giuseppe Castagno (aka beppec56) from comment #10)
>...
> Where it's clearly stated the addon supports only up to LO 4.2.8.2.
> See comment 2 for old Google code link.
> ...
So not our bug, addon just needs to evolve.
Comment 12 Giuseppe Castagno (aka beppec56) 2016-02-18 10:24:13 UTC
(In reply to Julien Nabet from comment #11)

> So not our bug, addon just needs to evolve.

Yeah, so I believe, after this:
<http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3de490437df4c9093f32e97fc185066d64c0f46>
On branch 5.1.

Though branch 5.0 won't work, see first lines of comment 4.