Download it now!
Bug 93372 - Format of a table is ignored - character only shown in standard-high
Summary: Format of a table is ignored - character only shown in standard-high
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.3 target:6.0.7
Keywords: bibisected, bisected, regression
: 93185 98521 (view as bug list)
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-08-11 19:49 UTC by Robert Großkopf
Modified: 2018-10-17 08:40 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the database, open the table and have a look at the data in LO 4.* and LO 5.* (3.43 KB, application/vnd.oasis.opendocument.database)
2015-08-11 19:49 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2015-08-11 19:49:37 UTC
Created attachment 117843 [details]
Open the database, open the table and have a look at the data in LO 4.* and LO 5.*

Open the attached database in LO 4.*
Open the table.
The characters are shown bold and and 14pt.

Now open the attached database in LO 5.0.0.5.
Open the table.
The characters are shown in standard format - could not be changed.

The format of text in a table could be changed in all versions up to 5.* by typing with the left mousebutton above the left rowheaders. A context-menue appears for setting this format.
Comment 1 Alex Thurgood 2015-08-13 10:15:58 UTC
Confirming

The bold attributes are ignored in LO 5.0.0.5
They are displayed in LO 4352
Comment 2 Michael Weghorn 2015-08-14 20:54:52 UTC
(bi)bisect result (using the bibisect-50max repository):

c91580d4bd99f5dd42558a725c9b6449874e13ba is the first bad commit
commit c91580d4bd99f5dd42558a725c9b6449874e13ba
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 23:14:15 2015 +0800

    source-hash-b4bbb5e5d7b31caad2fbcc00382ad27df3c81001
    
    commit b4bbb5e5d7b31caad2fbcc00382ad27df3c81001
    Author:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    AuthorDate: Sun May 17 22:56:46 2015 +0900
    Commit:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    CommitDate: Mon May 18 11:22:49 2015 +0900
    
        refactor how font, fg. and bg. are applied in widgets/controls
    
        - Move vcl::RenderContext to outdev.
        - Change some methods on vcl::Window to accept RenderContext
          as parameter.
        - Add ApplySettings to vcl::Window - This method is called before
          painting. Refactor existing classes that use InitSettings to
          have ApplySettings or mark the classes to be refactored later.
        - Add RenderSettings for adding defered settings to rendering.
          This is similar to ApplySettings but for more ad-hoc calls.
    
        Change-Id: I4ea58461f3b6b08ccfa3e0ddd1a4a3e04f8c4f45

:040000 040000 f9a462284415a152e18e911e9958b2b89135554e 67e888db41932c0f3b56f1058daed6a634d45318 M	opt

---

$ git bisect log
# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# good: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect good 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# good: [40875247f0002056effdf6d2fbe43627691cd86c] source-hash-93f0b14458a618ad575cd446680e5c4aa7d87bdc
git bisect good 40875247f0002056effdf6d2fbe43627691cd86c
# skip: [61f66b1a251477193d796411ca95f50d606ead45] source-hash-3fd5f8919ec2256c70ff26c14cb9f8065c5cb2f1
git bisect skip 61f66b1a251477193d796411ca95f50d606ead45
# good: [e7374cd735af2344dae55be40946d96633d2f6ee] source-hash-8a91528a3e03fe6e2923c33327b687ecf57adb0b
git bisect good e7374cd735af2344dae55be40946d96633d2f6ee
# good: [541837707e7b0c5f5335180de535043c43e78e8d] source-hash-0811de12ee6727bbb9d4265217833ba02301eed8
git bisect good 541837707e7b0c5f5335180de535043c43e78e8d
# bad: [ab7dc1f0829167681894eb9f833d7ab348d91669] source-hash-e27ee95cced755e52b62d6cb095bc911ca3fbbe6
git bisect bad ab7dc1f0829167681894eb9f833d7ab348d91669
# good: [fa6b220d5ca96e8d2cbf8a12980ae4074b7a7fa0] source-hash-9bb59aab72d8226e0d31d71e52125b0a9474a30b
git bisect good fa6b220d5ca96e8d2cbf8a12980ae4074b7a7fa0
# good: [1599f87e48a938167cc328c857b384a383bb44bc] source-hash-a76dcdfaa6c6d2b1d73fb1c96fe38dd7e452f48a
git bisect good 1599f87e48a938167cc328c857b384a383bb44bc
# good: [2e616994f8ae0952d540b22204852af60b37b112] source-hash-598f0e26c16f18b6ea03ef1e0e6d7d9dddf6d10f
git bisect good 2e616994f8ae0952d540b22204852af60b37b112
# good: [5ccfb271f131b7ab936d5ee3a0a85ddd1a4b9262] source-hash-773bb53d0b672fbb6b274e45f35228c9427d7fb4
git bisect good 5ccfb271f131b7ab936d5ee3a0a85ddd1a4b9262
# good: [a9df50d9865d334a08ca9b5043c7b730f131f2b9] source-hash-5862ed1851ecc755aa6c49789e00cd920f6a5036
git bisect good a9df50d9865d334a08ca9b5043c7b730f131f2b9
# good: [a203270d19f0e8d7d57286bbdab960f5604d8126] source-hash-2ca7795a6a723c701f295323fcc3f6c52ad37976
git bisect good a203270d19f0e8d7d57286bbdab960f5604d8126
# bad: [c91580d4bd99f5dd42558a725c9b6449874e13ba] source-hash-b4bbb5e5d7b31caad2fbcc00382ad27df3c81001
git bisect bad c91580d4bd99f5dd42558a725c9b6449874e13ba
# first bad commit: [c91580d4bd99f5dd42558a725c9b6449874e13ba] source-hash-b4bbb5e5d7b31caad2fbcc00382ad27df3c81001
Comment 3 Michael Weghorn 2015-08-14 20:55:53 UTC
@Tomaž: Could you possibly have a look at this?
Comment 4 Björn Michaelsen 2015-08-29 08:56:48 UTC
As per comment 2, this seems to be render context related, thus blocking the tracker issue for that.
Comment 5 Michel M 2015-09-27 21:13:39 UTC
I have the same problem in5.0.1.2 and 5.0.2.2 Ok in 4.4
Comment 6 Julien Nabet 2015-09-29 19:09:56 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

During tests, I noticed these logs:
warn:legacy.tools:2777:1:cui/source/tabpages/chardlg.cxx:1442: DocShell not found!
warn:legacy.osl:2777:1:svtools/source/uno/genericunodialog.cxx:323: OGenericUnoDialog::OnDialogDying: where does this come from?
warn:legacy.osl:2777:1:svx/source/fmcomp/fmgridcl.cxx:952: FmGridHeader::PostExecuteColumnContextMenu: no view frame -> no bindings -> no property browser!
Comment 7 Julien Nabet 2015-09-29 19:12:42 UTC
Tomaz: any thoughts about this one + the See Also one?
Comment 8 Lionel Elie Mamane 2015-09-30 05:19:44 UTC
(In reply to Julien Nabet from comment #6)

> warn:legacy.osl:2777:1:svx/source/fmcomp/fmgridcl.cxx:952:
> FmGridHeader::PostExecuteColumnContextMenu: no view frame -> no bindings ->
> no property browser!

this one sounds like it can be related
Comment 9 Robinson Tryon (qubit) 2015-12-13 11:13:02 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2016-09-26 15:09:36 UTC
Adding Cc: to Tomaž Vajngerl
Comment 11 Xisco Faulí 2017-09-29 08:52:43 UTC Comment hidden (obsolete)
Comment 12 Robert Großkopf 2017-09-29 14:02:05 UTC
Bug appears also in LO 5.4.2.1 on OpenSUSE 42.2 64bit rpm Linux.
Comment 13 QA Administrators 2018-09-30 02:48:21 UTC Comment hidden (obsolete)
Comment 14 Robert Großkopf 2018-09-30 06:15:49 UTC
Bug still exist in LO 6.1.1.2 on OpenSUSE 15 64bit rpm Linux.
Comment 15 Julien Nabet 2018-09-30 09:01:46 UTC
On pc Debian x86-64 with master sources updated today, when I right click on left top cell and select "Table Format...", I got a dialog with "Font" and "Font Effects tabs" but those are empty.
By adding some traces, I saw that dialog came from extensions/uiconfig/spropctrlr/ui/controlfontdialog.ui

I also noticed that keyid didn't appear at all except for Reset button.

Caolán: any idea why these dialogs are empty?
Comment 16 Commit Notification 2018-10-03 07:53:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d868e004f62013ba5fcb9595dbe5c3f18d0623b

Related: tdf#93372 pass in parent to base's table format dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-10-03 07:53:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b2bf16f2d7794638e4ca72fc3616330b7b76d0c

Related: tdf#93372 fix up extensions character dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Caolán McNamara 2018-10-03 15:41:29 UTC
In the initial commit where the initial regression takes place, the pattern of ImplInitSettings editbrowsebox.cxx is different to the others in that two different Windows/RenderContext are in play, while in the others its just one Window/RenderContext
Comment 19 Commit Notification 2018-10-03 19:05:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0be3a5eea3089c2b63cc821ffb282fd4ab8ec455

Resolves: tdf#93372 format table in base is ignored

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Caolán McNamara 2018-10-03 19:09:43 UTC
backport to 6-1 in gerrit
Comment 21 Xisco Faulí 2018-10-08 11:19:58 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 4854acc7929ea58632c5d0f7f80a4adc3c62b8cd
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Caolán McNamara, thanks for the quick fix!
Comment 22 Xisco Faulí 2018-10-08 11:27:56 UTC
*** Bug 93185 has been marked as a duplicate of this bug. ***
Comment 23 Xisco Faulí 2018-10-08 11:28:14 UTC
*** Bug 98521 has been marked as a duplicate of this bug. ***
Comment 24 Commit Notification 2018-10-08 11:39:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c523d9556a354e1afac3203b6f1c8b75a2f7d2f0&h=libreoffice-6-1

Resolves: tdf#93372 format table in base is ignored

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2018-10-16 09:03:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e69c24b4f4a8d4bbf1e2e76177e503f1d6d5840&h=libreoffice-6-0

Resolves: tdf#93372 format table in base is ignored

It will be available in 6.0.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2018-10-17 08:22:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=de630044f20b7261a7f8a0b75a3f533653814f3a&h=libreoffice-6-0-7

Resolves: tdf#93372 format table in base is ignored

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Julien Nabet 2018-10-17 08:40:17 UTC
Simplify targets.