Bug 93441 - EDITING: cursor jumps to different horizontal position when moving to a different line with Up / Down
Summary: EDITING: cursor jumps to different horizontal position when moving to a diffe...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: bibisected, bisected, regression
: 112351 119635 139066 (view as bug list)
Depends on:
Blocks: Text-Cursor
  Show dependency treegraph
 
Reported: 2015-08-15 08:19 UTC by Paul Jähne
Modified: 2021-03-18 08:55 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (9.75 KB, application/vnd.oasis.opendocument.text)
2015-08-25 14:22 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Jähne 2015-08-15 08:19:30 UTC
When you add text and move the cursor via the arrow keys a line up or down, the cursor doesn't jump to the corresponding character in the line up or below but rather to the start of edit.

Maybe an example:

We start with this text (cursor is the pipe symbol):
Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.
Lorem ipsum dolor sit amet,|

Now we add text (" consetetur sadipscing elitr.") and the cursor is at the end of the second line:
Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.
Lorem ipsum dolor sit amet, consetetur sadipscing elitr.|

When you press arrow key up, the cursor jumps to the start of the edit rather to the corresponding character in the above line:
                        actual                      expected
                          |                             |
                          v                             v
Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.
Lorem ipsum dolor sit amet, consetetur sadipscing elitr.|
Comment 1 V Stuart Foote 2015-08-17 01:08:31 UTC
Can not confirm on Windows 10 Pro 64-bit en-US with
Version: 5.0.1.1 (x64)
Build ID: 13f702ca819ea5b9f8605782c852d5bb513b3891
Locale: en-US (en_US)

Movement of text cursor with Up or Down moves within the current paragraph to the expected location.
Comment 2 raal 2015-08-25 14:22:15 UTC
Created attachment 118171 [details]
test file

Reproducible with Verze: 5.0.0.5
ID sestavení: 1b1a90865e348b492231e1c451437d7a15bb262b

Steps to reproduce>
open attachment
go to the end of the text with keyboard
write few random words
click twice key up
Comment 3 QA Administrators 2016-09-20 10:26:06 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2019-02-01 20:49:50 UTC
Really weird bug.

Still reproducible with
Version: 6.3.0.0.alpha0+
Build-ID: 51af3179cf972809d6495c7d58033e069f647bbf
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-01_00:15:00
Gebietsschema: de-AT (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 5 Aron Budea 2019-11-17 02:06:04 UTC
Bibisected to the following commit using repo bibisect-44max. Found bug 119635 as a similar issue. (possible dupe?) Adding Cc: to Juergen Funk.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d58bea0ffa2a2fe79103ab7aa743aea63e27a0fd
author		Juergen Funk <juergen.funk_ml@cib.de>	2014-09-17 16:31:20 +0200
committer	Samuel Mehrbrodt <s.mehrbrodt@gmail.com>	2014-09-22 08:01:57 +0000

Fix fdo#38884 Improve Up/Down movement in writer
Comment 6 Telesto 2020-12-19 15:47:14 UTC
*** Bug 139066 has been marked as a duplicate of this bug. ***
Comment 7 V Stuart Foote 2020-12-19 16:21:45 UTC
(In reply to Telesto from comment #6)
> *** Bug 139066 has been marked as a duplicate of this bug. ***

looking at dupe bug 139066, the edit cursor jumps to prior edit's starting x-position with an up/down line change, as here, continues to occur.

Guess the old edit start value needs to be kept for any undo--but the ending text cursor x-position should become the new value for subsequent edit cursor movement.
Comment 8 Telesto 2020-12-19 19:22:21 UTC
*** Bug 119635 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2020-12-19 19:22:47 UTC
*** Bug 112351 has been marked as a duplicate of this bug. ***
Comment 10 Telesto 2020-12-21 08:21:47 UTC
Bumping priority.. to pop it out a little out of ignorance of the ' rules', personal gain, being an old bug.. having a number of duplicates (see also see also bugs, not marked as duplicate..

And the cursor being pretty essential part of a word processor.
Comment 11 Xisco Faulí 2021-03-03 14:28:08 UTC
I guess the easiest way to reproduce this issue is:
1. Open Writer
2. Type 'Hello' + return
3. Type 'Hello World'
4. Press Up key

-> The cart goes to the beginning of the first paragraph. it should go to the end
Comment 12 Commit Notification 2021-03-05 18:45:39 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ee0f845b3d739a6109f08d5c0cd0d839100f6828

tdf#93441: Revert "Fix fdo#38884 Improve Up/Down movement in writer"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2021-03-05 18:50:05 UTC
I've reverted the culprit commit < d58bea0ffa2a2fe79103ab7aa743aea63e27a0fd > in master to see if reintroduced any problem that it fixed.
Closing for now. Please test it
Comment 14 Jim Raykowski 2021-03-14 21:55:09 UTC
verify fixed in:

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 9530bd2fd6ab00a68f593666d2d7f7bd9fc72961
CPU threads: 4; OS: Linux 5.4; UI render: Skia/Raster; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 9530bd2fd6ab00a68f593666d2d7f7bd9fc72961
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 15 Commit Notification 2021-03-18 08:55:53 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/28757ce2246f2598c8ace45f87225eaabbdaf8f0

tdf#93441: Revert "Fix fdo#38884 Improve Up/Down movement in writer"

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.