Download it now!
Bug 93505 - Sidebar: Crash when modifying trend line
Summary: Sidebar: Crash when modifying trend line
Status: RESOLVED DUPLICATE of bug 94931
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-08-18 07:45 UTC by Laurent BP
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2015-08-18 07:45:12 UTC
Description: crash when modifying trend line

Steps to reproduce:
1. Create a XY chart with one series
2. Right click on Data series point > Insert Trend Line, OK
3. Select trend line, right click > Format Trend Line
4. Modify something in dialog (type, checkbox, or Line property)
5. OK

Actual behavior:
crash
Comment 1 Jacques Guilleron 2015-08-18 20:54:14 UTC
Hi Laurent,

I reproduce with LO 5.1.0.0.alpha1+
Build ID: 56050b75941355285911c0293a3c02fc403d0c89
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-13_05:36:16
Only on master?
Comment 2 Julien Nabet 2015-08-19 21:21:31 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Here's some gdb session:
Breakpoint 1, chart::sidebar::ChartSidebarModifyListener::modified (this=0x2d32a10)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/controller/sidebar/ChartSidebarModifyListener.cxx:31
31	    mpParent->updateData();
(gdb) s
chart::sidebar::ChartAreaPanel::updateData (this=0x31bce40) at /home/julien/compile-libreoffice/libreoffice/chart2/source/controller/sidebar/ChartAreaPanel.cxx:369
369	{
(gdb) n
370	    if (!mbUpdate || !mbModelValid)
(gdb) 
373	    css::uno::Reference<css::beans::XPropertySet> xPropSet = getPropSet(mxModel);
(gdb) 
374	    if (!xPropSet.is())
(gdb) 
377	    css::drawing::FillStyle eFillStyle = css::drawing::FillStyle_SOLID;
(gdb) 
378	    xPropSet->getPropertyValue("FillStyle") >>= eFillStyle;
(gdb) 
terminate called after throwing an instance of 'com::sun::star::beans::UnknownPropertyException'
Comment 3 Julien Nabet 2015-08-20 05:24:33 UTC
Markus: one for you? (noticing your last commits on this area)
Comment 4 Laurent BP 2015-08-20 07:12:16 UTC
Resolution of bug 93506 did not fixed this one.
Comment 5 Julien Nabet 2015-08-20 07:35:02 UTC
(In reply to Laurent BP from comment #4)
> Resolution of bug 93506 did not fixed this one.
Yep, I had put it in "See Also" because it was the same domain but indeed, the unknown property problem couldn't be fixed with Caolan's commit for tdf#93506.
Comment 6 Matthew Francis 2015-08-20 09:22:33 UTC
This specifically seems to have started at the below commit.

commit b3a52304593328b8950602535ef03d026ee27bf0
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Thu Jul 23 21:00:37 2015 +0200

    update some area properties
Comment 7 Julien Nabet 2015-08-22 12:35:49 UTC
warn:sfx.sidebar:2567:1:sfx2/source/sidebar/SidebarController.cxx:819: Cannot create panel private:resource/toolpanel/ChartPanelFactory/CharacterPanel: unsatisfied query for interface of type com.sun.star.ui.XUIElement!
warn:sfx.sidebar:2567:1:sfx2/source/sidebar/SidebarController.cxx:819: Cannot create panel private:resource/toolpanel/ChartPanelFactory/CharacterPanel: unsatisfied query for interface of type com.sun.star.ui.XUIElement!
warn:sfx.sidebar:2567:1:sfx2/source/sidebar/SidebarController.cxx:819: Cannot create panel private:resource/toolpanel/ChartPanelFactory/AreaPanel: ChartPanelFactory::createUIElement exception
warn:sfx.sidebar:2567:1:sfx2/source/sidebar/SidebarController.cxx:819: Cannot create panel private:resource/toolpanel/ChartPanelFactory/CharacterPanel: unsatisfied query for interface of type com.sun.star.ui.XUIElement!
[New Thread 0x2aaad95a0700 (LWP 2790)]

Program received signal SIGSEGV, Segmentation fault.
0x00002aaae14950d1 in chart::sidebar::ChartSidebarModifyListener::modified (this=0x31ebbf0)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/controller/sidebar/ChartSidebarModifyListener.cxx:31
31	    mpParent->updateData();
(gdb) bt
#0  0x00002aaae14950d1 in chart::sidebar::ChartSidebarModifyListener::modified(com::sun::star::lang::EventObject const&) (this=0x31ebbf0)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/controller/sidebar/ChartSidebarModifyListener.cxx:31
#1  0x00002aaae0b2284a in chart::ChartModel::impl_notifyModifiedListeners() (this=0x71226e0)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/model/main/ChartModel_Persistence.cxx:676
#2  0x00002aaae0b0ef61 in chart::ChartModel::unlockControllers() (this=0x71226e0) at /home/julien/compile-libreoffice/libreoffice/chart2/source/model/main/ChartModel.cxx:476
#3  0x00002aaae0bd4c9f in chart::ControllerLockGuardUNO::~ControllerLockGuardUNO() (this=0x7fffffff37c0, __in_chrg=<optimized out>)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/tools/ControllerLockGuard.cxx:39
#4  0x00002aaae1425c1c in chart::ChartController::execute_MouseButtonUp(MouseEvent const&) (this=0x334ca60, rMEvt=...)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/controller/main/ChartController_Window.cxx:891
#5  0x00002aaae14380ee in chart::ChartWindow::MouseButtonUp(MouseEvent const&) (this=0x72d9950, rMEvt=...)
    at /home/julien/compile-libreoffice/libreoffice/chart2/source/controller/main/ChartWindow.cxx:154
#6  0x00002aaab1b3f4da in ImplHandleMouseEvent(vcl::Window*, MouseNotifyEvent, bool, long, long, unsigned long, unsigned short, MouseEventModifiers) (pWindow=0x26fc790, nSVEvent=MOUSEBUTTONUP, bMouseLeave=false, nX=351, nY=310, nMsgTime=4104980, nCode=1, nMode=(SIMPLECLICK | SELECT))
    at /home/julien/compile-libreoffice/libreoffice/vcl/source/window/winproc.cxx:739
Comment 8 Laurent BP 2015-08-29 16:00:33 UTC
With Version: 5.1.0.0.alpha1+
Build ID: b2363e98af7b0281279617e43b8fec5b898b9120
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-26_00:57:35
Locale: fr-FR (fr_FR.UTF-8)
crash still exists, but recovery of document is proposed.
Comment 9 Laurent BP 2015-08-29 16:38:24 UTC
Workaround: disable View > Sidebar

Add "Sidebar" to summary

It seems that Area property is requested for trend line, but there is no such property. I noticed that in Sidebar, when selecting a series, Area property is enable and corresponds to Line color of the series. Modifying line color of a series has no effect. Area property should be removed from data series as well as from trend line.
Comment 10 Markus Mohrhard 2015-09-04 01:31:37 UTC
(In reply to Laurent BP from comment #9)
> Workaround: disable View > Sidebar
> 
> Add "Sidebar" to summary
> 
> It seems that Area property is requested for trend line, but there is no
> such property. I noticed that in Sidebar, when selecting a series, Area
> property is enable and corresponds to Line color of the series. Modifying
> line color of a series has no effect. Area property should be removed from
> data series as well as from trend line.

I'll fix that with another round of crashes in a bit.

The Area panel wills tay for data series as they provide the FillProperties. They are just not used in the rendering of some chart types but are still available and are actually available through the API.
Comment 11 Laurent BP 2015-09-04 08:49:10 UTC
(In reply to Markus Mohrhard (retired) from comment #10)
> The Area panel will stay for data series as they provide the FillProperties.
> They are just not used in the rendering of some chart types but are still
> available and are actually available through the API.
Sorry, I was just focusing on XY scatter diagram, and I forgot that many other diagrams are using Area properties.
Comment 12 Markus Mohrhard 2015-10-12 11:34:22 UTC

*** This bug has been marked as a duplicate of bug 94931 ***
Comment 13 Robinson Tryon (qubit) 2015-12-15 11:03:41 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]