Download it now!
Bug 93555 - Navigator pane does not show location of cursor in editing window
Summary: Navigator pane does not show location of cursor in editing window
Status: RESOLVED DUPLICATE of bug 108766
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2015-08-21 03:02 UTC by GM
Modified: 2017-10-16 08:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A short .odt with Heading 2 style on chapter titles, Text Body style for body copy. (24.16 KB, application/vnd.oasis.opendocument.text)
2015-08-21 23:30 UTC, GM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description GM 2015-08-21 03:02:49 UTC
I have a book divided in chapters--default text for the body, chapter titles set as heading 2. I can double-click on the heading/chapter title in the navigator pane to go to that chapter, but if I edit ahead into another chapter, the navigation pane does not show that I am further on past another heading. ie: I'm editing chapter one, scroll down and edit some text in chapter three, but the navigator still shows chapter one.

I was using LibreOffice 4.3.2 on a Mac, and wherever the cursor was in the book, the appropriate heading/chapter title in the navigator pane would highlight, and I could tell where I was.
Comment 1 GM 2015-08-21 16:42:18 UTC
I've since found that the behavior difference between the Mac version and the Linux version is the Content View button setting. The Mac was set to hide the other categories, the Linux to show all.

On both platforms, the headings list responds to the cursor position in the document when the Content View button is set to show only the selected category. It doesn't report the position when the button is set to show all categories.
Comment 2 Joel Madero 2015-08-21 20:30:45 UTC
Hi GM -

We need some kind of simple document to test this on. I understand the book is probably confidential and it's far too complex for us to use as a sample test case. Please create a new test case (as simple as possible), attach it to the bug, and then set the bug to UNCONFIRMED. Thanks
Comment 3 GM 2015-08-21 23:30:13 UTC
Created attachment 118081 [details]
A short .odt with Heading 2 style on chapter titles, Text Body style for body copy.
Comment 4 GM 2015-08-21 23:33:54 UTC
I uploaded a short .odt with Heading 2 style for chapter titles and Text Body style for the body copy.
Comment 5 Buovjaga 2015-09-09 14:57:28 UTC
(In reply to GM from comment #1)
> I've since found that the behavior difference between the Mac version and
> the Linux version is the Content View button setting. The Mac was set to
> hide the other categories, the Linux to show all.
> 
> On both platforms, the headings list responds to the cursor position in the
> document when the Content View button is set to show only the selected
> category. It doesn't report the position when the button is set to show all
> categories.

Confirmed with your document.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 6 QA Administrators 2016-09-20 10:29:26 UTC Comment hidden (obsolete)
Comment 7 GM 2016-09-20 16:51:33 UTC
Bug tested and found still present with LibreOffice 5.1.5 on Linux Mint 17.3 64
Comment 8 Xisco Faulí 2017-09-29 08:52:53 UTC Comment hidden (obsolete)
Comment 9 GM 2017-09-29 21:38:47 UTC
Bug tested and found still present with LibreOffice 5.3.6.1 on Linux Mint 18.2 Cinnamon 64-bit
Comment 10 Jim Raykowski 2017-10-01 23:19:04 UTC
Tested using GM's attached test document and found that as each chapter is encountered it is selected in the Navigator and does not unselect the previously selected chapter so when all chapters are moved through all chapters are selected in the Navigator. Is this new behavior to this bug?

Version: 6.0.0.0.alpha0+
Build ID: c7983a1fe9327e3d33c88ee0cfd33694daefc392
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 11 Jim Raykowski 2017-10-15 22:41:04 UTC
The source indicates the cursor position is only tracked for Headings when in Headings single category view. No bug was found causing Headings not to be tracked by Navigator when in all categories view. 

I will open a new bug concerning my previous comment.
Comment 12 Heiko Tietze 2017-10-16 08:25:47 UTC
I make this ticket a duplicate of the later bug 108766 since the other is easier to understand. Well spotted, Jim.

*** This bug has been marked as a duplicate of bug 108766 ***