Download it now!
Bug 93585 - Calc: Graph save as image EPS segmentation fault
Summary: Calc: Graph save as image EPS segmentation fault
Status: RESOLVED DUPLICATE of bug 91782
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-08-22 03:20 UTC by Doug
Modified: 2015-12-17 10:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice --backtrace of crash from saving graph as EPS (8.61 KB, text/plain)
2015-08-22 03:20 UTC, Doug
Details
demo calc spreadsheet with graph (12.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-22 03:21 UTC, Doug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doug 2015-08-22 03:20:52 UTC
Created attachment 118082 [details]
libreoffice --backtrace of crash from saving graph as EPS

On Windows 7 LO 5.0.5 and Linux OpenSuse 13.2 KDE 5 LO 5.0.1.1:

1.  Create graph in calc.
2.  Right mouse click on graph, select "Export As Image"
3.  Select format "EPS - Encapsulated PostScript"
4.  Choose name and save.

RESULT:  Segmentation fault, crash on both Linux and Windows systems.  Backtrace on Linux machine provided.
Comment 1 Doug 2015-08-22 03:21:49 UTC
Created attachment 118083 [details]
demo calc spreadsheet with graph

follow steps to reproduce using this spreadsheet.
Comment 2 Joel Madero 2015-08-22 04:50:08 UTC
Confirmed:

Ubuntu 15.04 x64
LibreOffice 5.0.0.5

Setting as:
NEW
Major - crash;
High - default for crashes
Comment 3 Joel Madero 2015-08-22 04:51:52 UTC
regression - works fine in 4.5
Comment 4 MM 2015-08-22 08:26:20 UTC
Try a newer version. The problem (eps filter) should have been fixed with 5.0.1.1 and higher.

https://bugs.documentfoundation.org/show_bug.cgi?id=91782
Comment 5 Julien Nabet 2015-08-22 09:27:35 UTC
If you still reproduce this with prerelease 5.0.1 (see https://www.libreoffice.org/download/pre-releases/), please don't hesitate to reopen this one.

*** This bug has been marked as a duplicate of bug 91782 ***
Comment 6 V Stuart Foote 2015-08-22 12:33:20 UTC
(In reply to Julien Nabet from comment #5)
> If you still reproduce this with prerelease 5.0.1 (see
> https://www.libreoffice.org/download/pre-releases/), please don't hesitate
> to reopen this one.
> 
> *** This bug has been marked as a duplicate of bug 91782 ***

Crasher present through 5.0.1.1 aka RC1 build; will be included in 5.0.1.2 RC2 release build--or a TinderBox nightly before then.
Comment 7 Robinson Tryon (qubit) 2015-12-17 10:31:19 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]