Bug 93594 - Mail Merge Writer Document to individual documents in PDF format does not increment to next record data
Summary: Mail Merge Writer Document to individual documents in PDF format does not inc...
Status: RESOLVED DUPLICATE of bug 93565
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2015-08-22 17:45 UTC by Beck Greene
Modified: 2016-01-05 13:37 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Two pdf documents from Mail Merge and Spreadsheet with data (50.38 KB, application/zip)
2015-08-22 17:45 UTC, Beck Greene
Details
Writer file and spreadsheet (107.39 KB, application/zip)
2015-08-24 13:24 UTC, Beck Greene
Details
Corresponding ODB file linking to Calc sheet (2.12 KB, application/vnd.oasis.opendocument.database)
2015-08-24 14:06 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Beck Greene 2015-08-22 17:45:53 UTC
Created attachment 118093 [details]
Two pdf documents from Mail Merge and Spreadsheet with data

LO 5.0.0.5 Mac OSX 10.10.5

Mail Merge with Writer document.

1. Print 
2. Dialog: Your document contains... - choose yes
3. Mail Merge Dialog 
 Records: choose All
 Output: Choose File, Save as Individual Documents, Check Generate File Name..., Field: Name, Path: Valid path on computer, File format: PDF...
 Click OK
4. Documents are created in the specified folder
5. All Documents are populated with the data from the first record, 2 examples attached.

Note: ODT, DOC, TXT, RTF formats work as expected with Mail Merge.
Comment 1 Alex Thurgood 2015-08-24 06:57:05 UTC
@Beck : please provide the Writer document you are using as the basis for the merge, the archive only contains the Calc file and two output PDF files
Comment 2 Beck Greene 2015-08-24 13:24:43 UTC
Created attachment 118116 [details]
Writer file and spreadsheet
Comment 3 Alex Thurgood 2015-08-24 14:04:08 UTC
Confirming

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale : fr-FR (fr.UTF-8)

OSX 10.10.5
Comment 4 Alex Thurgood 2015-08-24 14:05:56 UTC
In the end I also had to create an ODB file to host the Calc document, and then assign it to the Writer document. Added as attachment.
Comment 5 Alex Thurgood 2015-08-24 14:06:29 UTC
Created attachment 118119 [details]
Corresponding ODB file linking to Calc sheet
Comment 6 Beck Greene 2015-08-24 16:11:16 UTC
I did that. Where you able to mail merge to pdf format?
Comment 7 Alex Thurgood 2015-08-24 16:53:55 UTC
(In reply to Beck Greene from comment #6)
> I did that. Where you able to mail merge to pdf format?

Yes, as I mentioned in comment 3, I confirmed the buggy behaviour, and set the report to CONFIRMED. Now it is up to any developer who happens to have the time and inclination in trying to fix it (or not, as the case may be, depending on how hard it might be to fix).
Comment 8 Alex Thurgood 2015-08-24 16:57:34 UTC
This works correctly in 

Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

==>> regression
Comment 9 Alex Thurgood 2015-08-24 17:01:33 UTC
Also works correctly in

Versio : 4.2.4.2
Version: 4.3.5.2
Comment 10 Beck Greene 2015-08-24 18:49:37 UTC
Copy that! I missed the confirmation. Thank you.
Comment 11 raal 2015-08-24 21:34:06 UTC
is it duplicate of bug 93565?
Comment 12 Beck Greene 2015-08-24 21:38:50 UTC
Yes, looks like a duplicate of 93565. Thanks.
Comment 13 raal 2015-08-25 04:31:52 UTC

*** This bug has been marked as a duplicate of bug 93565 ***
Comment 14 Robinson Tryon (qubit) 2015-12-17 10:31:27 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]
Comment 15 Cor Nouws 2016-01-05 13:37:36 UTC
(In reply to raal from comment #13)
> 
> *** This bug has been marked as a duplicate of bug 93565 ***

please mind the summary :)