Download it now!
Bug 93565 - MAILMERGE: Mail merge doesn't work with version 5.0 (individual documents in PDF format does not increment to next record data)
Summary: MAILMERGE: Mail merge doesn't work with version 5.0 (individual documents in ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.0.2 target:5.0.5
Keywords: bibisected, bisected, regression
: 93594 96907 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-21 08:06 UTC by a.grilli
Modified: 2016-09-13 06:48 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
sample documents (1 of 2 - writer) (13.44 KB, application/vnd.oasis.opendocument.text)
2015-08-24 13:09 UTC, a.grilli
Details
sample documents (2 of 2 - spreadsheet) (18.90 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-24 13:09 UTC, a.grilli
Details
The merged document as ODT (16.86 KB, application/vnd.oasis.opendocument.text)
2016-02-03 11:36 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.grilli 2015-08-21 08:06:44 UTC
Good morning

Since the first 5.0 version, the Mail merge in writer doesn't work correctly anymore.

If i merge more than one record, all the generated files repeat the same data of the first record.

Thanks
Comment 1 raal 2015-08-24 12:43:22 UTC
I can not confirm with Verze: 5.0.0.5
ID sestavení: 1b1a90865e348b492231e1c451437d7a15bb262b
Please send us a sample document, as this makes it easier for us to verify the bug and provide step-by-step instructions how to reproduce the bug. Thank you
Comment 2 a.grilli 2015-08-24 13:09:41 UTC
Created attachment 118114 [details]
sample documents (1 of 2 - writer)

Last time I tried by:
File - Print
from 1 to 4 - file - save as individual documents - file name from database "NOMINATIVO" - file format: PDF
Comment 3 a.grilli 2015-08-24 13:09:47 UTC
Created attachment 118115 [details]
sample documents (2 of 2 - spreadsheet)
Comment 4 raal 2015-08-24 14:02:46 UTC
Reproducible with Verze: 5.0.0.5
ID sestavení: 1b1a90865e348b492231e1c451437d7a15bb262b

File - Print
from 1 to 4 - file - save as individual documents - file name from database "NOMINATIVO" - file format: PDF
 -> creates 42 files, but in every file is name = Name1

When I print to printer or to "one .odt file", then names are correctly changing.
Comment 5 raal 2015-08-25 04:31:52 UTC
*** Bug 93594 has been marked as a duplicate of this bug. ***
Comment 6 Michael Weghorn 2015-08-25 18:05:19 UTC
(In reply to raal from comment #4)
> Reproducible with Verze: 5.0.0.5
> ID sestavení: 1b1a90865e348b492231e1c451437d7a15bb262b
> 
> File - Print
> from 1 to 4 - file - save as individual documents - file name from database
> "NOMINATIVO" - file format: PDF
>  -> creates 42 files, but in every file is name = Name1
> 
> When I print to printer or to "one .odt file", then names are correctly
> changing.

It also works OK when "printing" to individual odt files. Printing to single PDF files fails.

It is also reproducible on amd64 (Debian Jessie) - setting respective field.
Comment 7 Michael Weghorn 2015-08-25 18:28:36 UTC
(bi)bisect result:

6cc283270df0b0586a23f91701450110ec7ed834 is the first bad commit
commit 6cc283270df0b0586a23f91701450110ec7ed834
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 19:58:10 2015 +0800

    source-hash-356d93766e27337a5463e793ceeb9da757a3a37f
    
    commit 356d93766e27337a5463e793ceeb9da757a3a37f
    Author:     Luboš Luňák <l.lunak@collabora.com>
    AuthorDate: Sun Feb 15 22:53:57 2015 +0100
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Wed Mar 11 16:21:42 2015 +0100
    
        avoid creating temporary document copies in non-singlefile MM mode
    
        The singlefile mode needs a new copy for every record, because it modifies
        it (such as changing fields to text), but the non-singlefile mode does not
        need all that relatively expensive work, because it just updates the fields
        and nothing else.
    
        Conflicts:
        	sw/source/uibase/dbui/dbmgr.cxx
    
        Change-Id: If02cf8aca1d0f050ffb63cd85d5a9455afc5a6ea

:040000 040000 48a2d6882bbefa38118e41a51ff8c12441b6ea83 12c0fdffadb5a94fa319abebb231392d830e9845 M	opt


$ git bisect log
# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# bad: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect bad 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# bad: [e4deb8a42948865b7b23d447c1547033cb54535b] source-hash-ce46c98dbeb3364684843daa5b269c74fce2af64
git bisect bad e4deb8a42948865b7b23d447c1547033cb54535b
# bad: [15e8b5cc6b4784fecd63b2a5a04ac086b3e9fc01] source-hash-26b500afcaed704db7a300836f466517c309ee77
git bisect bad 15e8b5cc6b4784fecd63b2a5a04ac086b3e9fc01
# good: [534715525a93b0d7d56ba123d253c927cccf0afe] source-hash-40c9a46b78b8919aae82dd9b94774d63bb9cb4e6
git bisect good 534715525a93b0d7d56ba123d253c927cccf0afe
# good: [9aac2d2b68f538e8e24f6c4fed5b9170ba938b60] source-hash-82c37453482e6b8bd6ab7b7e96b1257a1d5b0699
git bisect good 9aac2d2b68f538e8e24f6c4fed5b9170ba938b60
# bad: [eb45492ed52bea38d7fc71a4d1cd8808231c2fd0] source-hash-888c28dd07ad97454231e0ff7e976f311b39e40c
git bisect bad eb45492ed52bea38d7fc71a4d1cd8808231c2fd0
# bad: [c0c33bfc27520a3b03ab910f4ad6cce30bcc0190] source-hash-d5c93cccaebf92b7f99e174552a7c84a5c652690
git bisect bad c0c33bfc27520a3b03ab910f4ad6cce30bcc0190
# good: [5eaea7f1ebf8d0be2b744f51f0bd64f480eff192] source-hash-50d961ebf107bfd3e3a557c4da75bfec2a463408
git bisect good 5eaea7f1ebf8d0be2b744f51f0bd64f480eff192
# good: [c8c9b07400f62974cf714c2b9ed248219dd7910c] source-hash-58a48aceb289d4d9ccef4f8652d2a41a567e23e9
git bisect good c8c9b07400f62974cf714c2b9ed248219dd7910c
# bad: [6cc283270df0b0586a23f91701450110ec7ed834] source-hash-356d93766e27337a5463e793ceeb9da757a3a37f
git bisect bad 6cc283270df0b0586a23f91701450110ec7ed834
# good: [d04de9ad56ac4b5f8d56f6e8d496d102e76215b2] source-hash-b2f5850ba2a51635290fd74ed5b4ed2607530d42
git bisect good d04de9ad56ac4b5f8d56f6e8d496d102e76215b2
# good: [8934926195ff0d97c02bf7b72353a5462ab9e41c] source-hash-d753dde3a701eba0fdfadb393c6380389246f0eb
git bisect good 8934926195ff0d97c02bf7b72353a5462ab9e41c
# first bad commit: [6cc283270df0b0586a23f91701450110ec7ed834] source-hash-356d93766e27337a5463e793ceeb9da757a3a37f
Comment 8 Michael Weghorn 2015-08-25 18:30:54 UTC
@Luboš: Could you possibly have a look at this?
Comment 9 Björn Michaelsen 2015-08-31 08:40:02 UTC
Possibly related to other mailmerge regression in 5.0: tdf#93719
Comment 10 Robinson Tryon (qubit) 2015-12-13 11:13:02 UTC Comment hidden (obsolete)
Comment 11 Cor Nouws 2016-01-05 13:40:22 UTC
*** Bug 96907 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2016-01-05 21:49:23 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d7e0d0135ba65243fab5ee038c21290b8e74e548

tdf#93565 Use multiple docs for individual PDF MM

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-01-07 14:14:41 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dcae0a5dba5aadc1e89828518102947f749db10e&h=libreoffice-5-1

tdf#93565 Use multiple docs for individual PDF MM

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 a.grilli 2016-01-13 07:52:29 UTC
Hello

I tested yesterday's patch 
libreoffice-5-1~2016-01-12_11.37.42_LibreOfficeDev_5.1.0.1.0_Win_x86_en-US_de_ar_ja_ru_qtz.msi

and it works perfectly.

I tested it saving as individual documents in PDF format all my records, then the first five records and finally a random selected record; no problems.

Thanks!

Alberto
Comment 15 Commit Notification 2016-01-19 08:27:07 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d03d6dea84f8c0c9a83031b646e242df7ea5678&h=libreoffice-5-0

tdf#93565 Use multiple docs for individual PDF MM

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Jan-Marek Glogowski 2016-02-03 11:36:30 UTC
Created attachment 122351 [details]
The merged document as ODT

Just as a reference, as I use it for testing ;-)