Download it now!
Bug 93599 - Personalization and themes
Summary: Personalization and themes
Status: RESOLVED DUPLICATE of bug 99776
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2015-08-23 16:06 UTC by Heiko Tietze
Modified: 2018-04-10 09:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Dialog after search for plain themes, selection of the middle theme from the bottom, and finalizing per okay. (70.58 KB, image/png)
2015-08-23 16:06 UTC, Heiko Tietze
Details
LibreOffice: Managing Your In-House Personas (370.41 KB, application/vnd.oasis.opendocument.text)
2016-09-20 17:14 UTC, Peter Maunder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2015-08-23 16:06:27 UTC
Created attachment 118101 [details]
Dialog after search for plain themes, selection of the middle theme from the bottom, and finalizing per okay.

By default LO comes with some gradient, which does not fit my design in Breeze Dark (resp. Breeze-gtk). Options > Personalization is set to "Default look, do not use Themes" but the right side is bright and left dark. (That's the first bug, IMHO.)

So I tried to change it and wanted to select another theme. This dialog shows nothing unless I search. I'd assess this as another bug but maybe its by design. But when I searach for 'plain' and select one of the resulting themes and want to apply it per okay the dialog shows the complete URL without any ellipsis. Luckily my resolution is high enough.

How to solve: 
1. Ensure the default is the default.
2. Make the 'pre-installed' option a way to select something from the local drive (or get rid of this).
3a. Prefil the themes dialog and make the search a filter. 
3b. Speed up the processing/communication or whatever; the dialog must be filled with items - otherwise show an indicator for proecssing
3c. Error messages shouldn't be part of the UI; use ellipsis or line breaks in case of long text

Personally, I wouldn't implement Mozilla Persona like features at all. Office suits are not intended to be entertaining. But obviously there was a request for this feature, or not?
Comment 1 Peter Maunder 2015-08-24 09:31:47 UTC
I am an enthusiastic user of Personas as it allows us to add a personal touch to the system whether a "business house style" of to make the system more friendly for the casual user. 

Ideally the Firefox / Thunderbird Personas Plus add-on shows what could be done. I use it to test out and choose Personas that I create offline before installing them on LibO. Failing that, a simple way to set up a default Personas would be a great improvement.  Personas are discussed in 86544 and 59611 amongst others..Peter
Comment 2 Heiko Tietze 2015-08-24 09:49:21 UTC
(In reply to Peter Maunder from comment #1)
> I am an enthusiastic user of Personas...

Thanks for adding this. So ignore my last comment as a personal opinion.
Comment 3 Peter Maunder 2015-08-24 10:58:13 UTC
(In reply to Heiko Tietze from comment #2)
> (In reply to Peter Maunder from comment #1)
> > I am an enthusiastic user of Personas...
> 
> Thanks for adding this. So ignore my last comment as a personal opinion.

I think your Description is important and useful. The current Personalization screen seems rather clumsy, complicated and slow and makes it difficult to take advantage of the Personas. This makes it difficult to casually add this little "friendly marketing touch" to the look of a screen. My users are older than average and sometimes a little wary of impersonal computer screens. 

I agree though, many people have no interest in changing the look of their screens...
Comment 4 Buovjaga 2015-09-12 12:38:21 UTC
Effectively confirmed by Peter, so setting to NEW.
Comment 5 QA Administrators 2016-09-20 10:32:49 UTC Comment hidden (obsolete)
Comment 6 Peter Maunder 2016-09-20 17:14:41 UTC
Created attachment 127480 [details]
LibreOffice:  Managing Your In-House Personas
Comment 7 Cor Nouws 2016-09-20 17:25:35 UTC Comment hidden (obsolete)
Comment 8 Cor Nouws 2016-09-20 17:26:17 UTC
(In reply to Peter Maunder from comment #6)
> Created attachment 127480 [details]
> LibreOffice:  Managing Your In-House Personas

Thanks Peter!
Do you have a blog or other place to publish about this :) ?
Comment 9 Peter Maunder 2016-09-21 15:52:50 UTC
No, I am afraid I don't have a blog. I guess we really hoped that this basic type of function would have been incorporated in the Personalization function, just like Firefox Personas Plus. With Firefox any user can manage their own In-House personas. My solution is too complicated for the casual user, and I think would not be suitable to include in the standard documentation. I guess others would also need to check that it is applicable to other platforms and language sets...

I put this document on this bug as I did not know where also to place it. 

There have been a number of questions, for example on ask.libreoffice.org about the use of ones own theme. Or USE PRE-INSTALLED THEME, if available. Something I have never  managed to get to work with my themes.
Comment 10 Xisco Faulí 2017-09-29 08:52:28 UTC Comment hidden (obsolete)
Comment 11 Peter Maunder 2017-10-03 16:21:12 UTC
Still applies to LibO 5.4.1.2
Comment 12 Peter Maunder 2017-10-19 14:14:07 UTC
Still applies to 6.0.0.0.alpha0
Comment 13 Heiko Tietze 2018-04-10 09:21:47 UTC
This issue is the same as in 99776. There is no preselection for categories because of slow access. So let's continue in the other issue.

*** This bug has been marked as a duplicate of bug 99776 ***