Bug Hunting Session
Bug 93643 - Header appears on page that shouldn't have header
Summary: Header appears on page that shouldn't have header
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Limitations DOCX-Header-Footer
  Show dependency treegraph
 
Reported: 2015-08-25 00:33 UTC by Matthew Holloway
Modified: 2018-02-21 09:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Source document (283.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-08-25 00:33 UTC, Matthew Holloway
Details
msword rendering of document (58.74 KB, image/png)
2015-08-25 00:35 UTC, Matthew Holloway
Details
Rendering in LibreOffice 5.0.0.5 (210.06 KB, application/pdf)
2015-08-25 00:35 UTC, Matthew Holloway
Details
The example file opened in LO 5.3.3 (126.42 KB, image/png)
2018-02-21 09:28 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Holloway 2015-08-25 00:33:22 UTC
Created attachment 118154 [details]
Source document

In the attached document on page 2 a page header appears that is not present in MSWord.
Comment 1 Matthew Holloway 2015-08-25 00:35:36 UTC
Created attachment 118155 [details]
msword rendering of document
Comment 2 Matthew Holloway 2015-08-25 00:35:55 UTC
Created attachment 118156 [details]
Rendering in LibreOffice 5.0.0.5
Comment 3 Joel Madero 2015-08-25 03:45:05 UTC
Probably something to do with styles. I wouldn't be horribly surprised if this is a duplicate but:

Confirmed:
Ubuntu 15.04 x64
LibreOffice 5.0.0.4


Setting as:
NEW
Normal - can prevent high quality work. This could technically be a minor bug because there is the ability to "reset" the object but if someone sends you a document it's very hard to collaborate as objects are not maintained in the correct place;
Medium - default

@Matthew - if possibly it would be great to determine if this is a regression. Our team isn't big enough to test every bug to determine if they are regressions but if it is a regression there are additional things we can do to track down the cause. Older versions can be found here: http://downloadarchive.documentfoundation.org/libreoffice/old/

Note that version is the oldest version confirmed on - so if you confirm it on an older version please update the version field. Thanks!
Comment 4 Matthew Holloway 2015-08-26 05:06:24 UTC
Doesn't appear to be a regression.

The correct behaviour is to show a header on the first page but not the second page.

LibreOffice 3.3.0.4 doesn't show a header on the first or second page, and then 3.5.0.3 shows a header on both pages.

Will investigate further tomorrow.
Comment 5 Matthew Holloway 2015-08-27 00:00:31 UTC
Not a regression. It was always buggy.

3.4.6.2 doesn't have header
3.5.0.3 does have header but it's duplicated, and it remains unchanged until current versions (at least 5.0.0.5)
Comment 6 Matthew Holloway 2015-08-27 01:25:29 UTC
Notes from a tester,

"In this case the headers are linked (the header for section 2 (p.2) is “same as previous” – Word 2010 = Linked to previous), which would normally replicate their content. Somehow the author has managed to vanish the image for the (p.2) even header while retaining it in the (p.1) odd header "

I don't have Microsoft Office so I haven't been able to confirm this.
Comment 7 QA Administrators 2016-09-20 10:25:42 UTC Comment hidden (obsolete)
Comment 8 Gabor Kelemen 2018-02-21 09:28:35 UTC
Created attachment 140032 [details]
The example file opened in LO 5.3.3

Seems that the second page does not have an extra header anymore.