Bug Hunting Session
Bug 93670 - Limited out of the box font effects (to Fontwork Gallery)
Summary: Limited out of the box font effects (to Fontwork Gallery)
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: DTP
  Show dependency treegraph
 
Reported: 2015-08-25 23:50 UTC by Neo
Modified: 2017-01-02 15:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of stylezed text from PowerPoint 2010 (828.95 KB, image/png)
2015-08-25 23:50 UTC, Neo
Details
Example of PPT 2010 text transform capabilities (652.66 KB, image/png)
2016-02-01 03:13 UTC, Neo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neo 2015-08-25 23:50:10 UTC
Created attachment 118181 [details]
Example of stylezed text from PowerPoint 2010

I use PowerPoint to create highly stylized text that includes chrome effects, bevels, soft shadows, styled character outlines, 3D effects, and so on.  I've tried LibreOffice and it just doesn't have the same graphic capability for effects as MS Office 2010.  Specifically, I use PowerPoint 2010.  I absolutely love LibreOffice and would love to completely switch away from MS Office but the advanced graphic graphic capabilities of PowerPoint would absolutely be necessary.

Additionally, I export selected graphics to PNG files at high resolution (300 dpi and higher) for use in other publishing programs such as Scribus.

I've included an example of some text outputs that I made for a recent project.  They are not the best but they do begin to give an idea of what I'm getting out of PowerPoint 2010.  Please do not hesitate to contact me further if you need more inputs.

Neo
Comment 1 Joel Madero 2015-08-26 01:50:00 UTC
Is this just WordArt? 

If so this is likely a duplicate of one of the other open issues regarding WordArt. 

Please let us know - to be quite frank, it's very unlikely that this will be implemented any time soon without some kind of sponsoring. It's a huge task and a volunteer just likely won't be able/willing to tackle it in the immediate future.

Marking as NEEDINFO just to get clarification as to what you're asking for. If you can find the equivalent Microsoft Office help pages and link to those, that would be a decent start. Once you provide a bit more details please set to UNCONFIRMED. Thanks.
Comment 2 Cor Nouws 2015-09-08 12:29:35 UTC
Hi Neo,

(In reply to Neo from comment #0)

> I absolutely love LibreOffice and would love to completely switch

Great to read that :)

Please provide a sample file from powerpoint, so that we can set this issue right.
Cheers - Cor
Comment 3 Neo 2016-02-01 02:55:12 UTC
(In reply to Joel Madero from comment #1)
> Is this just WordArt? 
> 
> If so this is likely a duplicate of one of the other open issues regarding
> WordArt. 
> 
> Please let us know - to be quite frank, it's very unlikely that this will be
> implemented any time soon without some kind of sponsoring. It's a huge task
> and a volunteer just likely won't be able/willing to tackle it in the
> immediate future.
> 
> Marking as NEEDINFO just to get clarification as to what you're asking for.
> If you can find the equivalent Microsoft Office help pages and link to
> those, that would be a decent start. Once you provide a bit more details
> please set to UNCONFIRMED. Thanks.

There is no help page associated with it.  To be more precise, I was looking for LibreOffice WordArt to have an equivalent capability to MS Office's WordArt, which produces some very advanced beveling, gradients, metallic effects, shading, shadowing, etc.  It probably is too complex to emulate with donated time and expertise but its definitely a worthwhile effort since it will allow me to move away from MS Office.  I need to work on intellectual property and sharing things in the cloud or to some third party company (who might be a potential competitor) is not an option.  Even if I wasn't doing work for a company, no third party company should require you to trust their cloud to do your personal work.  The lack of privacy with Microsoft products is a big reason I want to move entirely to LibreOffice.
Comment 4 Neo 2016-02-01 02:58:19 UTC
(In reply to Cor Nouws from comment #2)
> Hi Neo,
> 
> (In reply to Neo from comment #0)
> 
> > I absolutely love LibreOffice and would love to completely switch
> 
> Great to read that :)
> 
> Please provide a sample file from powerpoint, so that we can set this issue
> right.
> Cheers - Cor

Thank you for your reply.  I can give you a PPT file but LibreOffice will not be able to render Microsoft's WordArt.  I can provide you with screenshots exemplifying the level of sophistication I can achieve with MS's WordArt.
Comment 5 Neo 2016-02-01 03:13:32 UTC
Created attachment 122306 [details]
Example of PPT 2010 text transform capabilities

I've been calling it "WordArt" inside of PPT but I think it's just a basic text transformation/decoration capability.  WordArt is what they used to call it when text was transformed externally to MS Office (via DDE link) and embedded.
Comment 6 Neo 2016-02-01 03:14:52 UTC
(In reply to Neo from comment #4)
> (In reply to Cor Nouws from comment #2)
> > Hi Neo,
> > 
> > (In reply to Neo from comment #0)
> > 
> > > I absolutely love LibreOffice and would love to completely switch
> > 
> > Great to read that :)
> > 
> > Please provide a sample file from powerpoint, so that we can set this issue
> > right.
> > Cheers - Cor
> 
> Thank you for your reply.  I can give you a PPT file but LibreOffice will
> not be able to render Microsoft's WordArt.  I can provide you with
> screenshots exemplifying the level of sophistication I can achieve with MS's
> WordArt.

I just noticed that I had attached a screenshot in my original post but I uploaded another example of what PPT can do with text.
Comment 7 Heiko Tietze 2016-06-30 07:47:02 UTC
You do something similar with Insert > Media > Fontwork Gallery... with limited functionality. More/Other options are available when you draw a curve and attach the text per Fontwork (with the workaround from bug 94535). You can also convert the text to 3D (Modify > Convert > To 3D, or use the context menu) and access all 3D effects per context (haven't found the equivalent in the main menu).

What are you missing exactly? Right now this ticket is too generic and not actionable.
Comment 8 Heiko Tietze 2017-01-02 15:25:37 UTC
Generic issue, workaround available, and no reply for half a year. Closing now.