Bug 93738 - Shortcuts next to menu entries don't always correspond to UI language (appear in language of keyboard layout instead)
Summary: Shortcuts next to menu entries don't always correspond to UI language (appear...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-28 11:16 UTC by ooome
Modified: 2016-07-17 03:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (58.11 KB, image/jpeg)
2015-09-18 07:22 UTC, ooome
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ooome 2015-08-28 11:16:16 UTC

    
Comment 1 sophie 2015-08-28 11:52:29 UTC
Hi, what is the language it's not translated in? Thanks - Set as need info - Sophie
Comment 2 ooome 2015-08-31 07:05:29 UTC
Actually, the headline
Comment 3 ooome 2015-08-31 07:08:18 UTC
I have edited the summary, because this isn't only about the menu entry I put originally (that's just where I spotted it).

I'm using the English version of LO 5.0.0.5 on Windows 7. The Windows version is French, but that shouldn't matter. The shortcuts (e.g. "Ctrl + Shift + X") appear in German ("Strg + Umschlt + X"). This seems to be the case across all menus.
Comment 4 ooome 2015-08-31 07:08:59 UTC
Just to clarify, the menu entries as such appear in English, it's just the shortcut bit at the end.
Comment 5 Buovjaga 2015-09-12 17:45:14 UTC
Sounds really weird. When things get weird, this is what we do: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 ooome 2015-09-18 07:22:16 UTC
Created attachment 118816 [details]
screenshot

The problem persists with a fresh user profile. (added screenshot to better illustrate issue)
Comment 7 Aron Budea 2016-06-02 02:41:59 UTC
Does the issue with language of shortcuts in LibreOffice persist for you with newer versions?
Comment 8 ooome 2016-06-03 06:29:29 UTC
Unfortunately I'm not in a position to provide you with an update. This concerns a machine I don't have administrator rights, and I've been "given" Version: 5.0.5.2; it's unknown when the next update round will happen.

What I can confirm, though, is that this bug does exist in Version: 5.0.5.2; I've been given a new computer with a fresh install recently.

So I must leave this to someone else, or whenever my administrators upgrade LibreOffice.
Comment 9 Aron Budea 2016-06-03 07:45:16 UTC
Thanks for the reply.
I checked myself, and language of keyboard shortcuts definitely doesn't seem to change with UI language settings, I installed French and German UI languages, and despite changing between them, shortcuts stayed English the whole time. My Windows language is English.

This might be a bug, but I'm not sure how it should be working, so setting back to UNCONFIRMED now.
Can someone else comment on this?
Comment 10 Maxim Monastirsky 2016-06-03 09:59:46 UTC
This is similar to Bug 96445. Keyboard key names translation is handled differently than other UI elements. I don't have Windows build to actually test it, but by just reading the code it seems that:

1. Some languages translation is hardcoded in http://opengrok.libreoffice.org/xref/core/vcl/win/window/keynames.cxx#66
2. For anything not present there - it gets the name from Windows using the GetKeyNameTextW function (with whatever the current input language is).
3. And there is a last chance English fallback.

So based on 2. the shortcuts will appear in German if it's the current input language. As soon as you switch to English, the shortcuts will be in English again.
Comment 11 ooome 2016-06-03 10:08:53 UTC
Just tested this, and indeed the shortcuts change with the input language.
Comment 12 Aron Budea 2016-06-04 00:28:20 UTC
Thanks for the valuable insights, Maxim.

This actually seems to be intended, because normally the keyboard layout corresponds to what appears on your keyboard, and it makes sense to display what the keyboard reads. Of course people often have multiple keyboard layouts installed, but as a general principle this seems correct.

Thus closing as NOTABUG. Ooome, if you have any further comments on this, let us know.