Bug 96445 - AutoCorrect Word Completion: drop-down "Accept with" cannot be localized
Summary: AutoCorrect Word Completion: drop-down "Accept with" cannot be localized
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Not-Localizable
  Show dependency treegraph
 
Reported: 2015-12-12 16:49 UTC by Stanislav Horacek
Modified: 2018-11-23 09:09 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
word completion tab with unlocalized drop-down for cs (41.41 KB, image/png)
2015-12-12 16:49 UTC, Stanislav Horacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2015-12-12 16:49:32 UTC
Created attachment 121246 [details]
word completion tab with unlocalized drop-down for cs

In Tools - AutoCorrect - AutoCorrent Options - Word Completion tab, there is the "Accept with" drop-down with English key names (End, Return, Space, Right, Tab) which cannot be localized (the names are not in .po files for translation).

Also, the "Return" should be renamed to "Enter" (it seems that "Enter" appears on Windows whereas "Return" on Linux).

Checked in 5.1 beta 2 (Ubuntu), cs locale, presumably inherited from OOo (observed also in 3.5.4 and AOO 4.1.2).
Comment 2 tommy27 2015-12-13 06:28:56 UTC
Hi, I tested under Win8.1 x64 and it's correctly localized (at least in the italian version) using LibO 5.0.3.1
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
Versione locale: it-IT (it_IT)

so I suspect the issue is just in the CS locale.

@Julien and Sophie
what about the french locale?
who's the CS locale team leader to ping?
Comment 3 Stanislav Horacek 2015-12-13 14:18:36 UTC
Interesting, but these strings have no KeyID (qtz locale) so they can't be found in .po files - or are they there for Italian translation?

I am Czech localizer - so I could fix this easily if the strings were translatable.
Comment 4 tommy27 2015-12-14 06:31:20 UTC
@Valter Mura
can you answer Stanislav's question?
Comment 5 Jean-Baptiste Faure 2016-01-11 08:33:58 UTC
(In reply to tommy27 from comment #2)
[...]
> what about the french locale?

No problem in French localization for 5.0 and 5.1. In 4.4 there is only one item of the dropdown list which is not localized (Space).

In Pootle, for the master, the string is "Acc_ept with:", it is there:
Comment: W8dF5
libo_ui/cui/uiconfig/ui.po Unit #79289479
wordcompletionpage.ui label3 label string.text 
wordcompletionpage.ui

Best regards. JBF
Comment 6 Stanislav Horacek 2016-01-11 17:52:01 UTC
It seems that Pootle contains the same strings for both French and Czech: there is "Accept with" (which is localized in cs), but the key names ("End", "Return" etc.) are missing.

So I think the translation for French and Italian has been done somehow out of Pootle which is what confuses me...
Comment 7 Jean-Baptiste Faure 2016-01-11 19:25:49 UTC
(In reply to Stanislav Horacek from comment #6)
> It seems that Pootle contains the same strings for both French and Czech:
> there is "Accept with" (which is localized in cs), but the key names ("End",
> "Return" etc.) are missing.
> 
> So I think the translation for French and Italian has been done somehow out
> of Pootle which is what confuses me...

I am not sure but I believe that translations of words like End, Return, Space (for spacebar) are taken from the OS.

Best regards. JBF
Comment 8 Valter Mura 2016-01-11 20:01:39 UTC
(In reply to Jean-Baptiste Faure from comment #7)
> (In reply to Stanislav Horacek from comment #6)
> > It seems that Pootle contains the same strings for both French and Czech:
> > there is "Accept with" (which is localized in cs), but the key names ("End",
> > "Return" etc.) are missing.
> > 
> > So I think the translation for French and Italian has been done somehow out
> > of Pootle which is what confuses me...
> 
> I am not sure but I believe that translations of words like End, Return,
> Space (for spacebar) are taken from the OS.
> 
Jean Baptiste,

maybe you're right.

However, there are other parts which I cannot translate, or better I cannot find; these are the comments (text field 'Description') to the commands in Tools/Customize. Please check and confirm if I'm right.
Comment 9 Jean-Baptiste Faure 2016-01-11 20:35:36 UTC
(In reply to Valter Mura from comment #8)
> [...]
> However, there are other parts which I cannot translate, or better I cannot
> find; these are the comments (text field 'Description') to the commands in
> Tools/Customize. Please check and confirm if I'm right.

Indeed, the string from Tools > Customize > Menus -> menu Edition, entry Fields,
"Opens a dialog where you can edit the properties of a field. Click in front of a field, and then choose this command."
is not translated in French and I can't find it in Pootle: there is 51 occurrences of "where" in the UI and none of them match this string. 

There is other strings not translated / translatable :
Entry: Change Database
-> "Change the data sources for the current document."
Only 3 strings with the word "sources".

In the menu Edition | Reference : all 3 menus entry descriptions
etc.

Best regards. JBF
Comment 10 Stanislav Horacek 2016-01-13 20:51:15 UTC
No, these strings in customization *are* translatable - though they're not part of UI, but Help (the texts enclosed by <ahelp> tags).

For instance, the Fields description is available here (and I am pretty sure that the others can be found there too):
https://translations.documentfoundation.org/cs/libo_help/translate/swriter/01.po#unit=100754052

In any case, other bugs should be filed separately - this one is about the word completion drop-down (and you probably did not want to confirm it). As we agreed that its translation is not handled by LibreOffice, I would suggest to change this to allow its translation in Pootle.
Comment 11 Maxim Monastirsky 2016-01-13 21:44:17 UTC
Key names are handled differently in each VCL plugin. Some examples:

gtk2:

It's possible to translate these strings in vcl/unx/generic/app/keysymnames.cxx. Strings that are missing there, are taken from Xlib using XKeysymToString.

gtk3:

We get names from gtk using gtk_accelerator_get_label.
Comment 12 Valter Mura 2016-02-01 21:57:55 UTC
(In reply to Stanislav Horacek from comment #10)
> No, these strings in customization *are* translatable - though they're not
> part of UI, but Help (the texts enclosed by <ahelp> tags).
> 
> For instance, the Fields description is available here (and I am pretty sure
> that the others can be found there too):
> https://translations.documentfoundation.org/cs/libo_help/translate/swriter/
> 01.po#unit=100754052
> 
> In any case, other bugs should be filed separately - this one is about the
> word completion drop-down (and you probably did not want to confirm it). As
> we agreed that its translation is not handled by LibreOffice, I would
> suggest to change this to allow its translation in Pootle.

In this case, all Italian strings are translated. So, the problem is that the <ahelp hid="." visibility="hidden"> status doesn't allow to correct show the translated tip. Many of them are contextualized (example: <ahelp hid="HID_SCRL_PAGEUP">), many others not.

Is it correct?
Comment 13 QA Administrators 2017-09-01 11:14:49 UTC Comment hidden (obsolete)
Comment 14 Julien Nabet 2018-11-17 00:08:22 UTC
With Czech UI + LO master sources updated today, I got:
End
Enter
Mezerník
Vpravo
Tabulátor
Comment 15 Stanislav Horacek 2018-11-18 21:11:03 UTC
I can confirm this - I guess that this is because gtk3 plugin is now enabled and it takes translations from GTK:
https://gitlab.gnome.org/GNOME/gtk/blob/master/po/cs.po
Comment 16 Julien Nabet 2018-11-19 08:15:19 UTC
(In reply to Stanislav Horacek from comment #15)
> I can confirm this - I guess that this is because gtk3 plugin is now enabled
> and it takes translations from GTK:
> https://gitlab.gnome.org/GNOME/gtk/blob/master/po/cs.po

So is it ok for you or "End" and "Enter" should be also translated?
But even if it's the case, since it depends on GTK, it's not related to LO.
In brief, we'd put either WFM or NOTOURBUG, shouldn't we?
Comment 17 Stanislav Horacek 2018-11-23 09:01:00 UTC
Yes, the GTK3 translation is OK ("End" and "Enter" are correct in Czech translation).

I'm not sure about the other plugins (for KDE4 I get not localized strings) - but it is apparently matter of upstream and I agree with closing of this bug.
Comment 18 Julien Nabet 2018-11-23 09:09:26 UTC
Thank you for your feedback.
Let's put this one to WFM then since the fix has been done outside LO.