Download it now!
Bug 93833 - FORMATTING: Track Changes not working correctly with styles
Summary: FORMATTING: Track Changes not working correctly with styles
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Track-Changes Writer-Styles
  Show dependency treegraph
 
Reported: 2015-09-01 09:13 UTC by mike.hall
Modified: 2017-04-21 12:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike.hall 2015-09-01 09:13:03 UTC
Working with styles in Windows under 5.n.n.n is seriously broken. Makes cleaning up a document to improve electronic quality with track changes impossible. Appears to be a regression (works correctly under 4.4.3.2 on Linux).
Document dependent - does not always occur with documents created elsewhere - have not tracked down all the circumstances of this. 


To demo:
create new document
add three lines, first and third with text, second line blank,
do edit>track changes
apply a heading level to line2
put cursor at beginning of heading line
press backspace

Actual behaviour
The heading becomes normal text and undo does not reverse the change, but if you do Ctrl+Z a couple of times and then Ctrl+Y the heading is restored.

Expected behaviour
The heading level is preserved (regression from 4.4.3.2 - Linux)
Comment 1 Buovjaga 2015-09-14 15:02:07 UTC
Heading level is preserved for me on Win.
Have to try on Linux next..

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)
Comment 2 Buovjaga 2015-09-23 08:23:33 UTC
Not reproduced.

Kubuntu 15.04 64-bit Plasma 5.4
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)
Comment 3 Yousuf Philips (jay) (retired) 2016-10-17 04:15:32 UTC
Hi Mike,

Please provide more details as unfortunate we arent able to reproduce.

Version: 5.3.0.0.alpha0+
Build ID: 45a7137c6796f33fbf5b8f7cb64e293260d991cb
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-13_23:38:06
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 mike.hall 2016-10-24 12:25:41 UTC
Thanks. No, I can't reproduce reliably now with 5.2.2.2 (Win 10 64 bit).

There is a minor oddity I can create.

Create a new document and add two lines with different styles and some text, say heading 1 and text body.
Do changes > track changes and show changes
Amalgamate the two lines by deleting the para mark after the heading line

Still shows text body for the second line (incorrect)
Now, without editing the text, stop showing changes - text now shown correctly on one heading 1 line
Show changes - second line is shown as heading 1 (correct)

I doubt this oddity is worth bothering with, so I have marked this one resolved.
Comment 5 Buovjaga 2016-10-24 12:30:58 UTC
Changing status to WFM.

I will look into making that other oddity its own report.
Comment 6 Buovjaga 2016-11-02 08:09:36 UTC
Added bug 103638. It is not dependent on having different styles.