Bug Hunting Session
Bug 93877 - Sidebar on the right breaks Fitt's law for scroll bar (screen edge)
Summary: Sidebar on the right breaks Fitt's law for scroll bar (screen edge)
Status: RESOLVED DUPLICATE of bug 92831
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-03 07:37 UTC by Mateusz
Modified: 2015-09-08 13:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz 2015-09-03 07:37:18 UTC
As per Fitt's law, screen edges are important target for cursor movement.

See:
http://blog.codinghorror.com/fitts-law-and-infinite-width/
http://sixrevisions.com/usabilityaccessibility/improving-usability-with-fitts-law/

Scroll bar is very often used, don't have data for LibreOffice, but for Firefox it scores 95% in heatmap: https://heatmap.mozillalabs.com/

So when sidebar is enabled, it breaks this important workflow (move cursor to the right, can't catch scroll bar) and increases user frustration.

Maybe it should actually be on the left of the screen (if not by default, then as an option)?

Or maybe sidebar should be on the right, but scroll bar would be better placed at screen edge?

Many projects struggled with this aspect:
https://bugs.kde.org/show_bug.cgi?id=96727
https://bugzilla.mozilla.org/show_bug.cgi?id=284550
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/206837

So as innovation in UI is great, it shouldn't mess up with this important law and scroll bar position.
Comment 1 Jean-Baptiste Faure 2015-09-06 21:33:09 UTC
You can dock the sidebar on the left if you want. 
I use the scrollbar very rarely in LibreOffice (and never in Firefox) because the mouse wheel (or the touchpad) is more usable. So having the sidebar on the right side is more important than the scrollbar, but the scrollbar must be  close to the area it controls. So for me the current disposition is the best and simple one.

Best regards. JBF
Comment 2 Mateusz 2015-09-07 06:57:27 UTC
Jean,

thank you for your reply. I didn't know I can undock sidebar and move it to the left.

I understand that current situation suits your needs. Can we discuss what could be the best solution for the majority of users?
Comment 3 Jean-Baptiste Faure 2015-09-08 04:35:05 UTC
(In reply to Mateusz from comment #2)
> Can we discuss what could be the best solution for the majority of users?

Who know the majority of users ?

@ux-advise: What are your thoughts?


Best regards. JBF
Comment 4 V Stuart Foote 2015-09-08 13:08:55 UTC
We've been there...

*** This bug has been marked as a duplicate of bug 92831 ***