Download it now!
Bug 92831 - Position vertical scroll bar widget outboard of Sidebar
Summary: Position vertical scroll bar widget outboard of Sidebar
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 93877 98041 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-07-20 03:22 UTC by Jiggle Billy
Modified: 2016-10-24 16:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiggle Billy 2015-07-20 03:22:27 UTC
The sidebar should be on the left of the window. The rationale for this is that when a window is maximised, the user can flick their mouse to the right side of screen and the scroll bar is of infinite size (Fitt's Law). This is how most scrollbars are on the windows platform. Maximise a window in google chrome, notepad or word 2013 and you will see that the scrollbar touches the outside right window.


Libreoffice too has this feature but if the sidebar is enabled on the right side then it loses the infinitely sized scrollbar.

Having the sidebar appear by default on the left rather than the right side of the window would be better so a user could flick their mouse to the right in order to scroll.
Comment 1 Joel Madero 2015-07-20 04:02:42 UTC
Again I completely disagree with this but it's UX's call. Setting to UX-advise and setting to NEW. I hope it's closed as WONTFIX.
Comment 2 Jean-Baptiste Faure 2015-07-20 04:57:48 UTC
What do you mean by "infinitely sized scrollbar"?

Best regards. JBF
Comment 3 Stefan Knorr (astron) 2015-07-20 07:19:55 UTC
"Infinite size" refers to the fact that if you go to the edge of the screen, you can't get any further -- so no matter how much further you physically fling your mouse, you can't miss an item that is to that side of the screen.
This is also called "Fitts's Law", as Jiggle said in comment 0. Fitts's Law is commonly applied to important user interfaces items: the Mac OS menu bar, the Windows Start button, the X button of fullscreen windows on Windows. (You may notice that even while the graphic design of these items makes them seem as if they don't extend to the edge of the screen, their clickable area actually does. (The exception here is the Windows 95/98 start menu: it does not respect Fitts's Law.))

In any case, scrollbars have been becoming less important for actual manipulation since the advent of the mouse wheel, touchpad scrolling and outright touchscreen. Now, in many cases they are rather used as indicators.

The proposed solution also seems to put cart before the horse: Instead of putting an item that has been on the right ~forever on the left (the scrollbar), it may be a better idea to rethink the position of the sidebar.
Comment 4 Jean-Baptiste Faure 2015-07-20 10:47:20 UTC
(In reply to Stefan Knorr (astron) from comment #3)
> "Infinite size" refers to the fact that if you go to the edge of the screen,
> you can't get any further -- so no matter how much further you physically
> fling your mouse, you can't miss an item that is to that side of the screen.

Ok, I see. Thank you for your answer.
It seems to me that the problem pointed by Jiggle is widely shared by all software having a working area between two docked panels. For example all IDE I know fall in this category.
In the case of LibreOffice, even if you dock the sidebar on the left side of the screen, you may want to dock some toolbar on the other side, and you still have the same "problem".
Docking toolbars and sidebar on the left side has other drawbacks, the  bigger, for me, being that the main working area, the area of the screen where you are mainly looking when you type, is shifted to the right instead to be around the center of the screen.

Best regards. JBF
Comment 5 V Stuart Foote 2015-07-22 02:17:18 UTC
Agree with the suggestion to reposition the vertical scroll bar and attach to the outer edge of the frame where it would benefit from activation using its "infinite size". I.e. reposition outboard of the current default Sidebar attachment.

But IMHO perceive no compelling reason to also reposition Sidebar to left edge of frame. Neither is there a requirement to attach Sidebar to right edge of the LO frame.  

So, in a practical sense believe the Sidebar's Show/Hide toggle would function equally well if the collapsed position was left of the vertical scroll bar. Its button is not sensitive to the frame edge, and so must be targeted rather than swiped. 

That works equally well at the frame edge or as suggested inboard of the scroll bar--which as noted can be swiped into focus.

A reasonable enhancement.
Comment 6 Jean-Baptiste Faure 2015-07-22 05:11:14 UTC
This idea to put the scrollbar away from the window it controls, seems strange to me.
I think it will be more confusing for all users. If a user prefer to have the sidebar on the left, he can easily configure LO and he have to do that only once. Please let the things as simple as possible.

I suggest to close this enhancement request as WontFix or NotABug because it will create a bug.

Best regards. JBF
Comment 7 Heiko Tietze 2015-07-22 07:35:42 UTC
I agree with Jean-Baptiste. Imagine a scrollbar that doesn't affect the direct neighbor (the properties panel aka sidebar wouldn't be scrolled). Furthermore the properties panel could have its own sidebar too left of the tab bar.
Comment 8 Adolfo Jayme 2015-07-22 09:47:28 UTC
(In reply to Heiko Tietze from comment #7)
> I agree with Jean-Baptiste. Imagine a scrollbar that doesn't affect the
> direct neighbor (the properties panel aka sidebar wouldn't be scrolled).
> Furthermore the properties panel could have its own sidebar too left of the
> tab bar.

You don’t need to imagine it: it is already a big problem in Basic; see bug 86568. (I’ll understand your shocked face :-] )

IMHO, it’s not worth to introduce new problems in order to resolve others.
Comment 9 V Stuart Foote 2015-07-22 12:46:23 UTC
Closing is a bit short sighted, consider behavior when the Sidebar is undocked. 

Also, as I hope, at some not too distant future date behavior when we are able to split out multiple content panel decks independently.

At that point the mix of docked and floating Sidebar widgets would in fact benefit from from the vertical scroll bar of the document canvas being consistently attached to right edge of frame.

We lose nothing by attaching to right edge of frame now, and it simplifies design and development going forward.
Comment 10 V Stuart Foote 2015-09-08 13:08:55 UTC
*** Bug 93877 has been marked as a duplicate of this bug. ***
Comment 11 V Stuart Foote 2016-02-21 22:37:18 UTC
*** Bug 98041 has been marked as a duplicate of this bug. ***
Comment 12 V Stuart Foote 2016-02-21 22:44:58 UTC
While this is marked up resolved wontfix Design & UX team was split on this issue. 

As Sidebar framework continues to evolve (multiple decks and additional attachment points) believe there is a case to be made for reopening and reposition the main canvas scroll bar to its Fitt's law compliant "infinite" position.