Bug 93925 - Regression: Comments lost in PDF Export of documents with comments inside margin
Summary: Regression: Comments lost in PDF Export of documents with comments inside margin
Status: RESOLVED DUPLICATE of bug 93009
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-09-04 15:43 UTC by Gerry
Modified: 2016-04-05 17:07 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2015-09-04 15:43:01 UTC
Additionally to the issues of exporting documents with comments inside the margin (bug 79232), there is a new regression: 

The comments themselves are missing in the PDF output. See the PDF output here: 
https://bugs.documentfoundation.org/attachment.cgi?id=118417

The source document is this here:
https://bugs.documentfoundation.org/attachment.cgi?id=99806
 
Version: 5.0.1.2 (x64)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: en-US (en_US)

P.S: I followed comment 45 in bug 36815 to activate comments inside margin for PDF export. For this, you need to activate: "in margins" in tools->options->writer->print. It is not yet implemented in the PDF export dialog (see bug 77650).
Comment 1 m.a.riosv 2015-09-04 22:03:11 UTC
Hi @Gerry, thanks for reporting.

Reproducible:
Win10x64
Version: 5.0.1.2 (x64) Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261

Regression from:
Version: 4.4.6.0.0+
Build ID: 319d725c73b8bf60158961aa0b014258708effab
TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-08-21_20:30:18
Comment 2 Chris Halls 2015-09-21 11:39:37 UTC
Also Debian bug https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=799540

Further information from the bug submitter:

On 20-Sep-2015, Rene Engelhard wrote:
> Sounds like
> https://bugs.documentfoundation.org/show_bug.cgi?id=93925 to me

Agreed, that matches the behaviour I've found.

Also of note: The comment text does appear in the PDF, but it is
rendered as white-on-white, or some other invisible rendering.

If I select text in the PDF around the place where the comment box
would be, the text becomes visible in the selection. So it does get
placed on the page in the PDF, but is not visible.

> Can you confirm? (Maybe remove "in margins" for a try?)

When I choose a different setting for the appearance of comments, such
as “End of page”, the comments are still not visible. This time, they
do not even appear to be selectable on the page.
Comment 3 raal 2015-10-09 07:13:43 UTC
Works OK in oldest, latest range in bibisect-win32-5.0, latest:Version: 5.0.0.0.alpha1+
Build ID: ab465b90f6c6da5595393a0ba73f33a1e71a2b65
Comment 4 Machiel van Veen 2015-10-15 10:25:22 UTC
I can confirm this issue, please note this bug is disruptive for our users. If this can be resolved we would be very grateful.

Ubuntu 14.04.3
Version: 5.0.2.2 (x64)
Build ID: 00m0(Build:2)
Locale: en-US (en_US.UTF-8)
Comment 5 raal 2015-10-16 06:15:32 UTC
This seems to have begun at the below commit.
Adding Cc: to mstahl@redhat.com ; Could you possibly take a look at this one? Thanks

a517fec6f749fa4d5a8e1688bfb776a616e16b14 is the first bad commit
commit a517fec6f749fa4d5a8e1688bfb776a616e16b14
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Jul 25 15:46:10 2015 -0700

    source sha:a6f5770b4aaaa6506a22eae0d641ad48f9b6d239

    source sha:a6f5770b4aaaa6506a22eae0d641ad48f9b6d239
    source sha:5bc343cc723f993ed112cf5c700e3f397527d671
    source sha:c6483666232a231446190d5c256857db45c5e4cc
    source sha:bded4ddd6da0de2c465b28a51d773720338542c3
    source sha:79429448052d4b69cc235000b74f3f8d6fa5a74c
    source sha:7e74fe416de8f2da49d7fd2eb13759cde76e9c6c
    source sha:cd0474555eed3e65c145c85ed21baab8f09258d2
    source sha:a843c457044acc3155b0d3c49534e78569c69d96
    source sha:cfde943f59b0cf63c46cbe061fd37e53201d2363
    source sha:cade2b8f9f9c39fc7bc6960f5faf591860be58ae
    source sha:6556043364877c0ac74c07b509856dccfe52e43a
    source sha:4cf3dd78870456f786d39e8946648550a655d9a3
    source sha:978033d5ed9f93f2d5d9a1ba44acf6b37bc13bfe
    source sha:b5a4e6974a5473c44fc239b6a9ae21f233111c2a
    source sha:f1256611054701a2bba20225fb654814eecbf559
    source sha:3b32c5898ff4e744d3f18b00421b433500426d74

:040000 040000 6093f6370d68f4d531ba15227dc174d16b00ae7d f97ce311938e40fe38fbfad9a4ef3d69fbcc6603 M   instdir

author	Michael Stahl <mstahl@redhat.com>	2015-07-03 14:53:45 (GMT)
committer	Michael Stahl <mstahl@redhat.com>	2015-07-03 14:53:45 (GMT)
commit	a6f5770b4aaaa6506a22eae0d641ad48f9b6d239 (patch)
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:13:10 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 7 Gerry 2016-01-09 12:41:21 UTC
@Michael Stahl: I would like to send a 'ping' regarding this regression. Is there a (simple) solution to this bug introduced by commit a517fec6f749fa4d5a8e1688bfb776a616e16b14?
Comment 8 Michael Stahl (CIB) 2016-02-19 20:25:19 UTC
commit a6f5770b4aaaa6506a22eae0d641ad48f9b6d239
Author:     Michael Stahl <mstahl@redhat.com>
AuthorDate: Fri Jul 3 16:53:45 2015 +0200

    Revert "loplugin:unusedmethods sax,shell,stoc,basegfx"
    
    The basegfx changes appear to break Windows builds.

    This reverts commit 3b32c5898ff4e744d3f18b00421b433500426d74.


really, this commit broke something? it's just a revert of another commit
that removed "unused" code.

commit 3b32c5898ff4e744d3f18b00421b433500426d74
Author:     Noel Grandin <noel@peralex.com>
AuthorDate: Thu Jul 2 14:21:30 2015 +0200

    loplugin:unusedmethods sax,shell,stoc,basegfx


there's just a day between the two. are you sure the bibisect result is correct?
Comment 9 raal 2016-02-19 20:36:37 UTC
(In reply to Michael Stahl from comment #8)
> 
> really, this commit broke something? it's just a revert of another commit
> that removed "unused" code.
> 

It can be anyone from these commits
    source sha:a6f5770b4aaaa6506a22eae0d641ad48f9b6d239
    source sha:5bc343cc723f993ed112cf5c700e3f397527d671
    source sha:c6483666232a231446190d5c256857db45c5e4cc
    source sha:bded4ddd6da0de2c465b28a51d773720338542c3
    source sha:79429448052d4b69cc235000b74f3f8d6fa5a74c
    source sha:7e74fe416de8f2da49d7fd2eb13759cde76e9c6c
    source sha:cd0474555eed3e65c145c85ed21baab8f09258d2
    source sha:a843c457044acc3155b0d3c49534e78569c69d96
    source sha:cfde943f59b0cf63c46cbe061fd37e53201d2363
    source sha:cade2b8f9f9c39fc7bc6960f5faf591860be58ae
    source sha:6556043364877c0ac74c07b509856dccfe52e43a
    source sha:4cf3dd78870456f786d39e8946648550a655d9a3
    source sha:978033d5ed9f93f2d5d9a1ba44acf6b37bc13bfe
    source sha:b5a4e6974a5473c44fc239b6a9ae21f233111c2a
    source sha:f1256611054701a2bba20225fb654814eecbf559
    source sha:3b32c5898ff4e744d3f18b00421b433500426d74
> 
> there's just a day between the two. are you sure the bibisect result is
> correct?

Sure - not, sometimes I make mistakes ;-)
Comment 10 Michael Stahl (CIB) 2016-02-19 22:53:15 UTC
(In reply to raal from comment #9)
> It can be anyone from these commits

oops, sorry, you are right, i didn't read properly
and assumed it was one of these -max repos when it clearly
was not.
Comment 11 Michael Stahl (CIB) 2016-02-22 21:27:10 UTC
regression from:

commit 978033d5ed9f93f2d5d9a1ba44acf6b37bc13bfe
Author:     Miklos Vajna <vmiklos@collabora.co.uk>
AuthorDate: Fri Jul 3 11:52:17 2015 +0200

    SwViewShell::DLPrePaint2: fix missing clipping for the non-buffered case


... fixed in 5.0.5 release... naturally, its a duplicate

*** This bug has been marked as a duplicate of bug 93009 ***