Bug 77650 - PDF Export dialog lacks options to position comments (as on Print dialog, e.g. in margin)
Summary: PDF Export dialog lacks options to position comments (as on Print dialog, e.g...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:7.5.0 inReleaseNotes:7.5
Keywords: filter:pdf, needsDevEval, topicUI
: 91539 103376 (view as bug list)
Depends on: 152573 152575
Blocks: PDF-Export-Options-Dialog
  Show dependency treegraph
 
Reported: 2014-04-18 16:39 UTC by Gerry
Modified: 2023-02-20 13:59 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
pdfgeneralpage.ui (modified) (42.46 KB, application/x-designer)
2014-05-17 07:50 UTC, Gerry
Details
Screenshot of modified PDF export dialog (for Writer).png (74.49 KB, image/png)
2014-07-02 20:41 UTC, Gerry
Details
PDF-export prints comments only to the margin of the first page (49.35 KB, application/vnd.oasis.opendocument.text)
2022-12-16 10:54 UTC, devseppala
Details
PDF-export prints comments only to the margin of the first page (38.78 KB, application/pdf)
2022-12-16 10:56 UTC, devseppala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2014-04-18 16:39:09 UTC
It is so good to have Writer being able to print and PDF export documents with comments in the margin (bug 36815). Whereas the printing of documents with comments is straight-forward, the usability of PDF exporting of documents with comments needs to be improved to actually make it usable for end users.

Current situation:
In the PDF export dialog "File" -> "Export as PDF", there is an option "Export comments". This, however, exports the comments as PDF comments (according to the PDF spec). Currently, from the PDF export dialog the user is not able to export PDFs with comments in the margin. For that, the user needs to go to "Tools" -> "Options" -> "LibreOffice Writer" -> "Print" and enable there "Comments, Place in Margin". Then, the user can use again the PDF export dialog to correctly export PDFs with comments in the margin. But, the user has to *switch off* the option "comments" in that dialog in order to not get the comments twice (as PDF comments and in the margin). If the user wants to PDF export the next document without comments, he/she has to do the entire procedure again. UX needs to be improved.

Improvement idea:
As all features actually do exist, the improvement should be quite easy and limited to UI only (I hope so). Change the dialog "File" -> "Export as PDF" to:

 _______________
|Export comments|
  o Do not export comments
  o Place as PDF comments
  o Place in margin
  o Place at end of document
  o Place at end of page
  o Export only comments

A pulldown menu is probably the best solution to have these six options available.
The second option is the current (in LO 4.2.x) default option when the user checks "Export comments" in the export PDF dialog.
The options 3 to 6 are the options currently (in 4.3 nightly) found only in the "Options" -> "LibreOffice Writer" -> "Print" dialog.
Comment 1 Gerry 2014-04-18 16:42:58 UTC
Hi Caolan, I CCed you to this small enhancement request for the usability improvement of PDF export of documents with comments in the margin. 

I assume and hope that this is mostly a UI change. I think it would increase usability of the feature a lot.
Comment 2 Gerry 2014-05-17 07:50:25 UTC
Created attachment 99203 [details]
pdfgeneralpage.ui (modified)

Hi Caolan, please find attached a slightly modified pdfgeneralpage.ui in order to improve usability of PDF export of Writer documents with comments. I am not a programmer, but I hope that this is somewhat helpful.

I took the dialog from here (http://cgit.freedesktop.org/libreoffice/core/tree/filter/uiconfig/ui) and I added a section in line 546-711 with the id "comments_writer". As far as I understand, all applications use exactly the same dialog, but are not calling all of the entries/IDs. As the Writer dialog now needs many more options, I left the ID "comments" like it was (to be called from Calc, Draw, Impress) and the new "comments_writer" to be called from Writer.

I know that changes in the UI-file are just a small part of the overall changes for this enhancement, but I have no clue how applications are connected to the UI-files. I hope that someone is willing to take over for this part.
Comment 3 Gerry 2014-07-02 20:41:12 UTC
Created attachment 102160 [details]
Screenshot of modified PDF export dialog (for Writer).png

Attached is a screenshot of the modified PDF Export dialog for Writer from comment 2. (at least this is the way how Glade displays it).

I hope someone is interested to implement the export of comments inside the margin also into the PDF Export dialog. This would be super! :-) I hope the .ui file is helpful for this.
Comment 4 Gerry 2015-01-12 18:18:03 UTC
EasyHack? Isn't this enhancement request "Improve usability of PDF export of Writer documents with comments" one that can be added to the EasyHacks list? Thanks!
Comment 5 Gerry 2015-06-27 21:12:05 UTC
needsDevEval: Could one of the developers please have a quick look at this enhancement request, whether it is trivial or an easy hack? Thanks a lot!

@Caolan: Since you developed the code for printing of documents with comments, maybe it is easy for you to estimate the difficulty/time requirement of this request to also have a UI for PDF export of docs with comments. Thanks.
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:23:49 UTC Comment hidden (obsolete)
Comment 7 Gerry 2016-01-09 12:36:42 UTC
@Caolán: Since you wrote the code around "printing documents with comments inside the margin", could you please give your opinion, whether this enhancement is an Easy Hack or not. Is it just about touching the PDF Export UI or much more complicated? 

Thanks!
Comment 8 Cor Nouws 2016-10-21 08:10:23 UTC
*** Bug 103376 has been marked as a duplicate of this bug. ***
Comment 9 Cor Nouws 2016-10-21 08:20:26 UTC Comment hidden (obsolete)
Comment 10 Cor Nouws 2016-10-21 08:22:36 UTC
(In reply to Cor Nouws from comment #9)

> Would it be an idea to split this:
>  - do not mess setting in Tools > Options with that in PDF dialog

Hmm, that should be bug 79232, isn't it?

>  - more options as you suggest in your initial comment?
Comment 11 Gerry 2016-10-21 17:03:05 UTC
Hi Cor, thanks a lot for looking into this bug.

The main message from my original bug report above is that all possible options for PDF export with comments should be accessible via the "File" -> "Export as PDF" dialog. Currently, most of the options are not accessible from this dialog, but hidden somewhere in the LO settings.

The different options are:

|Export comments|
  o Do not export comments
  o Place as PDF comments
  o Place in margin
  o Place at end of document
  o Place at end of page
  o Export only comments

Attached pdfgeneralpage.ui file shows how the dialog could look like.

Did my response clarify your question?
Comment 12 Cor Nouws 2016-10-21 18:10:52 UTC
Hi Gerry,
(In reply to Gerry from comment #11)

> Attached pdfgeneralpage.ui file shows how the dialog could look like.

Very clear - sorry that I messed up the summary with another bug in this area. Corrected that.
The dialog example is clear and quite easy. The harder part of course is all needed code..
Comment 13 Gerry 2016-10-22 09:09:54 UTC
(In reply to Cor Nouws from comment #12)
> The dialog example is clear and quite easy. The harder part of course is all
> needed code..

Thanks a lot Cor. 

To me - as a user - it seems that the features are actually there in LO, but that they are not easily accessible for the users (PDF export dialog).

By the way, Caolán had implemented the feature for printing of documents with comments inside margin. I don't know about his rationale why he did not implement this feature also for the PDF export dialog.
Comment 14 Cor Nouws 2016-10-22 09:29:02 UTC Comment hidden (obsolete)
Comment 15 Timur 2020-09-14 11:38:15 UTC
*** Bug 135371 has been marked as a duplicate of this bug. ***
Comment 16 Timur 2022-07-15 14:24:49 UTC
*** Bug 91539 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2022-11-28 10:26:10 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/19e3bab1a8def52d9a60f67bd87697e828e37773

tdf#77650 Add option to place comments in margin (PDF Export)

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Stéphane Guillou (stragu) 2022-12-08 18:14:26 UTC
Samuel, thanks for the extra setting.

what are your thoughts on the remaining 3 options that are in the Print dialog but not in the PDF Export dialog? Namely:

- Comments only
- Place at end of document
- Place at end of page

I agree that it is odd one could create such a PDF by using Print > Print to file, but not by using the PDF export dialog.

Maybe something for UX to discuss? Is see in the history that they were never copied in.

Version: 7.5.0.0.alpha1+ (X86_64) / LibreOffice Community
Build ID: ad085990b8073a122ac5222e5220f8f1d6826dcf
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 19 devseppala 2022-12-16 10:52:52 UTC
I tested this new feature on 7.5.0.0.beta1 (X86_64) and it seems that only comments on the first page will be printed on the margin. Can someone verify this. I will attach an example .odt document and the resulting pdf.

Version: 7.5.0.0.beta1 (X86_64) / LibreOffice Community
Build ID: 3aca23eec42e9d6fbe57071d7633ae1fc4bc5fcc
CPU threads: 16; OS: Windows 10.0 Build 19045; UI render: Skia/Vulkan; VCL: win
Locale: fi-FI (fi_FI); UI: en-GB
Calc: CL threaded
Comment 20 devseppala 2022-12-16 10:54:55 UTC
Created attachment 184179 [details]
PDF-export prints comments only to the margin of the first page
Comment 21 devseppala 2022-12-16 10:56:32 UTC
Created attachment 184180 [details]
PDF-export prints comments only to the margin of the first page
Comment 22 devseppala 2022-12-16 11:17:36 UTC
I would just like to add that, using the regular print functionality, the comment on the second page is printed correctly on the margin.
Comment 23 Stéphane Guillou (stragu) 2022-12-16 18:52:13 UTC
(In reply to devseppala from comment #22)
> I would just like to add that, using the regular print functionality, the
> comment on the second page is printed correctly on the margin.

I couldn't see that issue in:

Version: 7.6.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 4e4a31ac7d920c71e26ca4acd18c11ec2bd015bb
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

But I could reproduce in:

Version: 7.5.0.0.beta1 (X86_64) / LibreOffice Community
Build ID: 3aca23eec42e9d6fbe57071d7633ae1fc4bc5fcc
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

I couldn't see a relevant commit in between the 7.5 branch point and the latest master commit though...

Can you please report this issue in a separate ticket, and link to this one in the "blocks" field? Thank you!
Comment 24 devseppala 2022-12-18 10:58:23 UTC
> Can you please report this issue in a separate ticket, and link to this one
> in the "blocks" field? Thank you!

Created bug 152575 and added this to the "blocks" field.
Comment 25 Stéphane Guillou (stragu) 2023-02-20 10:50:15 UTC
See follow-up report bug 152575 which I see as an implementation error on top of pre-existing interference between Print to File and PDF export dialogs.