Download it now!
Bug 94148 - LibreOffice Draw Could Use an Eyedropper Tool
Summary: LibreOffice Draw Could Use an Eyedropper Tool
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: color_handling
Keywords: needsUXEval
Depends on:
Blocks: Draw-UX
  Show dependency treegraph
 
Reported: 2015-09-11 22:54 UTC by MarjaE
Modified: 2016-12-07 08:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MarjaE 2015-09-11 22:54:07 UTC
It can be hard to compare colors in LibreOffice to check that objects which should have the same color do have the same color, especially when some of these objects are in different groups.

I think a tool to check the color at any one position without having to go into groups would be useful.
Comment 1 Cor Nouws 2015-09-12 11:38:16 UTC
Thanks! set as enhancement.
Comment 2 Heiko Tietze 2016-06-21 07:39:42 UTC
(In reply to MarjaE from comment #0)
> I think a tool to check the color at any one position without having to go
> into groups would be useful.

Could you please elaborate a little bit what you have in mind. If you use styles the same color is guaranteed. That's the preferred method. And in case you want to see the exact color value under the cursor we would need to show the number somewhere. Not next to the area color picker in the sidebar, for instance, which would be misleading, but in the statusbar. Would be an interesting use case for extensions requiring access to the statusbar.
Comment 3 MarjaE 2016-06-21 14:26:15 UTC
I want a tool to be able to check the color at any one position without having to go into groups would be useful.

Older LibreOffice and OpenOffice documents use different color palletes from newer ones, and it would be useful to be able to update older LibreOffice and OpenOffice documents in newer versions of LibreOffice instead of redrawing everything from scratch, wasting time, and for some of us, worsening repetitive strain injuries.

I don't know how to use styles, or how to update older LibreOffice and OpenOffice documents and add styles. I avoid styles, because Word styles wreck documents I'm trying to edit, and Word styles sometimes crash LibreOffice Writer.
Comment 4 Heiko Tietze 2016-06-21 15:03:18 UTC
(In reply to MarjaE from comment #3)
> I want a tool to be able to check the color at any one position without
> having to go into groups would be useful.
> 
> Older LibreOffice and OpenOffice documents use different color palletes from
> newer ones, and it would be useful to be able to update older LibreOffice
> and OpenOffice documents in newer versions of LibreOffice instead of
> redrawing everything from scratch, wasting time, and for some of us,
> worsening repetitive strain injuries.
> 
> I don't know how to use styles, or how to update older LibreOffice and
> OpenOffice documents and add styles. I avoid styles, because Word styles
> wreck documents I'm trying to edit, and Word styles sometimes crash
> LibreOffice Writer.

What makes me wonder is how you _compare_ the colors. The only way is to read the exact RGB values. Alternatively, the color from the selection could be compared with the palette. For example you click on a red shape and the color picker tells you "Rose" if the values match exactly. But the name "Rose" must not fit your palette entry which could have been "Poppy". Today you see the selected color in the sidebar's picker even when the color is not part of the list. We should keep this behavior and better add something to the statusbar. 

About styles you should read the chapter "Using styles" in https://wiki.documentfoundation.org/images/a/ad/DG43-DrawGuide.pdf. Draw has numerous of hidden features. But using styles is the basis of every well defined document, even more in Writer. If you have a compatibility issues please feel free to report.
Comment 5 MarjaE 2016-06-21 16:23:48 UTC
> What makes me wonder is how you _compare_ the colors. The only way is to read the exact RGB values.

In LibreOffice, colors have names. Among other things, when updating older drawings, I'd like to be able to find each color from the old palette, and replace it with an appropriate color from the new palatte, so there aren't slight mismatches between objects using the old palette and those using the new palette.

> About styles you should read the chapter "Using styles" in https://wiki.documentfoundation.org/images/a/ad/DG43-DrawGuide.pdf.

I have. I still don't have the faintest idea how styles are supposed to work or how they're supposed to help.

> But using styles is the basis of every well defined document, even more in Writer. If you have a compatibility issues please feel free to report.

I suppose in theory styles could be useful. I've posted an enhancement request. But in the meantime, styles are a fiasco.

In my experience, working without styles has worked relatively well in Writer. Working with styles, because I was trying to edit a doc imported from Word, has not worked at all. Styles scramble the text and crash LibreOffice.
Comment 6 Heiko Tietze 2016-06-21 20:20:56 UTC
(In reply to MarjaE from comment #5)
> In LibreOffice, colors have names. Among other things, when updating older
> drawings, I'd like to be able to find each color from the old palette, and
> replace it with an appropriate color from the new palatte, so there aren't
> slight mismatches between objects using the old palette and those using the
> new palette.

WONTFIX in this case. The color value and the color name on the current palette are not necessarily the same on the other. But I'll bring it up to the next design meeting. Personally I like the idea of more information in the statusbar. But that's not what you want actually.

Let's have the discussion about pro and con of styles somewhere else. Just keep in mind that you may apply a style rather than a color. And when you change the style later it will affect all shapes.
Comment 7 MarjaE 2016-12-05 22:39:29 UTC
I can create a style "Gray 6," but if I try to take another object, and apply the same style, then LibreOffice changes the size, font, etc. as well as the color.

It may be possible to edit the style, so that it's neutral about size, font, etc., and can include all objects of that area color, with another set for the line color. But it's not obvious how.
Comment 8 Heiko Tietze 2016-12-06 14:00:33 UTC
(In reply to MarjaE from comment #7)
> It may be possible to edit the style, so that it's neutral about size, font,
> etc., and can include all objects of that area color, with another set for
> the line color. But it's not obvious how.

tagezi published an interesting blog post about styles last week https://dnimruoynepo.blogspot.de/2016/12/philosophical-thinking-about-styles.html

If you say "it's not obvious" how to set a style you mean that understanding what is part of your "Grey 6" is not clear or how to assemble all properties? Anyway, doesn't this question goes beyond your initial request of an eye dropper tool? 

Possible solution to your request is the recent color feature that has been improved for 5.3. This part of the picker shows the colors you recently used, meaning '58% gray', for instance, will be available for quick selection. It was there before 5.3 but buggy and did reset after deselecting the object.

There is also an enhancement requests about the actual color picker in bug 93813. This one would be obsolete when the document colors work, which is another palette listing all colors used in the current document. However, this feature is not working properly.

Still in favor of WFM/WONTFIX/DUPLICATE.
Comment 9 MarjaE 2016-12-06 18:55:02 UTC
"If you say "it's not obvious" how to set a style you mean that understanding what is part of your "Grey 6" is not clear or how to assemble all properties?"

What?

I don't understand. I want to switch and match colors between objects.

You suggested using styles.

I actually tried using styles. I selected one object, created a style "gray 6," selected another object, changed it to gray 6, and found that LibreOffice changed its size, shape, font size, etc. to match the first object. Which doesn't help.

If we're supposed to use styles to switch and match colors between objects, then we need to be able to *remove* extra properties, so that each style only has one property: fill color for one set of styles, line color for another.

Yes, that's beyond the scope of the original bug.

But, it shows that styles aren't a solution to the original problem.
Comment 10 m.a.riosv 2016-12-06 20:51:28 UTC
Now with 5.2 it's possible to know the exact color.
- Select the object.
- On the side bar select Area.
- Click on the right arrow of the area color,
- Click on custom color,
RGB, HSB and CMYK values of the color are visible at once, so the exact color it's easily reproducible between styles or objects.
More obvious with the new Area box for 5.3.
Comment 11 Heiko Tietze 2016-12-07 08:03:32 UTC
Various options, esp. the rework of recent colors and the new area fill style dialog makes it a WFM.