Bug 94157 - Comments Don't Print in Margins When Locale Set to Hebrew
Summary: Comments Don't Print in Margins When Locale Set to Hebrew
Status: RESOLVED DUPLICATE of bug 93009
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-12 11:22 UTC by Amir Adar
Modified: 2015-09-20 17:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file, as shown inside LibreOffice (Hebrew locale) (13.39 KB, image/png)
2015-09-12 11:23 UTC, Amir Adar
Details
A test file, printed and displayed in Okular (9.85 KB, image/png)
2015-09-12 11:24 UTC, Amir Adar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Amir Adar 2015-09-12 11:22:52 UTC
Setup:
* LibreOffice Writer 4.4.3.2
* Locale set to Hebrew (Tools > Options > Language Settings > Languages > Locale Settings)

To Reproduce:
1. Create a document.
2. Add text to the document.
3. Add comments to the text: The comments appear on the left side of the document.
4. Open the printing dialogue (Ctrl + P).
5. From the "Comments" drop-down menu, select "Place in margins".
6. Print the document to a file or through a printer.

Expected Result:
The comments should be displayed at the page margins.

Actual Result:
* The comments are not displayed.
* There is a big gap between the text and the RIGHT side of the page, where the comments would appear, however, the comments in the document are displayed at the LEFT side.
Comment 1 Amir Adar 2015-09-12 11:23:35 UTC
Created attachment 118633 [details]
A test file, as shown inside LibreOffice (Hebrew locale)
Comment 2 Amir Adar 2015-09-12 11:24:11 UTC
Created attachment 118634 [details]
A test file, printed and displayed in Okular
Comment 3 Buovjaga 2015-09-18 16:45:28 UTC
Do they print for you in some other locale?
For me, they refuse to print even in Finnish or English (USA).

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 4 Buovjaga 2015-09-20 12:23:21 UTC

*** This bug has been marked as a duplicate of bug 93009 ***
Comment 5 Amir Adar 2015-09-20 17:55:10 UTC
Yes, they seem to print fine when setting locale to English (UK).