Bug 81957 - "Print comment on page margin" do not show comment in Print Preview (shown in Print dialog preview)
Summary: "Print comment on page margin" do not show comment in Print Preview (shown in...
Status: CLOSED DUPLICATE of bug 115302
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Preview
  Show dependency treegraph
 
Reported: 2014-07-31 10:08 UTC by Kevin Suo
Modified: 2022-03-08 09:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test odt file with comments (9.53 KB, application/vnd.oasis.opendocument.text)
2014-07-31 10:11 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-07-31 10:08:55 UTC
Steps to reproduce:

1. Enable "Tools - Options - LibreOffice Writer - Printing - Comments: On page margin";
2. Type in some text, insert a comment;
3. Print preview.

-> Comments do not show in print preview.

(Exporting to pdf or real printing shows comments as expected).

4.3.0.4
WinXP SP3
Comment 1 Kevin Suo 2014-07-31 10:11:48 UTC
Created attachment 103745 [details]
test odt file with comments

Just enable "Tools - Options - LibreOffice Writer - Printing - Comments: On page margin", then print preview to observe the issue.

The expected behaviour is: 
what you see in print preview = what you see in exported pdf or real printing.
Comment 2 A (Andy) 2014-07-31 17:39:47 UTC
reproducible with LO 4.3.0.4 (Win 8.1)

@Caolán: Could this maybe be something for you?  I would also suppose to see the comments in the PRINT PREVIEW.
Comment 3 QA Administrators 2015-09-04 02:49:22 UTC Comment hidden (obsolete)
Comment 4 Kevin Suo 2015-09-07 02:02:29 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2016-09-20 10:32:42 UTC Comment hidden (obsolete)
Comment 6 Kevin Suo 2016-09-21 02:18:28 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2017-09-29 08:52:24 UTC Comment hidden (obsolete)
Comment 8 Kevin Suo 2017-11-26 05:42:16 UTC
Bug still exists in:

Version: 6.0.0.0.alpha1+
Build ID:8b8aa6bc010fffbcd47679aa101075d702741f69
CPU 线程:4; 操作系统:Linux 4.13; UI 渲染:默认; VCL: gtk2; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group threaded
Comment 9 elisa wise 2018-10-02 02:32:21 UTC Comment hidden (spam)
Comment 11 ronn91 2019-08-16 08:53:38 UTC Comment hidden (spam)
Comment 12 aladanh 2019-09-30 03:22:27 UTC Comment hidden (spam)
Comment 13 Amit Singh 2019-10-10 04:27:46 UTC Comment hidden (spam)
Comment 14 Luke Garza 2019-10-17 15:37:47 UTC Comment hidden (spam)
Comment 15 Timur 2019-12-10 19:33:45 UTC
Repro 6.5+.
comment not seen in Print Preview, but seen in Preview in Print.
Comment 16 Timur 2019-12-10 19:44:55 UTC
Bug 115302 is related. 
But since we have spam here (and obviously BZ can't get rid of that), I'll mardk this one as a duplicate.

*** This bug has been marked as a duplicate of bug 115302 ***
Comment 18 Anurag gothwal 2020-04-27 11:42:25 UTC Comment hidden (spam)
Comment 19 Tom Hiddleston 2020-09-23 02:47:00 UTC Comment hidden (spam)