Bug 94255 - FILESAVE: XLSX - Column widths not retained
Summary: FILESAVE: XLSX - Column widths not retained
Status: RESOLVED DUPLICATE of bug 91475
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-09-16 04:52 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-11-14 07:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-16 04:52:02 UTC
Steps:
1) Open attachment 114697 [details]
2) Notice that column widths are 1.67cm
3) Save and close and reopen
4) Notice that the column widths are 1.64 cm

This change in width size seems more complicated that just a simple width size change, as the size of chart also has shrunk in width.

Version: 5.1.0.0.alpha1+
Build ID: 88c51cd55d1a9b29e62269c53b3923770253ab07
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-09-11_13:09:15
Locale: en-US (en_US)
Comment 1 raal 2015-09-16 05:00:35 UTC
Duplicate of bug 92753?
Comment 2 Yousuf Philips (jay) (retired) 2015-09-16 06:20:32 UTC
Seems it a regression as it reopens correctly in 4.4.2.

(In reply to raal from comment #1)
> Duplicate of bug 92753?

Not related.
Comment 3 Buovjaga 2015-09-20 15:59:16 UTC
Repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 4 raal 2015-09-30 11:00:33 UTC
bibisected

author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2015-05-20 02:06:46 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2015-05-20 02:07:17 (GMT)
commit	bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322 (patch)
forgot to include that part

author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2015-05-20 01:59:49 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2015-05-20 02:04:13 (GMT)
commit	16726a1b37df8bdcae02b3c7699df814977222bd (patch)
better algorithm for OOXML column width import, tdf#91267

bec7b2530255008c4e07cfb40b8779a4e74d7a16 is the first bad commit
commit bec7b2530255008c4e07cfb40b8779a4e74d7a16
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jun 5 10:17:16 2015 -0500

    source sha:bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322

    source sha:bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322
    source sha:16726a1b37df8bdcae02b3c7699df814977222bd

:040000 040000 aa32f98e45fa70c5153539e0884deb35c3f51f2b f9760d877fd366ca69a4910103e035043dd6f14b M      instdir

 ~/bibisect-win32-5.0
$ git bisect log
# bad: [575cd25f0560684895018d8fcfb1818dd4dd1c9b] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
# good: [f449493ae11ac76cc7396bddeaa624a60c565936] source sha:57d6b92b69a31260dea0d84fcd1fc5866ada7adb
git bisect start 'libreoffice-5-0-branch-point' 'oldest'
# good: [da12357c491a0dce5acc0bd1f00c26f89d8f20e6] source sha:c1b9402d49a7cd4bec383f28d397d9d89541f0e0
git bisect good da12357c491a0dce5acc0bd1f00c26f89d8f20e6
# good: [2783cac5d1f18f44ce31f52eb7ae2f0ea17d0c96] source sha:5d7a203bdae1940e4846c4c42f5d733e4ffa4160
git bisect good 2783cac5d1f18f44ce31f52eb7ae2f0ea17d0c96
# good: [c6b55917df3df447007dbb29dd84f24d1203cfb3] source sha:5b8acf459e4a6728ea656e7abd5dfb08ad2ae345
git bisect good c6b55917df3df447007dbb29dd84f24d1203cfb3
# good: [ac46cb21db25e4b49f28bbe57f5846dbca57e486] source sha:dbf1e124c7fef7cae5392959ab6a697a3a89c609
git bisect good ac46cb21db25e4b49f28bbe57f5846dbca57e486
# good: [eece862e921f0369dbf20571080344aa56577fd0] source sha:6fbda0905d4e721392038bfad9e173e180f788ee
git bisect good eece862e921f0369dbf20571080344aa56577fd0
# good: [1a67d9871788c07ab2b3859145fa62a0aec9f4af] source sha:fb69055c1b505ed09fb170093bab4ecd5bb3fdc7
git bisect good 1a67d9871788c07ab2b3859145fa62a0aec9f4af
# good: [136b816b871f19bbe0c6daf0def2527c41e8c3a1] source sha:f066fd04ab6d8f672c8de33ad1c83adbad5f05a6
git bisect good 136b816b871f19bbe0c6daf0def2527c41e8c3a1
# good: [81088783d161a6865c81373fdbe3e378ab2b5984] source sha:d02c15979b90fe356ee814acd77c4f21edeb2b0f
git bisect good 81088783d161a6865c81373fdbe3e378ab2b5984
# bad: [990c30868ed83d5bd16bab715b00402531331d86] source sha:447783a97777b2053acd74d265af3ed2a6c5c93a
git bisect bad 990c30868ed83d5bd16bab715b00402531331d86
# bad: [934aa51bfafbfdff12725d20cdb07e08344802e7] source sha:78deb81c55266d37e35ff97fbb5b4086245d8ff2
git bisect bad 934aa51bfafbfdff12725d20cdb07e08344802e7
# bad: [bec7b2530255008c4e07cfb40b8779a4e74d7a16] source sha:bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322
git bisect bad bec7b2530255008c4e07cfb40b8779a4e74d7a16
# good: [0ea5bbc13f5d1ddf3a6f8e6b17e8bd5d5b67cba8] source sha:1d2d037b4defa775b164880b56732af2a837f254
git bisect good 0ea5bbc13f5d1ddf3a6f8e6b17e8bd5d5b67cba8
# first bad commit: [bec7b2530255008c4e07cfb40b8779a4e74d7a16] source sha:bcdd3a403ca1d0ac05dd2382cf7e8fdfd3281322
Comment 5 m.a.riosv 2015-10-09 22:04:28 UTC
I think a dup, please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 91475 ***
Comment 6 Robinson Tryon (qubit) 2015-12-15 11:03:15 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 7 Fyodor 2017-11-14 07:02:10 UTC
*** Bug 107973 has been marked as a duplicate of this bug. ***