Bug 94302 - Filesave DOCX: Image Anchor changes from "To Paragraph" to "As Character" and image has wrong position on reopen
Summary: Filesave DOCX: Image Anchor changes from "To Paragraph" to "As Character" and...
Status: RESOLVED DUPLICATE of bug 135581
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Images DOCX-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2015-09-17 06:53 UTC by Jonathan Camilleri
Modified: 2022-02-07 12:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
documents in docs and odt format (1.20 MB, application/x-rar)
2015-09-17 06:53 UTC, Jonathan Camilleri
Details
The offending part of the document in current Writer master (188.38 KB, image/png)
2021-01-20 07:30 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Camilleri 2015-09-17 06:53:40 UTC
Created attachment 118783 [details]
documents in docs and odt format

It is noted that when saving the document in .docx format, table formats and images twist around and are not appealing, is it possible that you quality assure the layout in different formats please?

See page 31 of the docx document attached to start with.

Further reading
1. https://en.wikipedia.org/wiki/OpenDocument_technical_specification
2. https://ask.libreoffice.org/en/question/21580/which-is-the-best-docx-format/ and relevant links.
Comment 1 Buovjaga 2015-09-20 15:34:38 UTC
Confirmed the image on page 31 is not centered in its cell in a docx I saved.
Image anchoring:
ODT: Anchor to paragraph
DOCX: Anchor as character

Could not find a duplicate report.

Frame positions + sizes + backgrounds on page 29 are also messed up in docx. Anchors match, though.

Win 7 Pro 64-bit, Version: 5.0.1.2 (32-bit)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 2 QA Administrators 2016-11-08 10:38:17 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2019-12-03 14:47:34 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-05-29 22:11:23 UTC
Repro 7.1+.
Comment 5 NISZ LibreOffice Team 2021-01-20 07:30:03 UTC
Created attachment 169034 [details]
The offending part of the document in current Writer master

Still the same in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: e828d62503d06ebde0e41dc2d6dcc87c2dc77173
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

The original is a frame with an image and caption inside.
This is converted to a DML shape on export and that only supports "As character" anchoring in Word/docx. Writer generates this correctly, but the layout will change.
Comment 6 Dieter 2022-01-12 16:19:25 UTC
*** Bug 146450 has been marked as a duplicate of this bug. ***
Comment 7 Dieter 2022-01-12 16:22:21 UTC
*** Bug 140219 has been marked as a duplicate of this bug. ***
Comment 8 Dieter 2022-01-12 16:26:35 UTC
Bug 140219 comment 8 from Miklos: "docx only has to-char (anchored) and as-char (inline), so if the request is to preserve to-para in docx, that's a wontfix."


Bug 140219 comment 11 from NISZ-Team: "It seems like the image is anchored to the beginning of the bulleted "Low Color Reference" paragraph and has a 
						<text:soft-page-break/>
in the odt, which is not exported to docx, but other properties seem to be exported fine.

I'm not sure whether there is anything in docx that could be used here."


So is there any solution?
Comment 9 Timur 2022-02-07 12:35:30 UTC
Let's consider a duplicate so far.

*** This bug has been marked as a duplicate of bug 135581 ***