Bug 94411 - In alphabetical indexes f. and ff. should be used - not p. or pp.
Summary: In alphabetical indexes f. and ff. should be used - not p. or pp.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: sdc.blanco
URL:
Whiteboard: target:6.5.0
Keywords:
: 129480 (view as bug list)
Depends on:
Blocks: TableofContents-Indexes TableofContents-Indexes-Dialog
  Show dependency treegraph
 
Reported: 2015-09-21 14:19 UTC by Bernard Moreton
Modified: 2020-02-01 00:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document (16.47 KB, application/vnd.oasis.opendocument.text)
2020-01-06 09:15 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Moreton 2015-09-21 14:19:18 UTC

    
Comment 1 Bernard Moreton 2015-09-21 14:21:03 UTC
There seems to be no provision for the normal UK english usage of Nf, Nff. This would be highly desirable
Comment 2 Buovjaga 2015-09-22 13:29:34 UTC
I don't understand what these Np, Npp, Nf, Nff mean, but I'll set to NEW anyway.
Perhaps you could explain a bit more, either with steps or with a screenshot.
Comment 3 Bernard Moreton 2015-09-22 16:52:02 UTC
On going to Insert Index/Table, Type 'Alphabetical Index', tghere is an option to "Combine identical entries with p or pp".

This results, for example in
INDEX_ENTRY, 3p,17pp

In UK English, the first is a monetary value, and the second is an abbreviation for "17 pages".  The usage should be (in this instance) 3f,17ff.

UK English practice also allows for (eg) p3 or pp17ff/pp17-19

I cannot find any US examples to support the trailing 'p'/'pp'.  Canadian pracice seems to be the same as in the UK.
Comment 4 QA Administrators 2016-11-08 10:29:17 UTC Comment hidden (obsolete)
Comment 5 Bernard Moreton 2016-11-09 10:49:39 UTC
The issue is still present in 5.2.3.2 on Ubuntu 16.04 LTS, though the entry in the Insert dropdown is now 'Table of Contents,Index or Bibliography'.  The only entry for combining page references is still (in the EN-UK environment) 'p/pp', where it should be 'f/ff'.
Comment 6 R. Green 2020-01-01 13:59:38 UTC
*** Bug 129480 has been marked as a duplicate of this bug. ***
Comment 7 R. Green 2020-01-01 14:02:11 UTC
It is correct to use p. (page) and pp. (pages) BEFORE the page range of a cited reference text. However, they should not be used in an index.

The correct abbreviations which should be substituted are f. (and the following page); and ff. (and the following pages). These are placed after the first page number, and separated from it by a thin space (according to "New Hart's Rules").

(Duplicated at Bug 129480)
Comment 8 sdc.blanco 2020-01-01 19:04:17 UTC
(In reply to Bernard Moreton from comment #5)
> The only entry for combining page references is still (in the EN-UK
> environment) 'p/pp', where it should be 'f/ff'.

I believe the actual behavior is p. / pp.

Also, at present, the en_GB locale is defined as identical to en_US, which has a period after the p. and pp.  Will that be acceptable (if the p/pp is changed to f./ff.)?

(In reply to R. Green from comment #7)
> The correct abbreviations which should be substituted are f. (and the
> following page); and ff. (and the following pages). 

As a workaround, try setting "Locale setting" to Danish (in Tools > Options > Language Settings - Language)
Comment 9 sdc.blanco 2020-01-01 21:41:05 UTC
(In reply to sdc.blanco from comment #8)
 
> As a workaround, 

Even easier -- 

in the dialog box, where you have chosen p and pp, set the Sort Language to be Danish, German or Swedish -- and you will get f. and ff. (instead of p. and pp.)

No need to change the Locale setting in the Options
Comment 10 Heiko Tietze 2020-01-06 09:15:10 UTC
Created attachment 156959 [details]
Example document

Dummy text with "he" and "heard" being indexed to show up in the alphabetical index as "p." or "pp." respectively.
Comment 11 Commit Notification 2020-01-08 08:18:20 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/64d0e5cfb8e9b05b5de02121b948c15b94310204

tdf#94411 use f. and ff. in alphabetical index

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-01-08 22:15:14 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/5f5d1373c85c9de0cc9a906e9d8c4a78dab64740

tdf#94411 update help for Index page
Comment 13 Mihkel Tõnnov 2020-01-23 15:08:14 UTC
There are many more locales which currently have "p./pp." in this context: https://opengrok.libreoffice.org/search?project=core&project=cppunit&full="<FollowPageWord>p"+"<FollowPageWord>pp"&defs=&refs=&path=i18npool%2Fsource%2Flocaledata%2Fdata&hist=&type=&n=25

How should those be approached? Presumably most (if not all) of them could be changed to the latinate "f./ff." without making the situation worse (as "p./pp." there most likely just mirrored the English locale anyway), but "f./ff." might not actually be a known/used abbreviation in all locales. Is there a database that would list such abbreviations? CLDR doesn't seem to include it...

Or should native-language teams just step up and ask to have theirs fixed one by one?
Comment 14 Bernard Moreton 2020-01-23 15:19:40 UTC
In body text, pN, ppN-M are specific, [p]Nf is also specific (this page and the following one), but [p]Nff is indeterminate (doesn't say where the instances will end).
In the index, despite Harts Rules, international usage probably prefers "N-M" rather than Nff
Comment 15 Mihail Balabanov 2020-01-31 23:21:04 UTC
Since the issue is marked as resolved, what has been decided in respect to other locales? I think the abbreviation used in Bulgarian bibliographic data is ‘стр. X и сл.’, meaning ‘page X and next page/pages’. In an index it could be shortened to ‘X и сл.’ but currently LO shows ‘Xстр.’, which is incorrect. I couldn’t find a respective string in Weblate to fix it; is it hardcoded, or maybe taken from elsewhere? What about other locales?
Comment 16 sdc.blanco 2020-02-01 00:26:12 UTC
(In reply to Mihail Balabanov from comment #15)
> Since the issue is marked as resolved, what has been decided in respect to
> other locales?
afaik, nothing.

> is it hardcoded, or maybe taken from elsewhere? 
The index abbreviations are hard-coded. 
https://opengrok.libreoffice.org/xref/core/i18npool/source/localedata/data/bg_BG.xml?r=a40c56aa#205

The user interface should be translatable. 

> What about other locales?
Some of them are "correct" according to locale. Some are probably not. The relevant locale files are here.

https://opengrok.libreoffice.org/xref/core/i18npool/source/localedata/data/

The relevant section is  <LC_INDEX>