Download it now!
Bug 94418 - Improve referencing system / references in LO Writer
Summary: Improve referencing system / references in LO Writer
Status: RESOLVED DUPLICATE of bug 121958
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 95315 (view as bug list)
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2015-09-21 17:51 UTC by Bastián Díaz
Modified: 2019-02-05 20:22 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2015-09-21 17:51:08 UTC
LibreOffice has a poor referencing system, making it necessary to use third-party extensions to solve this feature. Unfortunately, these options are not fully integrated.

I think a good referencing system should allow:
-Collect and organize information from different sources. Local import and web import.
-Allow cited in the text and create lists of references, supporting the known/used styles
-Share that information with other applications in LibreOffice, and allow the export of such a standard format.

A good referral system for LibreOffice will improve its use for creating reports and scientific papers, publications, books, academic reports, university theses, etc.

Note: Personally, I prefer a Zotero integration at the core of LibreOffice that allows work locally with all its features and can connect to Zotero account on the web.

cheers
Comment 1 Yousuf Philips (jay) (retired) 2015-09-22 13:58:07 UTC
Heiko and I planned to go through the referencing system as part of a friday design session, but we never got around to it. You can see the beginning stuff about it in the following google doc, along with suggestions from others.

https://docs.google.com/document/d/1IQ2_dFlWodb3NI9VFy1l4_ZmKpJgoyATYvOmB-0yUcY/edit?usp=sharing
Comment 2 V Stuart Foote 2016-03-24 16:41:45 UTC
*** Bug 95315 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2018-12-07 08:27:34 UTC
*** Bug 121945 has been marked as a duplicate of this bug. ***
Comment 4 Cor Nouws 2019-02-05 20:22:34 UTC
with the extensive description in bug 121958, the issue is best served by closing this report as a duplicate.

*** This bug has been marked as a duplicate of bug 121958 ***