Bug 94438 - Duplicates of IDs in help files
Summary: Duplicates of IDs in help files
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2015-09-22 10:03 UTC by tagezi
Modified: 2018-04-13 11:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tagezi 2015-09-22 10:03:15 UTC
There are the double IDs in Help files. Likely, this do not allow to find the help for some functions. I try to correct IDs, but I get the unexpected result.
For example:
1) Open Calc 5.0
2) Open Function Wizard
3) Find ISNA and IFNA function
4) If we try to press F1, we go to IFNA function Help for both cases
The discription for these functions exist in ../helpcontent2/source/text/scalc/01/04060104.xhp file. IDs is bm_id3159273.
5) For example: Сhange the ID for ISNA to bm_id276122693712324.
6) make
7) check again (steps 1-4 for master)

The IFNA function is shown correctly. The ISNA function is not shown. We see somethin on the pages and we need to move in the bottom of the page.

This situation is for follow IDs:
../helpcontent2/source/text/scalc/01/04060104.xhp		bm_id3159273
../helpcontent2/source/text/scalc/01/04060185.xhp		bm_id3150405
../helpcontent2/source/text/scalc/01/04060181.xhp		bm_id2947521
../helpcontent2/source/text/scalc/01/04060184.xhp		bm_id2950709

Changes to these lead to nothing:
../helpcontent2/source/text/scalc/01/statistics.xhp		bm_id05004
../helpcontent2/source/text/scalc/01/statistics.xhp		bm_id05003
../helpcontent2/source/text/scalc/01/statistics.xhp		bm_id05002

Also, there are duplicates in the files, but I have not researched:
../helpcontent2/source/text/shared/guide/start_parameters.xhp	par_id315053
../helpcontent2/source/text/shared/guide/start_parameters.xhp	par_id314959
../helpcontent2/source/text/shared/explorer/database/menuview.xhp bm_id2862636
../helpcontent2/source/text/shared/explorer/database/menuedit.xhp bm_id1720023
../helpcontent2/source/text/swriter/01/mm_seladdblo.xhp	bm_id6604815
../helpcontent2/source/text/swriter/01/mailmerge06.xhp	bm_id9046601
../helpcontent2/source/text/swriter/01/mailmerge01.xhp	bm_id9740592
../helpcontent2/source/text/swriter/01/mailmerge00.xhp	bm_id9926450
../helpcontent2/source/text/swriter/01/06100000.xhp		bm_id6670125
../helpcontent2/source/text/swriter/01/04120250.xhp		par_id3155907
../helpcontent2/source/text/smath/01/05040000.xhp		bm_id3145596
../helpcontent2/source/text/smath/01/03090200.xhp		bm_id3150844
../helpcontent2/source/text/simpress/01/05120100.xhp		bm_id3154756
../helpcontent2/source/text/shared/optionen/java.xhp		bm_id6882839
../helpcontent2/source/text/shared/optionen/01150100.xhp	bm_id3149811
../helpcontent2/source/text/shared/optionen/01110100.xhp	bm_id4940946
../helpcontent2/source/text/shared/optionen/01010301.xhp	bm_id3154938
../helpcontent2/source/text/shared/optionen/01010301.xhp	bm_id3150768
../helpcontent2/source/text/shared/guide/tabs.xhp		par_id3151059
../helpcontent2/source/text/shared/explorer/database/menuview.xhp bm_id4928739
../helpcontent2/source/text/shared/explorer/database/menuview.xhp bm_id2447279
../helpcontent2/source/text/shared/explorer/database/menuview.xhp bm_id1720023
../helpcontent2/source/text/shared/explorer/database/menuview.xhp bm_id1669362
../helpcontent2/source/text/shared/explorer/database/menuinsert.xhp bm_id4928739
../helpcontent2/source/text/shared/explorer/database/menuinsert.xhp bm_id1720023
../helpcontent2/source/text/shared/explorer/database/menuedit.xhp bm_id4928739
../helpcontent2/source/text/shared/explorer/database/menuedit.xhp bm_id2862636
../helpcontent2/source/text/shared/explorer/database/menuedit.xhp bm_id244727 
../helpcontent2/source/text/shared/explorer/database/menuedit.xhp bm_id1669362
../helpcontent2/source/text/shared/01/password_dlg.xhp	bm_id3152878
../helpcontent2/source/text/shared/01/06150120.xhp		bm_id3148731
../helpcontent2/source/text/shared/01/06140500.xhp		bm_id1800286
../helpcontent2/source/text/shared/01/05230500.xhp		bm_id3149999
../helpcontent2/source/text/shared/01/02250000.xhp		bm_id4552446
../helpcontent2/source/text/shared/01/02180000.xhp		bm_id4889980
../helpcontent2/source/text/shared/01/02100000.xhp		bm_id6146427
../helpcontent2/source/text/shared/01/02070000.xhp		bm_id3154101
../helpcontent2/source/text/shared/00/01010000.xhp		bm_id3155892
../helpcontent2/source/text/shared/00/00000001.xhp		bm_id3147576
../helpcontent2/source/text/scalc/01/12090102.xhp		bm_id3154514
../helpcontent2/source/text/sbasic/guide/translation.xhp	bm_id1646778
../helpcontent2/source/text/sbasic/shared/01050300.xhp	bm_id3149656
../helpcontent2/source/text/schart/01/04030000.xhp		bm_id3144511
../helpcontent2/source/text/schart/01/04050000.xhp		bm_id877102
../helpcontent2/source/text/schart/01/05020201.xhp		bm_id8467056
../helpcontent2/source/text/shared/00/00000001.xhp		bm_id3147576
Comment 1 Yousuf Philips (jay) (retired) 2015-09-22 10:16:26 UTC
Yes i can that the id bm_id4928739 appears twice in source/text/shared/explorer/database/menuview.xhp.

<bookmark xml-lang="en-US" branch="hid/.uno:DBViewReports" id="bm_id4928739" localize="false"/>

<bookmark xml-lang="en-US" branch="hid/.uno:DBDisablePreview" id="bm_id4928739" localize="false"/>
Comment 2 chaitanya7991@gmail.com 2015-10-20 16:41:26 UTC
I would like to work on this bug.
Comment 3 QA Administrators 2016-11-08 11:33:34 UTC Comment hidden (obsolete)
Comment 4 Olivier Hallot 2018-04-12 18:07:31 UTC
Changes at 

../helpcontent2/source/text/scalc/01/04060104.xhp		bm_id3159273
../helpcontent2/source/text/scalc/01/04060185.xhp		bm_id3150405
../helpcontent2/source/text/scalc/01/04060181.xhp		bm_id2947521
../helpcontent2/source/text/scalc/01/04060184.xhp		bm_id2950709

are valid. Patch submitted.

Changes in 

../helpcontent2/source/text/scalc/01/statistics.xhp		bm_id05004
../helpcontent2/source/text/scalc/01/statistics.xhp		bm_id05003
../helpcontent2/source/text/scalc/01/statistics.xhp		bm_id05002

are not necessary because the same ID is used in different branch type (hid or index)

(more to come)
Comment 5 Commit Notification 2018-04-12 18:37:28 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=ba894a341a96b89e0dd18161abbd148fb410a389

tdf#94438 Fix dup bookmark branches
Comment 6 Commit Notification 2018-04-12 18:39:50 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=b5aad7c2f22be97d0d20ca7b31875fcaa55309a3

tdf#94438 disambiguate bookmark branch id's
Comment 7 Commit Notification 2018-04-12 20:01:34 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=c81535cf7d904c8c7625d66d3ba67f36f9d07f59

tdf#94438 disambiguate bookmark branch (ii)
Comment 8 Commit Notification 2018-04-12 20:02:53 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=2c5257ffbfa02e432a80f37fdfe6c9aa3280c873

tdf#94438 disambiguate bookmark branches (iii)