Bug 94582 - Formula editor UI flickers on mouse movement
Summary: Formula editor UI flickers on mouse movement
Status: RESOLVED DUPLICATE of bug 65584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError
Depends on:
Blocks: VCL-Scheduler Flickering-UI
  Show dependency treegraph
 
Reported: 2015-09-28 17:55 UTC by Kevin McDonough
Modified: 2018-09-08 18:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (3.04 KB, text/plain)
2017-10-05 08:23 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin McDonough 2015-09-28 17:55:05 UTC
As the mouse cursor hovers over the UI for the formula editor (not checked for other UIs) the images flicker. The flickering is stronger further down the interface (no flickering for first item), looking like an overzealous redraw. It seems to clearing the GUI and begin writing the new draw to the screen before the whole GUI is rendered.
Comment 1 Buovjaga 2015-10-02 08:10:48 UTC
Confirmed.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (fi_FI)
Comment 2 Celcius 2015-10-26 10:02:58 UTC
The description done by K. McDonough is what I have on my computer.
Comment 3 QA Administrators 2016-11-08 11:57:52 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2017-05-19 14:47:27 UTC
in LO 5.4 beta1 flickering became even stronger!

Video: intel HD4000 on Windows 7

Version: 5.4.0.0.beta1
ID build: 8672113ead4e403c55e31b1d9a3d1e0f3b299577
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group

opengl_device.log

DriverVersion: 9.17.10.4229
DriverDate: 5-26-2015
DeviceID: PCI\VEN_8086&DEV_0166&SUBSYS_21F717AA&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0166
AdapterSubsysID: 0x21f717aa
DeviceKey: System\CurrentControlSet\Control\Video\{92E621FD-7AE7-489A-8F2F-47AFD10834D8}\0000
DeviceString: Intel(R) HD Graphics 4000
Comment 5 Aron Budea 2017-07-15 14:35:22 UTC
The flickering was already there when this feature was added in 4.1, so adding implementationError keyword.

The commit where the flickering became worse is:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
author		Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 03:15:14 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 13:22:53 (GMT)

"tdf#103831, tdf#100986: Force using GDI when needed"

This commmit brought forth other bugs as well (but it's not directly responsible for those), see bug 107166 or bug 108236.
Comment 6 Telesto 2017-10-05 08:20:03 UTC
(In reply to Aron Budea from comment #5)
> The flickering was already there when this feature was added in 4.1, so
> adding implementationError keyword.
> 

The bibisect results aren't correct. The problem is older: see comment 1
Hoovering over the Formula dialog will flicker. Not always in the same extend, but it will eventually (depending on LibO version)

Also: still a repro with:
Version: 6.0.0.0.alpha0+
Build ID: b087e451527f2e497ccab83b63b4f10099bfb8b8
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-03_23:43:39
Locale: nl-NL (nl_NL); Calc: CL

I can reproduce it also on Linux. 

I did a bibisect:
# only skipped commits left to test
# possible first bad commit: [18afb8632caa524fbc70ed5ce3808e23e5dad16f] source-hash-d05a64df34fd143670cb939b72abfb32d6b714c7
# possible first bad commit: [891b689ba95b9e53609194ee2a1a2d3b8955843c] source-hash-01f406bc28f53acc5a2734af637aa8074a5d1813

------
author	Tobias Madl <tobias.madl.dev@gmail.com>	2015-03-06 13:48:18 (GMT)
committer	Tobias Madl <tobias.madl.dev@gmail.com>	2015-03-06 13:51:48 (GMT)
commit	d05a64df34fd143670cb939b72abfb32d6b714c7 (patch)
tree	3dc542680cd3728419b9c95e34325f42047986e5
parent	01f406bc28f53acc5a2734af637aa8074a5d1813 (diff)

Timer/Idle: adapted inherited funktions
Change-Id: I7714a4638b03d020820b276028c0819ef054fa26

-----
author	Tobias Madl <tobias.madl.dev@gmail.com>	2015-03-06 10:39:49 (GMT)
committer	Tobias Madl <tobias.madl.dev@gmail.com>	2015-03-06 12:27:12 (GMT)
commit	01f406bc28f53acc5a2734af637aa8074a5d1813 (patch)
tree	43b42f4730a775e092a6ff809a006449f9f47975
parent	b6bb2e9315c9bc3338eaf066df40a969eb4774aa (diff)
adapted comments and variable names
Change-Id: I4f2c1d743ce2f30e8c24180b73f0716fc13b459e
Comment 7 Telesto 2017-10-05 08:23:49 UTC
Created attachment 136775 [details]
Bibisect log
Comment 8 Telesto 2017-10-06 21:50:13 UTC
@Jan Marek
You might be interested in this one. It has a timer/scheduler aspect; not sure if it's the root cause, though.
Comment 9 Aron Budea 2017-11-11 10:00:02 UTC
(In reply to Telesto from comment #6)
> (In reply to Aron Budea from comment #5)
> > The flickering was already there when this feature was added in 4.1, so
> > adding implementationError keyword.
> > 
> 
> The bibisect results aren't correct. The problem is older: see comment 1
> Hoovering over the Formula dialog will flicker. Not always in the same
> extend, but it will eventually (depending on LibO version)

I pointed to 4.1 as the oldest version, see the exact sentence you quoted. I only checked on Windows, but the flickering is clearly there in 4.1.0.4.
Comment 10 Buovjaga 2018-04-30 17:46:59 UTC

*** This bug has been marked as a duplicate of bug 65584 ***