Bug Hunting Session
Bug 108236 - Text in EMF looks worse since 5.3.2.2 esp. with default rendering (in 6.0+ only in presentation mode) (DirectWrite)
Summary: Text in EMF looks worse since 5.3.2.2 esp. with default rendering (in 6.0+ on...
Status: RESOLVED DUPLICATE of bug 107090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering EMF-WMF DirectWrite DirectWrite-Regression
  Show dependency treegraph
 
Reported: 2017-05-30 06:06 UTC by Aron Budea
Modified: 2017-10-04 21:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (132.63 KB, image/png)
2017-05-30 06:06 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-05-30 06:06:28 UTC
Created attachment 133715 [details]
Screenshot

- Turn off OpenGL rendering by unticking Tools -> Options...; LibreOffice -> View -> Use OpenGL for all rendering.
- Open attachment 124817 [details] (from bug 99651).

=> See attached screenshot. It looks much worse than in previous releases.

Looks bad starting with 5.3.2.2 / Windows 7 (but also in 5.4beta1), looks fine/better in 5.3.1.2. => regression

Bibisecting the bug pointed to the same commit as bug 107942, however it just switched to using different rendering, and isn't responsible for the bad rendering itself.
There's also bug 106990, but the quality of rendering is really something else here.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a51b7a1c3a7e7cf7b0c733e1dec40288278c1884
author		Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 03:15:14 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2017-03-03 13:22:53 (GMT)

"tdf#103831, tdf#100986: Force using GDI when needed"
Comment 1 Telesto 2017-05-30 07:37:38 UTC
Confirming a difference in rendering
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

It looks fine when disabling hardware acceleration (maybe related to bug 107090?)
Comment 2 V Stuart Foote 2017-05-30 13:12:17 UTC
Imagemagick identify shows the image to be low resolution of 501x281 pixels at ~72 ppi.

2000017F000044DA000026A654C04DA59551CB5D.wmf WMF 501x281 501x281+0+0 16-bit sRGB 0.000u 0:00.004

However the poor rendering to canvas only occurs when "Use hardware acceleration" is set active.  CPU only, or OpenGL based rendering produces a rendering to canvas of higher quality.

This appears to be a duplicate of bug 107090
Comment 3 V Stuart Foote 2017-05-30 13:16:43 UTC
@Aron, what happens on your system if you disable "Use hardware acceleration" and render with CPU only?
Comment 4 Aron Budea 2017-05-30 20:10:26 UTC
Stuart, indeed that is the case.
Comment 5 Aron Budea 2017-07-17 01:40:26 UTC
Looks kind of like this issue: http://xboxforums.create.msdn.com/forums/t/97583.aspx
Not really useful, as there are no solutions suggested there, only a problem statement, but it might be good enough of a hint on where to look for the bug.
Comment 6 Timur 2017-08-24 18:23:44 UTC
Looks fine to me with master in Windows with HW ACC and GDI.
Comment 7 Aron Budea 2017-09-24 04:28:59 UTC
(In reply to Timur from comment #6)
> Looks fine to me with master in Windows with HW ACC and GDI.

Yes (possibly due to the rewritten EMF plus renderer?), but still bad in presentation mode.
Comment 8 V Stuart Foote 2017-10-04 18:27:43 UTC
So this was a duplicate of mishandling the GDI fallback.

Fixed in master, 5.4 and 5.3

https://cgit.freedesktop.org/libreoffice/core/commit/?id=01f674a95ddec76dc4c8ecfccdca1773657e47cb

*** This bug has been marked as a duplicate of bug 107090 ***
Comment 9 Xisco Faulí 2017-10-04 20:57:28 UTC
This is a problem in DirectWrite, thus it's not fixed. My commit only changes the behaviour to use GDI instead, as it was before. The plan is to move to DirectWrite at some point. Keeping it open.
Comment 10 V Stuart Foote 2017-10-04 21:17:10 UTC

*** This bug has been marked as a duplicate of bug 107090 ***
Comment 11 V Stuart Foote 2017-10-04 21:20:55 UTC
Nothing to do with processing the WMF in the ODF Presentation (not even an EMF/EMF+), issue was strictly DirectWrite font handling for rendering to presentation canvas when HA is enabled which is bug 107090