Download it now!
Bug 94721 - FILEOPEN: some emojis not displayed
Summary: FILEOPEN: some emojis not displayed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.1 rc
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-03 06:47 UTC by tommy27
Modified: 2016-11-19 08:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (43.64 KB, image/png)
2015-10-03 06:47 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2015-10-03 06:47:10 UTC
Created attachment 119228 [details]
screenshot

this is a spin-off of Bug 94655 - Emoji not Visible in Exported PDF

this is about the display of emojis in an .odt file
the .PDF export issues shoul be discussed in the other report

STEPS TO REPRODUCE

- load attachment 119151 [details] in different LibO releases
- compare with screeshot

correct behaviour is the one in LibO 4.4.5.1 where all 3 emojis are correctly displayed

buggy behaviour happens in 5.0.2.1 where no emoji is shows and in a recent 5.1.0.0 alpha build where only the phone emoji is missing

this is a 5.0.x regression, partially solved in 5.1.x
Comment 1 Buovjaga 2015-10-03 14:32:16 UTC
I have shocking announcement to make: it depends on the zoom level in 5.0!
Actually in 5.1 all the 3 emojis are displayed no matter how I zoom it.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 25de5cfa43b2b1cb7d7214470acc7719839e13fe
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-01_08:49:54
Locale: en-US (fi_FI)
Comment 2 Iandol 2015-10-04 20:05:12 UTC
On OS X 10.11 the emoji display without issue on both 5.0.2 and 5.1alpha, irrespective of zoom level ;-)
Comment 3 tommy27 2015-10-05 05:43:11 UTC
hi there. I don't see the phone emoji in LibO 5.1.0.0.alpha1+ (x64)
Build ID: 8c7ba16ba4bdedb4354f342b20d5a5de8a132b48
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-24_21:53:09
Locale: it-IT (it_IT)

I'll retest later with a more recent daily build but I wonder if my issue here is a side effect of Bug 92940 - many Emojis do not work

please Beluga and Iandol, would you please take a look at that bug and compare my screenshot in  attachment 117448 [details] ?
Comment 4 Julien Nabet 2015-10-07 21:09:51 UTC
On pc Debian x86-64 with master sources updated today, phone appears like a rectangle, the 2 other emojis are ok.
Does it need some specific fonts?
Comment 5 Julien Nabet 2015-10-07 21:16:21 UTC
Typing manually U+0260E makes a phone appear.
What's the Unicode character used in the doc for the phone?
Comment 6 László Németh 2015-10-08 10:01:37 UTC
(In reply to Julien Nabet from comment #5)
> Typing manually U+0260E makes a phone appear.
> What's the Unicode character used in the doc for the phone?

It seems, this is the Unicode Character 'TELEPHONE RECEIVER' (U+1F4DE). The other characters are Unicode BMP characters, so this issue seems to be an automatic font replacement issue of the non-BMP characters (the text font is Graublau sans, and likely that font doesn't contain these pictograms).
Comment 7 V Stuart Foote 2016-11-02 15:43:25 UTC
Believe this was fixed on Windows for work on bug 71603, will be available in 5.3.0

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03bff1b6b953e4b7a54d2fb7bbf366bea7e959d9

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d39c2013374727b1c8f147b8b99d54402a7ff02

Could folks on Windows check with a post 20161102 master.

For other OS, not sure--do you have a font with coverage of the Code Point? Or is it related to bug 90043 where only the system font is being used for the AutoCorrect options replacement glyphs.
Comment 8 Buovjaga 2016-11-14 16:15:22 UTC
Works here for what it's worth.

Win 8.1 32-bit
LibO Version: 5.3.0.0.alpha1+
Build ID: c5f5b3e5334c52502c1de28828a44ad469c68850
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-14_06:24:19
Locale: fi-FI (fi_FI); Calc: group
Comment 9 tommy27 2016-11-19 08:44:30 UTC
I confirm it's fixed too under Win 8.1 x64 using latest 5.3.x daily build