Bug Hunting Session
Bug 94741 - Print dialog has pink in collate background (Win10)
Summary: Print dialog has pink in collate background (Win10)
Status: RESOLVED DUPLICATE of bug 94384
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-10-03 21:46 UTC by spartanhooah
Modified: 2015-10-15 17:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bug in german print dialog with windows 10 (55.56 KB, image/jpeg)
2015-10-06 09:11 UTC, Oliver Ostertag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description spartanhooah 2015-10-03 21:46:29 UTC
As can be seen in the image https://i.imgur.com/PYf4nPo.png, the collate image background is pink. This seems unintentional.
Comment 1 tommy27 2015-10-04 12:07:22 UTC
I don't reproduce it under Win8.1 x64 using LibO 4.4.5.1, 5.0.2.1 and recent 5.1.0.0 alpha daily build

which is your O/S?  do you have some special Windows theme?
did you try resetting the user profile?
Comment 2 spartanhooah 2015-10-04 15:19:49 UTC
I'm on Windows 10. No theme. I did try restting the profile, but forgot to mention that in the 2nd and 3rd bug reports I submitted yesterday.
Comment 3 tommy27 2015-10-04 15:27:37 UTC
maybe a Win10 specific issue
Comment 4 spartanhooah 2015-10-04 15:31:28 UTC
(In reply to tommy27 from comment #3)
> maybe a Win10 specific issue

Could be, but bugzilla groups all Windows versions together, so I couldn't select a specific version. I probably should have included that in my post, though.
Comment 5 tommy27 2015-10-04 15:41:30 UTC
added (Win10) to summary notes
Comment 6 Oliver Ostertag 2015-10-06 09:11:02 UTC
Created attachment 119333 [details]
Bug in german print dialog with windows 10

Confirmed the bug in my german LibreOffice 5.0.2.2 Print Dialog with german Windows 10 installed.
Comment 7 Oliver Ostertag 2015-10-06 09:12:30 UTC
Confirmed the bug in my german LibreOffice 5.0.2.2 Print Dialog with german Windows 10 installed.
Comment 8 Oliver Ostertag 2015-10-06 09:28:51 UTC
Confirmed, reproduced the bug in my german LibreOffice 5.0.2.2 Print Dialog with german Windows 10 installed.
Comment 9 Adolfo Jayme 2015-10-08 16:44:25 UTC
Idea: it could be related to the new OpenGL rendering, which was enabled by default in 5.0.2.
Comment 10 Oliver Ostertag 2015-10-08 19:05:53 UTC
Test with 5.0.2.2: can still reproduce the bug with option "OpenCL" disabled.
Comment 11 Maxim Monastirsky 2015-10-08 19:13:56 UTC
(In reply to Oliver Ostertag from comment #10)
> Test with 5.0.2.2: can still reproduce the bug with option "OpenCL" disabled.
Don't confuse "OpenCL" with "OpenGL". The latter is under Tools->Options...->LibreOffice->View. Try to disable it and restart LO.
Comment 12 Oliver Ostertag 2015-10-09 09:08:40 UTC
(In reply to Maxim Monastirsky from comment #11)
> Don't confuse "OpenCL" with "OpenGL". The latter is under
> Tools->Options...->LibreOffice->View. Try to disable it and restart LO.

Yes, i can confirm that. The bug is related to OpenGL rendering. I reproduced it (LO 5.0.2.2, german) with activated OpenGL rendering. When disabled the print dialog looks fine.
Comment 13 Michael Meeks 2015-10-09 12:04:16 UTC
Tomaz - could be some odd bit depth png issue as for some toolbar icons ?
Comment 14 Tomaz Vajngerl 2015-10-09 15:09:53 UTC
yes, it is possible - but why pink :)
Comment 15 Michael Meeks 2015-10-15 17:37:08 UTC
I used to be able to reproduce this, the pink would come from missing the 1-bit mask for those images and the default BG color there (and in all -very- old images of that type). With Tomaz' fix for bug#94384 I don't get this issue any more but without it I do =)

Thanks Tomaz !

*** This bug has been marked as a duplicate of bug 94384 ***