Download it now!
Bug 95029 - Find and Replace: search for character styles
Summary: Find and Replace: search for character styles
Status: RESOLVED DUPLICATE of bug 78582
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 95683 (view as bug list)
Depends on:
Blocks: Matters-to-Caolan
  Show dependency treegraph
 
Reported: 2015-10-14 02:05 UTC by Apt
Modified: 2016-03-09 09:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Apt 2015-10-14 02:05:57 UTC
As far as I've been able to determine, there is no functionality provided by default in LibreOffice Writer to search by character style, although it is provided for paragraph style. Someone raised this issue in 2013 [here](https://ask.libreoffice.org/en/question/21867/writer-how-can-i-search-for-character-syle/), but the solution provided (an extension called [AltSearch](http://extensions.libreoffice.org/extension-center/alternative-dialog-find-replace-for-writer)) "has not had a release in over 1 year and may no longer be maintained." Even if it were up to date, I would prefer the reliability of default integration for this "Search for character style" functionality than to rely on an extension that would require attention from time to time, could face at least temporary setbacks with new versions of LibreOffice, and could still eventually become unsupported. So is this something that LibreOffice's developers would be willing to consider?

By the way, I originally posted this at https://ask.libreoffice.org but was informed that this was a more appropriate venue.
Comment 1 Joel Madero 2015-10-14 03:21:28 UTC
Valid request - moving to NEW.

Note: Enhancements are handled almost entirely by volunteers. Thus, this enhancement would only be implemented if a volunteer found it interesting enough to do. We do not provide ETA's or voting. The result, it could be added tomorrow (incredibly unlikely), or never.

Thanks for the suggestion. As for the note on the extension - don't stress the 1 year, it probably just means it still works fine so no need to release a new version.
Comment 2 Cor Nouws 2015-11-09 09:11:01 UTC
*** Bug 95683 has been marked as a duplicate of this bug. ***
Comment 3 jirib 2015-11-09 10:24:24 UTC
I would find this handy too because I wanted to replace a character style for italic with markdown syntax. Not sure if it is possible but this is how I discovered character styles are not supported in Find & Replace dialog :)
Comment 4 Cor Nouws 2016-03-09 09:31:08 UTC
Ah, already filed before :)

*** This bug has been marked as a duplicate of bug 78582 ***