Bug 95050 - Font background atttribute in styles: no UI to modify fo:background-color
Summary: Font background atttribute in styles: no UI to modify fo:background-color
Status: RESOLVED DUPLICATE of bug 88276
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Matters-to-Caolan
  Show dependency treegraph
 
Reported: 2015-10-14 12:12 UTC by Jerome Fenal
Modified: 2016-02-19 20:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jerome Fenal 2015-10-14 12:12:36 UTC
In Impress, possibly with slides either imported from earlier versions or from PowerPoint, font background style are set to a plain color with the attribute fo:background-color="#ffffff".

In order to set the background to the default one, one has to save the file as fodp, remove the attribute using vi/sed/perl, and re-open the file in LO Impress.

Would it be possible to add a way to modify this attribute within the ui, both in direct character format setings, or style character format settings ?
Comment 1 Buovjaga 2015-10-14 17:26:10 UTC
Could you attach an example document, so we can quickly confirm?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Michael Stahl (allotropia) 2015-10-23 16:22:02 UTC
the erroneous white background color was caused the very serious bug 88295.

there is actually UI to modify the background color but only in 5.0, see:

https://wiki.documentfoundation.org/ReleaseNotes/5.0#Impress_and_Draw

because this is new UI with new translation strings it cannot be backported to 4.4.

i've just found out that it also works to round-trip an affected ODP file through LO 4.3, apparently that version didn't support the background color at all yet so it makes everything transparent again.

so i think this is a duplicate of bug 88276
Comment 3 Michael Stahl (allotropia) 2016-02-19 20:28:11 UTC
seems i should have resolved this DUPLICATE

*** This bug has been marked as a duplicate of bug 88276 ***