Download it now!
Bug 95184 - Online Update tab is missing in LibreOffice 5.x for x86 Windows XP
Summary: Online Update tab is missing in LibreOffice 5.x for x86 Windows XP
Status: RESOLVED DUPLICATE of bug 100295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: x86 (IA32) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-10-19 17:32 UTC by Pedro
Modified: 2016-07-08 17:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Options dialog from version 5.0.0.5 under Windows XP x86 (21.72 KB, image/png)
2015-10-19 17:32 UTC, Pedro
Details
Screenshot of Options dialog of LO 5.0.3.2 x86 under Win7 x64 (42.17 KB, image/png)
2015-11-09 15:12 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2015-10-19 17:32:57 UTC
Created attachment 119768 [details]
Options dialog from version 5.0.0.5 under Windows XP x86

The tab and list item regarding the Online Update is missing in Windows x86 since at least 5.0.0.5 (probably since 5.0.0.0alpha0)

The tab shows up as expected under Windows x64 (verified with version 5.0.3.1 under Windows 7 Pro x64 SP1)

In the attached screenshot from version 5.0.0.5 under Windows XP x86 it is easy to notice that the Options dialog is missing the item Online Update between Basic IDE Options and OpenCL
Comment 1 Dennis Roczek 2015-10-21 16:03:01 UTC
Version: 5.0.1.2
Build-ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Gebietsschema: de-DE (de_DE)

CONFIRMED

(win xp sp3 x86)


BTW: shouldn't the online-update be listed under internet?!?
Comment 2 V Stuart Foote 2015-11-09 14:58:01 UTC
Confirming regression on Windows XP Pro SP3, 32-bit en-US with
Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-US (en_US)

was fine for the 4.4 releases, but missing a "Online Update" entry in the Tools -> Options menu for 5.0 releases.
Comment 3 Pedro 2015-11-09 15:12:42 UTC
Created attachment 120420 [details]
Screenshot of Options dialog of LO 5.0.3.2 x86 under Win7 x64

To add to the complexity, when LO 5.0.3.2 x86 is installed under on a Windows x64 system (tested with Win7 Pro x64 SP1) the option is present.

Therefore this is a Win XP only problem OR a LO x86 under Win x86 only problem. Can someone with Win7 (or newer) x86 check this?

This problem causes uncertainty to users, as mentioned in topic
http://nabble.documentfoundation.org/a-question-about-libreoffice-opdate-td4165716.html
Comment 4 V Stuart Foote 2015-11-10 19:18:36 UTC
Tested on following x86 builds, XP sp3, Windows 7 sp1, Windows 8.1 and Vista sp2

With my usual "Online Update" optional components deselected -- Windows 7 and 8.1 had no issue and showed the entry in the Tools -> Options menu and the Help menu.  But, for Vista sp2 on initial install it did not.  Hmmm.

From an Appwiz.cpl launch, do a Change install of the LibreOffice install and select the Modify radio button. From Optional Components select active the "Online Update" item and complete the changes.  Relaunch LO 5 and the menu items are there. And, the update dialog runs.

Do the same steps on XP 32-bit--same result, menu items are present and functional.

Don't know why the Online Update is missing on initial install, but if confirmed by other 32-bit XP sp3 users, this seems like a reasonable workaround.
Comment 5 zahra 2015-11-11 04:19:59 UTC
hi every one. 
yes, as i mentioned i use windows xp service pack 3 on my laptop. 
i downloaded libreoffice 5.0.2.1 and installed it. 
but unfortunately, i could not find online update in the libreoffice options! 
i downloaded version 4.4.6.3 today and the problem is solved.
Comment 6 V Stuart Foote 2015-11-11 04:23:48 UTC
(In reply to zahra from comment #5)
> hi every one. 
> yes, as i mentioned i use windows xp service pack 3 on my laptop. 
> i downloaded libreoffice 5.0.2.1 and installed it. 
> but unfortunately, i could not find online update in the libreoffice
> options! 
> i downloaded version 4.4.6.3 today and the problem is solved.

No, reverting to 4.4.6.3 solves nothing.  

Instead we need to know if the Windows installer work around--as in comment 4-- of doing a Change to LibreOffice 5.0.x and selecting Modify, and reenabling the "Online Update" Optional component is viable for Windows XP sp3 32-bit users.
Comment 7 zahra 2015-11-11 04:29:22 UTC
and about using modify to do our desire changes, i downloadeed and tested more than 12 versions of libreoffice and could not find it when i am installing the program. 
this feature that we cand select whether to check for the newer version or not, i only found it in open office! 
and in libreoffice its only appeares in the options menu in windows xp before version 5 of libreoffice.
Comment 8 Pedro 2015-11-11 10:05:25 UTC
(In reply to V Stuart Foote from comment #4)
> With my usual "Online Update" optional components deselected -- Windows 7
> and 8.1 had no issue and showed the entry in the Tools -> Options menu and
> the Help menu.  But, for Vista sp2 on initial install it did not.  Hmmm.

So maybe the bug also occurs on Vista SP2 x86, since your procedure is always the same?
 
> Don't know why the Online Update is missing on initial install, but if
> confirmed by other 32-bit XP sp3 users, this seems like a reasonable
> workaround.

Unfortunately that was not the problem. I also do a Custom Install but I leave the Online Update checked (because I want the component to be installed).

I even tried running Appwiz.cpl, unchecking the Online Update, running LibreOffice and then running Appwiz.cpl again and checking the Online Update option hoping that this would force an install of the module. Unfortunately there was no change.

I believe the priority on this bug should be raised.
Comment 9 V Stuart Foote 2015-11-13 19:01:06 UTC
No issue with x86 Vista and onward, it is just x86 XP sp3. Sorry for the noise on that. 

Narrowed span to 3 weeks between 5.0.0.2 and 5.0.0.3rc builds.

WinDbg runs of the Update Check 5.0.0.3 onward suggest issue is in updchklo.dll  and libcurl.dll.  cURL had been updated that time frame--but not clear why the GUI menu entry just on XP, would be affected.
Comment 10 zahra 2016-06-25 06:26:16 UTC Comment hidden (me-too)
Comment 11 V Stuart Foote 2016-07-07 03:02:50 UTC
With Markus's patch for XP libcurl
http://cgit.freedesktop.org/libreoffice/core/commit/?id=8562b1068328e16a629d2397f00af2a3e7998081&h=libreoffice-5-2

tdf#100295 force curl to build for XP

Testing with Windows XP sp3 Pro 32-bit en-US with
Version: 5.2.0.1.0+
Build ID: a2ab810b268ea3555a3931196ab17a0a0de8ba0b
CPU Threads: 2; OS Version: Windows 5.1; UI Render: default; 
Locale: en-US (en_US)

The Tools -> Options -> LibreOffice -> Check for Updates menu entry still does not appear on XP install.
Comment 12 Aron Budea 2016-07-08 17:09:14 UTC
This is also a duplicate of bug 100295.

*** This bug has been marked as a duplicate of bug 100295 ***