Bug 95243 - Broken parsing custom style in ODT
Summary: Broken parsing custom style in ODT
Status: RESOLVED DUPLICATE of bug 95256
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-22 04:37 UTC by Grigoriy Kramarenko
Modified: 2015-10-23 19:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Flat XML ODF Text Document (44.84 KB, application/vnd.oasis.opendocument.text-flat-xml)
2015-10-22 04:37 UTC, Grigoriy Kramarenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grigoriy Kramarenko 2015-10-22 04:37:18 UTC
Created attachment 119864 [details]
Flat XML ODF Text Document

I have a Flat XML files that no longer correctly display 
information(style) in version 4.4 and above. The latest version of 
Libreoffice, which opens the document correctly - this 4.3.7.2 for 
Windows. In the new versions just do not displays the whole block 
of documents.

Style:

    <style:style style:name="ParagraphVerbatim" style:family="paragraph"
        style:display-name="Paragraph Verbatim">
        <style:paragraph-properties
            fo:text-indent="0.3cm"
            fo:background-color="#E0E0E0"
            style:shadow="none"/>
        <style:text-properties
            fo:font-size="10pt"
            style:font-name="Courier"/>
    </style:style>

    <style:style style:name="ParagraphSynopsis" style:family="paragraph"
        style:display-name="Paragraph Synopsis"
        style:parent-style-name="ParagraphVerbatim"
        style:next-style-name="ParagraphSynopsis">
        <style:paragraph-properties
            fo:padding-top="0.20cm"
            fo:padding-bottom="0.20cm"
            fo:background-color=""
            fo:border-left="0.2cm solid #303030"/>
        <style:text-properties/>
    </style:style>

The block of text that is not displayed:

    <text:p text:style-name="ParagraphSynopsis">№: 1793</text:p>
    <text:p text:style-name="ParagraphSynopsis">Дата: 21 октября 2015 г. 15:12:31</text:p>
    <text:p text:style-name="ParagraphSynopsis">Со склада: Главный склад</text:p>
    <text:p text:style-name="ParagraphSynopsis">На склад: Бар 1</text:p>


I think that broken interoperability between versions 4.3 and 4.4.
Comment 1 Jacques Guilleron 2015-10-22 16:09:02 UTC
Hi Grigoriy,

"Courier" is not available on my computer. The font window display an italic font name. 
But changing "Courier" to "Courier New" solve the issue.
Comment 2 Grigoriy Kramarenko 2015-10-22 22:08:33 UTC
(In reply to Jacques Guilleron from comment #1)
> "Courier" is not available on my computer. The font window display an italic
> font name. 
> But changing "Courier" to "Courier New" solve the issue.

I know. But I think the text should be displayed, even when fonts are not available. Otherwise, it is impossible to say that LO can be used on an industrial scale.
Comment 3 Jacques Guilleron 2015-10-23 19:27:37 UTC
HI Grigoriy,

Works with 
LO 4.3.7.2 Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
and Windows 7 Home.
but not with
LO 4.4.0.0.beta1 Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Trying to use Replacement table in 
Tools > Options > LibreOffice > Fonts doesn't work.
Set Status to Duplicate of 95256.

*** This bug has been marked as a duplicate of bug 95256 ***