Bug 95256 - Setting font to "Courier;Courier New" sometimes causes LibreOffice Writer to freeze and text is not displayed
Summary: Setting font to "Courier;Courier New" sometimes causes LibreOffice Writer to ...
Status: RESOLVED DUPLICATE of bug 98989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 94881 95243 95732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-22 14:15 UTC by Holger Voormann
Modified: 2016-05-11 13:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the problem (20.12 KB, image/png)
2015-10-22 14:15 UTC, Holger Voormann
Details
Page 3 missing in Windows (16.74 KB, application/vnd.oasis.opendocument.text)
2016-01-22 11:44 UTC, mal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Voormann 2015-10-22 14:15:03 UTC
Created attachment 119883 [details]
Screenshot showing the problem

Steps to reproduce:
1. Open LibreOffice Writer
2. Set Font to "Courier;Courier New"
3. Type some text

Result:
- Sometimes application freezes for some time
- Text is not displayed or the characters are shown one above the other (see attached screenshot)

Expected:
- UI should not freeze
- Text should be shown with font "Courier" or if "Courier" is not installed then with the font "Courier New"

Tested with LibreOffice 4.4.5 and 5.0.3.1
OS: Windows 10 German
Comment 1 Jacques Guilleron 2015-10-23 16:17:40 UTC
Hi Holger,

I reproduce with
LO 5.0.3.1 Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
and Windows 7 Home.
and with 
LO 4.4.0.0.beta1 Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e.
LO 4.3.7.2 Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba works.
Searching to use Replacemnt table, available in
Tools > Options > LibreOfffice > Fonts 
"Apply replacement table" and other settings like "Fonts", "Replace with" are deleted once you push OK and cannot be used.
I set Status to NEW, Keywords to regression.

Thank you for the report.
Comment 2 Jacques Guilleron 2015-10-23 19:27:37 UTC
*** Bug 95243 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2015-10-23 20:15:04 UTC
Jacques: usually a dup bug is a bug submitted after an initial bug. Any specific reason for not having done this here?
Comment 4 Jacques Guilleron 2015-10-23 20:28:48 UTC
Hi Julien,

No other reason than a clearer formulation of the subject in the title and an extended cover.
Comment 5 Julien Nabet 2015-10-23 20:45:55 UTC
(In reply to Jacques Guilleron from comment #4)
> Hi Julien,
> 
> No other reason than a clearer formulation of the subject in the title and
> an extended cover.
ok then :-) Thank you for your quick feedback.

On pc Debian x86-64 with master sources updated today or with LO Debian package 5.0.2, I don't reproduce this. Perhaps a Windows only bug?
Comment 6 Grigoriy Kramarenko 2015-10-24 00:02:40 UTC
(In reply to Julien Nabet from comment #5)
> (In reply to Jacques Guilleron from comment #4)
> > Hi Julien,
> > 
> > No other reason than a clearer formulation of the subject in the title and
> > an extended cover.
> ok then :-) Thank you for your quick feedback.
> 
> On pc Debian x86-64 with master sources updated today or with LO Debian
> package 5.0.2, I don't reproduce this. Perhaps a Windows only bug?

It looks like it. Debian Jessie 32bit, LO 5.0.2 from backports -- displays the text.
Comment 7 Jacques Guilleron 2015-10-30 14:21:25 UTC
*** Bug 94881 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2015-11-12 12:04:43 UTC
*** Bug 95732 has been marked as a duplicate of this bug. ***
Comment 9 mal 2016-01-22 11:43:23 UTC
Added a file to this for your perusal

Here when the font is Courier it works
in Linux ( openSUSE ) but if you send it
to a Windows machine the whole page that
has Courier on it is missing. 

If you select the Courier bit and change 
the font it is OK on Windows. I think this
is this bug but if it's not let me know and 
I'll do a new one.

This manifestation is quiet bad as with the example 
shown it is clear that something  is there
it's just messed up. This gives you no
clue that the page is even there.
Comment 10 mal 2016-01-22 11:44:21 UTC
Created attachment 122146 [details]
Page 3 missing in Windows

Open in Linux = OK
Open in Windows = Page 3 missing
Comment 11 Michael Stahl (CIB) 2016-05-11 13:48:24 UTC
should have fixed the Windows Courier bug, works on master anyway

*** This bug has been marked as a duplicate of bug 98989 ***