Bug 95247 - Borders accesibility
Summary: Borders accesibility
Status: RESOLVED DUPLICATE of bug 101886
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Borders-Tab
  Show dependency treegraph
 
Reported: 2015-10-22 07:59 UTC by jvprofe
Modified: 2018-03-25 16:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jvprofe 2015-10-22 07:59:16 UTC
In "Format - Page - Borders" or "Format - Paragraph - Borders", "border style" option in the "Line" area is not accesible. The border styles (dashed, dotted, etc.) are not readed by the screen reader. As a result, it's imposible for a blind person to set the border style.

Border styles should have an accesible description.
Comment 1 V Stuart Foote 2015-10-23 00:16:03 UTC
Confirmed on Windows 10 Pro 64-bit en-US with NVDA 2015.3 and
Version: 5.0.3.1 (x64)
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
Locale: en-US (en_US)

Borders:: Line::  Style -> Drop down list elements are not exposed to a11y AT renderings in IAccessibility2

Unknown about NSAccessibity and ATK handling, but likely the same issue.
Comment 2 Robinson Tryon (qubit) 2015-12-10 03:37:47 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2017-01-03 19:42:17 UTC Comment hidden (obsolete)
Comment 4 Quentin Christensen 2017-10-19 02:34:36 UTC
I can confirm this bug still exists using LibreOffice 5.4.2.2 (x64) using NVDA 2017.3 on Windows 10 1709 (build 17017.1000 Fast insider build just after Fall Creators Update).

I also tested with Narrator, however, Narrator has trouble with the whole dialog.  NVDA can read most of this borders page except the border style, and also the colour dialog.
Comment 5 V Stuart Foote 2018-03-25 16:09:59 UTC
code pointers for the mute listbox in bug 101886

*** This bug has been marked as a duplicate of bug 101886 ***