Bug 95341 - Last item of a popup menu with a title isn't selectable
Summary: Last item of a popup menu with a title isn't selectable
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, regression
: 96849 99431 100166 100227 104059 105472 105477 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-26 20:33 UTC by Maxim Monastirsky
Modified: 2017-02-11 21:44 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2015-10-26 20:33:42 UTC
Steps to reproduce:

1. Right click on any toolbar.
2. Try to select the last item of the popup menu (i.e. "Close Toolbar").


This was fixed once with:

commit 8ced97caa409d6dc8f69230145e9c9f281fb84fe
Author: Philippe Jung <phil.jung@free.fr>
Date:   Tue Jun 9 16:01:54 2015 +0200

    Last item of menu with title cannot be hilighted
    
    Seing the fix, it probably also impacts scrolled floating menus.

... but that fix was reverted in Bug 92702 because it created more severe bug. So now we have that bug again.
Comment 1 Terrence Enger 2016-01-02 01:57:54 UTC
*** Bug 96849 has been marked as a duplicate of this bug. ***
Comment 2 sergio.callegari 2016-03-31 13:27:10 UTC Comment hidden (me-too)
Comment 3 Maxim Monastirsky 2016-04-21 19:11:08 UTC
*** Bug 99431 has been marked as a duplicate of this bug. ***
Comment 4 Maxim Monastirsky 2016-06-01 07:40:11 UTC
*** Bug 100166 has been marked as a duplicate of this bug. ***
Comment 5 sergio.callegari 2016-06-02 08:50:05 UTC
Sorry for the noise with the duplicate bug 100166.

Nonetheless, I'd like to carry over from there that an easy workaround is to use the keyboard arrow keys to select the last menu item. This works and may be useful to know to other users impacted by the problem.
Comment 6 Maxim Monastirsky 2016-06-05 18:41:04 UTC
*** Bug 100227 has been marked as a duplicate of this bug. ***
Comment 7 Julien Nabet 2016-06-05 18:45:30 UTC
On pc Debian x86-64 with LO Debian package 5.1.3.2, I could reproduce this.
But I don't reproduce this with master sources updated today.
Comment 8 Maxim Monastirsky 2016-06-05 18:47:27 UTC
(In reply to Julien Nabet from comment #7)
> On pc Debian x86-64 with LO Debian package 5.1.3.2, I could reproduce this.
> But I don't reproduce this with master sources updated today.
When testing master, make sure you don't test with gtk3, or under OS X.
Comment 9 Julien Nabet 2016-06-05 19:02:06 UTC
(In reply to Maxim Monastirsky from comment #8)
> (In reply to Julien Nabet from comment #7)
> > On pc Debian x86-64 with LO Debian package 5.1.3.2, I could reproduce this.
> > But I don't reproduce this with master sources updated today.
> When testing master, make sure you don't test with gtk3, or under OS X.
You're right, I reproduced the problem with gtk and gen rendering with master sources.
So only gtk3 part has been fixed.
Comment 10 Harald Koester 2016-08-26 13:01:29 UTC
Bug checked with version 5.2.0. Bug still exists.
Comment 11 Xisco Faulí 2016-09-02 11:56:44 UTC
Regression from 4f1dca5083c5a301181786b563b165f19a9dec7f.

Submitted a fix to gerrit: https://gerrit.libreoffice.org/#/c/28617/
Comment 12 Xisco Faulí 2016-09-26 14:53:48 UTC
Adding Cc: to Caolán McNamara
Comment 13 Commit Notification 2016-11-03 08:00:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4669faa6835796267490efe906f0bd8355f6a50

tdf#95341: Make last item of menus clickable again

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Maxim Monastirsky 2016-11-20 17:38:16 UTC
*** Bug 104059 has been marked as a duplicate of this bug. ***
Comment 15 Maxim Monastirsky 2017-01-22 09:51:04 UTC
*** Bug 105472 has been marked as a duplicate of this bug. ***
Comment 16 g4827387 2017-01-22 17:04:12 UTC
*** Bug 105477 has been marked as a duplicate of this bug. ***
Comment 17 Harald Koester 2017-02-11 21:44:09 UTC
Patch verified with 5.3.0.3 and Win7. Works for me now --> Bug closed.