Bug Hunting Session
Bug 95636 - Shortcuts Ctrl+F and Ctrl+H (and..?) not working properly with readonly document, since the focus is not in the document.
Summary: Shortcuts Ctrl+F and Ctrl+H (and..?) not working properly with readonly docu...
Status: RESOLVED DUPLICATE of bug 89688
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-06 15:05 UTC by pavelz
Modified: 2015-12-14 10:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pavelz 2015-11-06 15:05:52 UTC
After opening readonly document, the shortcuts are not working properly.

Common procedure is to open an e-mail attachment (ODT file) and press Ctrl+F to search - the file is opened as readonly and the shortcut does not work. Maybe it is some kind of focus issue, because after clicking in the text area of the document, the shortcut starts to work. It similar with Ctrl+H shortcut to find and replace, while Ctrl+O shorcut works seamlessly with readonly document.

This bug occurs in Writer, not in Calc.
Comment 1 Cor Nouws 2015-11-06 15:46:00 UTC
Hi Pavelz,

thanks for reporting. I can confirm the behaviour.
Looks as if the focus is somewhere in the side bar..
Hitting F6 once is enough to put it in the document.

I set this to new.
Comment 2 Buovjaga 2015-12-14 10:19:19 UTC

*** This bug has been marked as a duplicate of bug 89688 ***