Bug 95646 - Checkbox with boolean data field does not display correctly
Summary: Checkbox with boolean data field does not display correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-07 00:53 UTC by B Mikowski
Modified: 2016-02-15 15:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Form with checkboxes - boolean, tinyint and char-field (10.32 KB, application/vnd.oasis.opendocument.database)
2015-11-07 15:23 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description B Mikowski 2015-11-07 00:53:52 UTC
Checkbox tied to a boolean data field will not display checked or unchecked status based on yes/no or 0/1 boolean status of database field tied to it.  It always displays a checked status.
Comment 1 B Mikowski 2015-11-07 00:54:16 UTC
This is in BASE Forms section.
Comment 2 Robert Großkopf 2015-11-07 15:23:09 UTC
Created attachment 120363 [details]
Form with checkboxes - boolean, tinyint and char-field

No Problem here with LO 4.4.6.3 and OpenSUSE 13.2 64bit Linux. See attached file
Comment 3 Alex Thurgood 2015-11-08 11:29:32 UTC
B Mikowski : please provide a sample db where the problem can be seen. This question has come up before, so we need to check whether it is a duplicate of an existing bug, or whether there is some other possible reason behind what you are experiencing.
Comment 4 Alex Thurgood 2015-11-08 11:32:16 UTC
@Mikowski : see also comment 3 on bug 88601 - is this what you are experiencing ?
Comment 5 Alex Thurgood 2015-11-08 11:35:08 UTC
My current impression is that this report is a DUP of bug 88601
Comment 6 B Mikowski 2015-11-10 02:10:31 UTC
LibreOffice 4.4.5.2; HSQL; OpenSuse 13.1;
I tested more thoroughly after looking @ Robert's sample DB.  My DB form wasn't created with a wizard, but I created the checkbox control manually and had assigned a specific field.  Anyway, in an earlier version of LO (3.x), I had set up reference values in the data tab of the control properties (1=on, 0=off).  This worked fine in that version. In this version of LO, this disturbs current functionality of the control when changing/moving through the records in the form.  When I removed the reference values (back to blank for both settings) the control worked properly.  From my standpoint, this issue can now be closed.
Comment 7 V Stuart Foote 2016-02-15 15:55:33 UTC
*** Bug 97849 has been marked as a duplicate of this bug. ***