Bug Hunting Session
Bug 95694 - One cannot print to A4 size paper in Impress.
Summary: One cannot print to A4 size paper in Impress.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) FreeBSD
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2015-11-09 09:47 UTC by Taka
Modified: 2018-03-14 17:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Taka 2015-11-09 09:47:36 UTC
Step to reproduce

1. Start up Impress.
2. Chose "Printer" in "File" menu.
3. Press "Properties" in the dialog.

Current behavior:
Letter & Landscape are selected and greyed out.

Expected behavior:
One can change paper size and orientation.

This behavior remains even after one set page format in Handout tab.

In addition,

1. Start up Impress.
2. Chose "Printer Setting" in "File" menu.
3. Press "Properties"

Current behavior:
Letter & Portrait are selected and greyed out. (<- not Landscape )

Expected behavior:
One can change paper size and orientation.

The 2nd bug is common in writer too, but the 1st bug is only in Impress.

We do not have such bugs in LibreOffice 4.
So, reverting to 4 at corresponding part seems a solution.

Because people in country other than US cannot use LibreOffice 5,
I think it is better to change the default latest version shown in the
LibreOffice home page to 4.4.6 and put 5.0.x in developing version,
at least in those country, in case it takes long to revert or fix.
Comment 1 Julien Nabet 2015-11-09 21:56:52 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Katarina: I noticed this commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a1fe443a8343642292444be19cbd10700e7e01c
I read the comment of the commit but where is "Use only papersize from printer prefs"?
Comment 2 baffclan 2015-11-10 10:21:23 UTC
related to bug 89493?
Comment 3 Cor Nouws 2016-02-03 13:47:03 UTC
I expect this is related to "Use only paper size from printer preferences" checkbox on the File > Print .. Options tab.
?
See
https://bugs.documentfoundation.org/show_bug.cgi?id=61186
and
https://wiki.documentfoundation.org/ReleaseNotes/4.1#Other

(So possibly a duplicate of 67576 ? )
Comment 4 Taka 2016-03-17 14:26:06 UTC
>I expect this is related to "Use only paper size from printer preferences" >checkbox on the File > Print .. Options tab.

I don't know. But, probably not related.
Please read "Step to reproduce" in comment #1.
It has nothing to do with the checkbox.
Even if the checkbox solve the problem, the behavior in comment #1 is a bug apparently.

Because of this bug, LO5 is unusable in Japan since US letter paper is not available. In fact, people in Japan including myself continue to use LO4 on unix systems.
Comment 5 Taka 2016-04-28 10:30:45 UTC
Today,I've found this bug still exists in LO Impress 5.0.5.2.
"Properties..." in "Printer setting" and "Print" shows a wrong paper size (=letter), and user cannot change it.
This wrong value remains even after one change "Paper format" at Handout Tab.
We did not have a such bug in LO4. We may had better to revert corresponding part.
Comment 6 Taka 2016-07-15 10:09:09 UTC
I've found this bug still exists in LO Impress 5.0.6.3.
"Properties" button in "Printer setting" and "Print" shows a fixed letter paper size, and users cannot change it.
Therefore, people live in other than US cannot use LO v5.
Comment 7 Ryan 2017-09-04 14:15:51 UTC
In LO Impress 5.1.6.2 it is possible to set the paper size via the "Slide -> Page/Slide Properties..." menu option. This does in fact change the visible page size.

This bug still exists with respect to printing. Even setting the page size correctly as described above, Impress prints only to Letter size (irrespective of "File -> Print -> Options -> Use only paper size from printer preferences). It also is irrespective of the Locale (English-US vs English-UK), and finally irrespective of the Paper Size set in the Operating System's Printer Preferences.

The good news is that this bug appears to no longer affect PDF export. So it is possible to export to PDF after setting the paper size, and then print the PDF. In addition, no Page Scaling is needed when printing the PDF; everything is exactly as it should be. So this is an effective workaround in the meantime which is worth documenting here.

For reference, the build I am using is 1:5.1.6~rc2-0ubuntu1~xenial2 installed from the repositories under Xubuntu 16.04.
Comment 8 Commit Notification 2017-10-28 01:42:15 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51eb767eaf514ee8106401e364e75533fd6fcb51

Related tdf#95694: Enable papersize & orientation listboxes

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Timur 2017-11-10 13:29:58 UTC
I don't understand this bug, what it was about and what was changed. 
(In reply to Taka from comment #0)
> 1. Start up Impress.
> 2. Chose "Printer" in "File" menu.
> 3. Press "Properties" in the dialog.
> 
> Current behavior:
> Letter & Landscape are selected and greyed out.

There's no "Printer". I guess it's "Print..". I don't have it greyed out. 
 
> 1. Start up Impress.
> 2. Chose "Printer Setting" in "File" menu.
> 3. Press "Properties"
> 
> Current behavior:
> Letter & Portrait are selected and greyed out. (<- not Landscape )

Also, cannot repro this. 
I do repro Bug 92676. We may speak of the same issue, but differently.
Comment 10 Xisco Faulí 2017-12-11 08:58:06 UTC
A polite ping to Katarina Behrens: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 11 Katarina Behrens (CIB) 2017-12-18 11:40:54 UTC
(In reply to Xisco Faulí from comment #10)
> A polite ping to Katarina Behrens: is this bug fixed? if so, could you
> please close it as RESOLVED FIXED ? Thanks

I have no idea. It is sorta fixed for me, but I'd prefer if someone independently verified this is indeed the case
Comment 12 Manuj Vashist 2017-12-26 09:52:45 UTC
(In reply to Taka from comment #0)
> Step to reproduce
> 
> 1. Start up Impress.
> 2. Chose "Printer" in "File" menu.
> 3. Press "Properties" in the dialog.
>

in Print->Properties page size and orientation is mutable
only when "Use only paper size from printer preferences" is checked.(I guess
that is expected result)
But it locks on the edited choices when "Use only..." is unchecked again.
(default page size and orientation should be loaded back ?)
> 
> Expected behavior:
> One can change paper size and orientation.
> 
> In addition,
> 
> 1. Start up Impress.
> 2. Chose "Printer Setting" in "File" menu.
> 3. Press "Properties"
> 
> Expected behavior:
> One can change paper size and orientation.
>
> The 2nd bug is common in writer too, but the 1st bug is only in Impress.

working as expected in both.
Comment 13 Timur 2018-03-14 17:12:42 UTC
There are 3 comments for no repro: 
- Comment 9
- Comment 12
- https://bugs.documentfoundation.org/show_bug.cgi?id=116386#c2

We may talk about diff. issues but no point in having this open, I'll close as WFM. 
Of course, feel free and happy to set back to New if repro again.