Download it now!
Bug 95810 - Writer Crashes on Close
Summary: Writer Crashes on Close
Status: RESOLVED DUPLICATE of bug 95796
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-11-14 00:39 UTC by J William Cupp
Modified: 2016-02-04 08:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of crash (23.11 KB, text/plain)
2015-11-16 02:50 UTC, J William Cupp
Details
Backtrace of crash on Windows 5.0.3 (10.32 KB, text/plain)
2015-11-19 08:23 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J William Cupp 2015-11-14 00:39:45 UTC
Since upgrading to Libre Office 5.0.3.2 a few days ago (Version: 5.0.3.2
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75) I am experiencing a new problem.  It does not happen every time, but it happens frequently.

When I am working on one or more documents, then save them and close, if it is the last document to close and I exit Writer, Writer then crashes.  It comes up with a report "the following documents will be saved for recovery" and it gives a null list -- since no documents were open at the time.

Nevertheless, I must click to accept, click to initiate recovery (of no documents) and click to Finish the recovery (after zero documents are recovered).  This is a nuisance since by definition I was trying to close Writer and go on to other things.

I haven't been specific yet but I would estimate it happens about 75% of the time.  Closing Writer when closing the last open document causes a crash.
Comment 1 Buovjaga 2015-11-15 17:25:10 UTC
You could try getting a backtrace of the crash: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 2 J William Cupp 2015-11-16 02:50:45 UTC
Created attachment 120565 [details]
Backtrace of crash

Note that the crash happens when Libre Office is closed -- that is, the last document is closed.  There is no apparent indication then.  However, on next attempted launch of Libre Office the notice is given that Libre Office has crashed and (no documents) need to be recovered.
Comment 3 J William Cupp 2015-11-17 22:39:31 UTC
This bug may be related to Bug 95796.  With further experimentation, I have not had LibreOffice Writer crash if I do not open a document that has a bitmap background for the page.

When I open documents with bitmap backgrounds, it tends to crash more often.  I don't have exact statistics, but whenever I have handled a document with the bitmap, which is distorted because as of v5.0.3.2 it *always* opens with "autofit" selected, whether the document was saved that way or not, the chance that Libre Office Writer will crash is quite high.

Again, Writer crashes not while handling the document, nor while clearing the "autofit" attribute, nor while saving the document, but upon closing the document.  It seems to crash when such a document is closed, whether there are other Libre Office documents open or not.  Of course, if the Writer document with the bitmap page background is the only one open, Writer crashes and reports a null list of documents to be saved and recovered.  However, if there are other documents (ODT, ODS, etc.) open, they are listed for recovery and recovered.
Comment 4 J William Cupp 2015-11-17 22:41:18 UTC
I forgot to mention that these symptoms appear to be the same on Linux and Windows platforms.  The problem appeared in both installations when I upgraded to LO 5.0.3.2.
Comment 5 Buovjaga 2015-11-18 06:40:22 UTC
Btw. the autofit problem is fixed in 5.1: bug 95850
Might be in 5.0.4 as well for all we know (testing encouraged).
http://dev-builds.libreoffice.org/daily/
Comment 6 Buovjaga 2015-11-19 08:23:30 UTC
Created attachment 120651 [details]
Backtrace of crash on Windows 5.0.3

Suddenly started getting crashes when closing Writer.
Compared our traces and it might be the same cause, but not sure.
I'll set to NEW anyway.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)
Comment 7 Buovjaga 2015-11-19 19:48:59 UTC
Hmm my problem went away with this: https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile
Comment 8 J William Cupp 2015-11-19 20:17:05 UTC
How do you know that resetting the user profile cleared the problem?

In my case, the crash-on-close happens frequently when I open a document with a watermark and clear the "autofit" property of the bitmap image background.  It does not seem to matter whether I save the document after clearing the autofit property or not.  Frequently, I say, but not always.

Additionally, I have experienced the crash-on-close even when I have not opened such a document.  It is not as common this way, but it has happened.

What sort of reliable test could I make after I clear the user profile in order to know if the problem is gone?  (Also, this begs the question as to how the user profile became corrupted so.  The timing with the upgrade to 5.0.3.2 and the concurrent appearance of the autofit background bitmap seems a bit of a long stretch to write off as coincidence.)
Comment 9 Buovjaga 2015-11-20 06:42:12 UTC
(In reply to J William Cupp from comment #8)
> How do you know that resetting the user profile cleared the problem?
> 
> In my case, the crash-on-close happens frequently when I open a document
> with a watermark and clear the "autofit" property of the bitmap image
> background.  It does not seem to matter whether I save the document after
> clearing the autofit property or not.  Frequently, I say, but not always.
> 
> Additionally, I have experienced the crash-on-close even when I have not
> opened such a document.  It is not as common this way, but it has happened.
> 
> What sort of reliable test could I make after I clear the user profile in
> order to know if the problem is gone?  (Also, this begs the question as to
> how the user profile became corrupted so.  The timing with the upgrade to
> 5.0.3.2 and the concurrent appearance of the autofit background bitmap seems
> a bit of a long stretch to write off as coincidence.)

I know it, because it stopped crashing on close after I renamed the profile.

We currently do not have tools to inspect profile corruption so there is no scientific method available.
Comment 10 Buovjaga 2015-11-20 09:45:28 UTC
Ah, I discovered that the extension causing the crashing on close is Voikko: http://www.puimula.org/htp/ooo/libreoffice-voikko.html

Setting back to unconfirmed.
Comment 11 J William Cupp 2015-11-22 20:46:10 UTC
I tried resetting my profile but it did not change the circumstances any.  The problem still persists.

Also, I had one event in which I had not opened any document with a background page bitmap image, and Writer crashed upon close.  However, this was a one-time event and I don't know if it's related.
Comment 12 Timur 2016-02-04 08:09:30 UTC
Please mark as a duplicate of Bug 95796 and focus on that one to be confirmed.
You can always reopen this one if proved different.
Comment 13 Buovjaga 2016-02-04 08:22:10 UTC

*** This bug has been marked as a duplicate of bug 95796 ***