Download it now!
Bug 96062 - Imported docx file from MS Office doesn't show/render hyperlinks (removing direct formatting makes the links visible)
Summary: Imported docx file from MS Office doesn't show/render hyperlinks (removing di...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2015-11-25 12:18 UTC by janvdberg
Modified: 2017-12-10 20:41 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Docx document with 2 hyperlinks that are not rendered (13.28 KB, application/zip)
2015-11-25 12:18 UTC, janvdberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description janvdberg 2015-11-25 12:18:19 UTC
Created attachment 120786 [details]
Docx document with 2 hyperlinks that are not rendered

After a discussion on IRC I have created this bug.

- I have a .docx/.doc file created in MS Office Word with hyperlinks in it. And it opens just fine in LO4 and LO5: except the hyperlinks are not shown in the text. They are however visible/editable from the Navigator menu (F5). 

- I've tried this with LO5 on my Lubuntu 14.04 and LO5 on my Windows 7 machine (and also on LO4 in Lubuntu). The behavior is the same.

- Document is attached. I've stripped this of otherwise sensitive information. There are two hyperlinks in there, that are not shown/visible in the text.

- IRC log:
[24-11-15 10:18:42] <jansolcon> Im not sure if this is a bug or not (before reporting): I have a .docx/.doc file created in MS Office with hyperlinks in it. And it opens just fine in LO4/5: except the hyperlinks are not shown in the text. They are however visible/editable from the Navigator menu (F5). Is this a bug or am I missing something?
[24-11-15 11:36:27] <DennisRoczek> jansolcon: well what does your stylesheet say?
[24-11-15 11:36:41] <DennisRoczek> oh taht's teh style shaat, or?
[24-11-15 11:37:00] <DennisRoczek> did you manually hit standard or somethign else?
[24-11-15 11:37:10] <DennisRoczek> (rightclikc remove formatting)
[24-11-15 11:40:59] <DennisRoczek> jansolcon: go to tab transparency: did you have choose 100% transparency?
[24-11-15 11:41:58] <jansolcon> DennisRoczek: good tip, but its not transparent
[24-11-15 11:42:41] <DennisRoczek> change the background so you can see something or hit ctrl+k (dunno which shortcut is for your local - open the link dialog)
[24-11-15 11:42:42] <jansolcon> it just doesnt render, it if is was transparent it would take up more space than only one space
[24-11-15 11:43:04] <DennisRoczek> maybe you have no visible text added to the link...
[24-11-15 11:43:10] <DennisRoczek> what happens when exporting to pdf?
[24-11-15 11:43:54] <jansolcon> tried it  :)
[24-11-15 11:44:01] <jansolcon> it export WITHOUT the hyperlinks
[24-11-15 11:44:07] <jansolcon> *exports
[24-11-15 11:44:42] <jansolcon> changing the background doesnt change it
[24-11-15 11:45:37] <DennisRoczek> well i guess we need the document to analyze that.
[24-11-15 11:45:56] <DennisRoczek> i have no clue atm without seeing the document
[24-11-15 11:47:49] <jansolcon> Its an internal document created by a coworker with MS Office
[24-11-15 11:48:21] <DennisRoczek> ah, maybe it's a docx import problem. lemme check
[24-11-15 11:49:01] <jansolcon> Im very curious! Thanks so much already, just to have someone to talk/vent to a bit helps ;)
[24-11-15 11:49:16] <jansolcon> I have to run to a meeting now so Ill be afk for a while 
[24-11-15 11:50:04] <DennisRoczek> yeah it's as i said
[24-11-15 11:50:09] <DennisRoczek> you missed the text for the link
[24-11-15 11:50:17] <DennisRoczek> moreover it does not use the style sheet hyperlink
[24-11-15 11:50:46] <DennisRoczek> go after the whitespace of the naar
[24-11-15 11:50:51] <DennisRoczek> hit ctrl k
[24-11-15 11:51:06] <DennisRoczek> or view --> hyperlink
[24-11-15 11:51:34] <DennisRoczek> "additional options" (dunno in english or dutch) --> field text is empty
[24-11-15 11:51:38] <DennisRoczek> add somehting
[24-11-15 11:51:48] <DennisRoczek> hit ok and the link will be presented
[24-11-15 11:52:02] <DennisRoczek> hope that helps
[24-11-15 11:53:06] <DennisRoczek> moreover the shown style sheet is not available here. o.O
[24-11-15 11:54:02] <DennisRoczek> oh it's a bug. in word it displays the link. jansolcon: can you open a bug report at https://bugs.libreoffice.org
[24-11-15 11:54:12] <DennisRoczek> please (it's your document!)
[24-11-15 11:55:14] <DennisRoczek> strange: i cannot reproduce the hidden link when creating a new document in word. o.O
Comment 1 Cor Nouws 2015-11-25 19:59:42 UTC
Hi Jan,

Thanks for filing the bug!

I confirm the problem in a daily build (Version: 5.1.0.0.alpha1+
Build ID: f6bc5b79c31225c02e9500d0ced4bd26f998f82b
Threads 2; Ver: 4.2; Render: default; TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2015-11-24_01:06:34
Locale: nl-NL (nl_NL.UTF-8) )
but also in earlier versions, among which LibreOffice 3.3.0.

So it's not a new problem.

When you select the area where the hyperlinks are and choose Format > Remove direct formatting (or hit Ctrl+M), then the hyperlinks appear :)

Is this with all docx files (from this source) that you know?

Ciao - Cor
Comment 2 janvdberg 2015-11-26 08:28:31 UTC
Hi!

Thanks for the 'workaround' tip. This confirms the links are there! 

I can't really say if its from all documents from this source, usually he shares doc/pdf files.

Jan
Comment 3 Octavio Alvarez 2016-09-18 10:52:10 UTC
Place the cursor at the start of the word "Wanneer". Hit the left arrow key twice to move it right before the dot. Hit Shift+Left. This will select the hyperlink. Choose "Format ยป Character..." from the menu bar and go to the "Font Effects" tab.

You will notice the "Hidden" attribute selected. This is why the hyperlinks are not shown.

Maybe the "hidden" attribute is set as direct formatting and that's why Ctrl+M clears it and makes the hyperlink reappear.

The question is, why did the hyperlink get imported into LibO as hidden?
Comment 4 Justin L 2017-11-02 14:38:06 UTC
Word 2003 is also unable to see the hyperlinks. Seems related to bug 43017.
Comment 5 Vasily Melenchuk (CIB) 2017-11-03 08:45:03 UTC
Document contains bookmarks, but they are marked as hidden (w:vanish attribute in DOCX/content.xml file).

MS Word 2010 by default does not displays these hyperlinks. Only when I toggle "Show / hide formatting marks" I see hidden text (as all hidden text it is with dotted underline).

I've checked document with LibreOffice 5.4.0.3, LibreOfficeDev 6.0 (b6295268ea42525c8e7e64328c1216c598dda2fd): hyperlinks are not displayed by default in both cases.

LibreOffice button "Toggle Formatting Marks" does not shows hidden text by default. However, if I enable it (toggle checkbox in "Tools" -> "Options" -> "LibreOffice Writer" -> "Formatting Aids" -> "Hidden Text") I will see these hidden hyperlinks exactly as in MS Word 2010.

My conclusion: not a bug.