Bug 96085 - Printing odt doc with image PRINTS no image
Summary: Printing odt doc with image PRINTS no image
Status: RESOLVED DUPLICATE of bug 94851
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-26 12:04 UTC by Robert
Modified: 2015-11-28 19:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
odt file with image that will not print (57.93 KB, application/vnd.oasis.opendocument.text)
2015-11-26 12:04 UTC, Robert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2015-11-26 12:04:13 UTC
Created attachment 120815 [details]
odt file with image that will not print

1. Using Windows 8.1 with Latest LibreOffice version 5.0.3.2.
2. Created a new document and typed in some text, about half a page.
3. Captured a screen shot and saved to the Clipboard.
4. Pasted the image into the document and saved the document as odt file.
5. Both text and Image are displayed in document on screen.
6. Go to print the document and only the text prints, NO IMAGE.
7. EXPORTED the file to PDF from Libreoffice.
8. Opened pdf file in Mozilla Firefox, selected print and document printed both text and image.
9. Tried saving the document to different file formats in libreoffice and retested print and same problem, text prints but not image.
10. Looked at both Saved odt and pdf files and noticed the file size of the pdf was larger which after further examination was the difference of the image size.
11. Even though Libreoffice is saving the odt file with the image in it the file size appears wrong as if the image is not being accounted for.
12. Retested the same file by first saving the image as jpg and then importing the image into the document.  SAME PROBLEM - no print image.
13. The document appears to only print correctly after exporting as pdf file.  And have noticed this issue for several releases.
14. My printer has no problems printing images outside of libreoffice.

QUESTION:  Could there be some code or something not being uninstalled from a previous installation that is contributing to this problem?  If not this is still a bug.  On a CLEAN uninstall and NEW install, if this problem is fixed I should not be seeing it anymore.

PLEASE EMAIL ME is you find out why this document does not print the image.  I would love to know why this issue has been around for so long.  crouchingsamurai@yaable.com .   Thanks.
Comment 1 Robert 2015-11-26 12:06:24 UTC
Please email me if you get it to work as I want to understand what is not working here since I've been having this problem for quite some time now.

And by the way if I do a PASTE SPECIAL to insert the image into the document it makes no difference when I attempt to print the document.  No image prints only text.  My only work-around is to export to pdf and then print that document from Firefox.
Comment 2 m.a.riosv 2015-11-27 01:14:51 UTC
Hi @Robert, thanks for reporting.

Do you see the picture when in the Print box, in the LibreOffice Writer tab, there is an option to print the pictures, is it enable?.

I can see the image in the Print box, and in a pdf generated with PDFcreator not with the export to pdf option.
Comment 3 Robert 2015-11-27 02:21:40 UTC
Hi @Robert, thanks for reporting.

Do you see the picture when in the Print box, in the LibreOffice Writer tab, there is an option to print the pictures, is it enable?.

Answer:  
1. Yes I can see the picture in the print box in libreoffice writer tab.
2. I also see the picture in the preview window prior to printing.
3. I also have checked the LibreOffice Writer "Contents" checkbox "Pictures and other graphics" which to my understanding should be checked.
4. Even though all this checks out libreoffice writer still appears to not be sending a complete file to the printer to output.
5. I don't know where I read it but someone online said, and I believe them, that it was fixed somewhere in the 3.x branch and somewhere in the 4.0 branch this issue came back.  Possibly the fix got lost in the build process?



I can see the image in the Print box, and in a pdf generated with PDFcreator not with the export to pdf option.

Answer:
1. From my point of view it does not matter whether you see the image in the Print Box or not with export to PDF.  After exporting the file to PDF Firefox sends the file to the printer and it prints fine.  When printing in LibreOffice the image will not print.  Something is not working as intended in Libreoffice writer when including images to print.
2. Also look at the file size.  The odt versus the pdf.  On my end the file is about double the size, basically the size of the image that is in the pdf but for some reason it may possible not be in the odt file.  ???
Comment 4 m.a.riosv 2015-11-27 22:28:36 UTC
Tested now with a Konica printer, print fine, but the printer ask for select the paper size. The page style has selected "Letter" size. Please test if with the same paper size for both printer and LibreOffice solves the issue.
Comment 5 Robert 2015-11-27 23:09:33 UTC
No, Selecting same papersize in Libreoffice and printer does not solve the problem.
1. Have a Brother MFC 7360 printer.
2. Both libreoffice and printer are using the same papersize and the jpg screen capture that was pasted into the odt document does not print.
3. Perhaps there is some issue with how the image is layered into the document?
4. I believe this issue is clearly in how libreoffice is handling images in documents.  I took the same image and opened it up with GIMP and it printed fine.  As I said before when I looked at the odt file it's half the size of it's pdf export which is approximately the difference in the size of the image.  If this is not the issue then I apologize however I can say the issue is with how Libreoffice is handling images, imported or pasted into a document.  If one program has no problem with the image and the other program is having problems with printing the image then it's safe to say the program is not processing or embedding the images correctly into the document thus creating a condition during printing process that is broken for many people.
Comment 6 m.a.riosv 2015-11-27 23:15:36 UTC
For me works, so I can't confirm.

Maybe some of those obscure bugs.

Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 7 Robert 2015-11-27 23:48:46 UTC
Deleted my libreoffice profile and nothing changed when printing the document.  No Image.  I'm running the latest build too.
Created a new text document and copied the text into it then drag & dropped image and printed and still no image printed.

How is the image embedded in the odt file?

I have no problem consistently reproducing this "no image" print problem and like I said before it's only happening in Libreoffice.  It's not a problem with the image as it prints fine in other software.

*****NOTE*****
- Downloaded AbiWord and opened same odt file and printed document just fine with image.  Libreoffice is definitely having issue with print.
QUESTION:
1. Is your Konica printer a laser printer.  Specifically a Laser printer of Type 1 Class Driver Advanced Document Settings?

I'm reaching now because other word processors print the file fine.  Just issue with Libreoffice writer???  And I still think it has something to do with the way LibreOffice handles images.  Something is broken.
Comment 8 V Stuart Foote 2015-11-28 19:11:34 UTC
Confirmed, but setting duplicate of 94851, workaround of disabling OpenGL GPU graphics offload from Tools -> Options -> View: uncheck "Use OpenGL for all rendering"

*** This bug has been marked as a duplicate of bug 94851 ***
Comment 9 Robert 2015-11-28 19:20:51 UTC
BINGO!  So it's an OpenGL rendering issue.  Great.  At least we now know where the problem is.  Perhaps future releases should leave this checkbox unchecked by default.  A lot of headaches on this one.  

THANK YOU MR FOOTE.  :)