Bug 94851 - Images are not printed (paper and PDF) with OpenGL activated
Summary: Images are not printed (paper and PDF) with OpenGL activated
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.0 target:5.1.0.1 target:5.0.5
Keywords: regression
: 94830 95023 95317 95521 95527 95562 95621 96085 96179 96220 96427 96646 96901 96934 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-10-07 10:08 UTC by James Foster
Modified: 2017-10-27 11:22 UTC (History)
25 users (show)

See Also:
Crash report or crash signature:


Attachments
test ODT document with SVG, EMF, EPS and transparent PNG (325.89 KB, application/vnd.oasis.opendocument.text)
2015-10-07 22:13 UTC, V Stuart Foote
Details
Test Print using PDF 24 (72.91 KB, application/pdf)
2015-10-08 18:54 UTC, Jack2600
Details
TEst file printed with Microsoft PDF printer (110.09 KB, application/pdf)
2015-10-08 18:55 UTC, Jack2600
Details
Test file printed with Microsoft XPS (107.51 KB, application/zip)
2015-10-08 18:56 UTC, Jack2600
Details
Tools -> Options -> Writer -> Print options (30.68 KB, image/png)
2015-10-08 19:47 UTC, V Stuart Foote
Details
Document containing image with LO445 (ok) and LO503 (bad) PDF and XPS output (711.60 KB, application/x-zip-compressed)
2015-12-07 11:06 UTC, marshals
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Foster 2015-10-07 10:08:09 UTC
Images in Writer documents are not printing at all.  Tested on 2 different printers with same results
Comment 1 Jack2600 2015-10-07 19:29:58 UTC
Got the same problem.
 
Even if I try to print using a PDF Printer like PDF24 we get the same problema.

The PDF gets created but only the text appears. Not the images.
Comment 2 V Stuart Foote 2015-10-07 22:13:44 UTC
Created attachment 119405 [details]
test ODT document with SVG, EMF, EPS and transparent PNG

Can not reproduce on Windows 10 Pro 64-bit en-US with
Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-US (en_US)

Clean printing to PostScript, PCL6, as well as Export to PDF of attached test ODT with SVG, EMF, EPS and transparent PNG images.
Comment 3 V Stuart Foote 2015-10-07 22:26:55 UTC
Please test printing with the attached test ODT document.

Also, we'll need some details about your Windows installs and specific LibreOffice build from Help -> About LibreOffice (just copy from the dialog).
Comment 4 m.a.riosv 2015-10-08 01:08:19 UTC
Maybe the option in Menu/Tools/LibreOffice Writer/Print - Pictures & Objects is disable.
Comment 5 Jack2600 2015-10-08 18:54:11 UTC
Created attachment 119432 [details]
Test Print using PDF 24
Comment 6 Jack2600 2015-10-08 18:55:28 UTC
Created attachment 119433 [details]
TEst file printed with Microsoft PDF printer
Comment 7 Jack2600 2015-10-08 18:56:29 UTC
Created attachment 119434 [details]
Test file printed with Microsoft XPS
Comment 8 Jack2600 2015-10-08 18:57:47 UTC
My system has Windows 10 Pro 64Bits with 8Gb RAM

Running on an AMD A6-3670

LibreOffice Details:
Versión: 5.0.2.2
Id. de compilación: 37b43f919e4de5eeaca9b9755ed688758a8251fe-GL
Configuración regional: es-ES (es_ES)
Comment 9 V Stuart Foote 2015-10-08 19:47:28 UTC
Created attachment 119436 [details]
Tools -> Options -> Writer -> Print options

Please comment on status of Tools -> Options -> Writer -> Print options.

Also, posted screen clips show system is affected by issues of bug 94428, any improvement if you disable OpenGL from Tools -> Options -> LibreOffice -> View? Or alternatively try a current TB build of master?
Comment 10 James Foster 2015-10-09 18:08:53 UTC
The document you supplied did not print correctly - images failed to print.

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe-GL
Locale: en-GB (en_GB)

Windows 7 64-bit.  Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz.  16MB RAM
Comment 11 ColinC 2015-11-02 18:30:15 UTC
Logged under 95527 as I did not find this bug report in a search.

With 5.0.2.2 release and 5.0.3.1 rc on Windows 8.1 and also reported on Windows 10.  Writer.

Text only and no images being printed on printer.  Also text only and not pictures being exported to pdf document.  All image print options are set to "on" within printer settings and Writer document option settings.

Has been discussed by others at http://en.libreofficeforum.org/node/11665

Loaded up LO 4.4.5.2.  To get things working again.
Comment 12 V Stuart Foote 2015-11-02 19:21:11 UTC
*** Bug 95527 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2015-11-02 19:24:39 UTC
Additional NEEDINFO

Please test with 5.0.3.2

http://downloadarchive.documentfoundation.org/libreoffice/old/5.0.3.2/

Use test document attachment 119405 [details] both with and without OpenGL support (set from Tools -> Options -> View: Graphics Output "Use OpenGL for all rendering" unchecked and again checked (restart between tests).
Comment 14 V Stuart Foote 2015-11-02 19:27:52 UTC
*** Bug 95317 has been marked as a duplicate of this bug. ***
Comment 15 Harald Koester 2015-11-09 21:19:44 UTC
A user on the German user mailing list had the same problem. According him disabling the option "Use OpenGL for all rendering" saves the problem with his own files. His system: Windows 10 - 64-bit, LO version 5.0.3.2, Build-ID: e5f16313668ac592c1bfb310f4390624e3dbfb75-GL. 

Bug 95023 and bug 95521 may be duplicates.
Comment 16 Jim Halsey 2015-11-09 23:53:58 UTC
I installed 5.0.3.2 with the following results.
 
With "Use OpenGL for all rendering" selected on attempting to print document program crashes, with "Use OpenGL for all rendering" unchecked program continues and file is printed correctly.
Comment 17 Robert 2015-11-11 03:33:50 UTC
I too have found this issue of images unable to print.  When I,
1. Import an image (ex. .png)
2. Or drag and drop the image into the page
3. The image is anchored to the paragraph or page.  It does not matter
4. When choosing to print the image the preview displays the image but the printer prints a blank piece of paper.
5. If I export out the document as pdf the picture then prints using the pdf.

- I recall this issue working back in version 4 and I've had issue with this picture printing problem all through version 5.  Printer is an MFC 7360N laser and again it prints the pdf fine.  No picture printing from writer or draw documents.
Comment 18 pillepalle_dingdong 2015-11-16 08:22:37 UTC
If I insert jpg-Images using drag & drop or menu item in a Writer-Document they are previewed but not printed - the paper is blanc, text is o.k.
This happens while working with Win 7 64-bit. The printing feature works correct with opensuse 13.2 64-bit.
Comment 19 Jean-Baptiste Faure 2015-11-16 20:21:57 UTC
Please, do not change the version number which shows the oldest version in which the bug has been observed.

Best regards. JBF
Comment 20 Cor Nouws 2015-11-28 12:10:58 UTC
A user on the Dutch list has the same problem.
Windows 10, 64 bits.

I'll set the other two (linked issues) as duplicates.
Comment 21 Cor Nouws 2015-11-28 12:12:29 UTC
*** Bug 95521 has been marked as a duplicate of this bug. ***
Comment 22 Cor Nouws 2015-11-28 12:12:38 UTC
*** Bug 95023 has been marked as a duplicate of this bug. ***
Comment 23 Cor Nouws 2015-11-28 12:26:59 UTC
prolly Major is more accurate.
Will try to get more details on the Dutch list.

Questions for all reporters: 

1. is it specific to Windows 10?
   From what I see, it is 64 bits related.
2. The same problem when exporting to PDF?
   I've heard from distorted smaller images
3. relation to setting Tools > Options > LibreOffice > View .. Use OpenGL ?
4. ... 

thanks a lot!
Cor
Comment 24 V Stuart Foote 2015-11-28 16:22:16 UTC
For folks experiencing this, we need specific details.

In addition to Cor's list in comment 23

1) what operating system, and Desktop environment.

2) the LibreOffice details copied from the Help -> About LibreOffice dialog

3) status of the Tools -> Options -> View : "Use OpenGL for all rendering" (as localized). Checked on or checked off?

4) specifically does printing of images resume when OpenGL rendering is checked off and LibreOffice restarted? Any change?

Also, there has been continued OpenGL development, if you have time and ability--please install a 5.1.0 dev daily build, or current master (5.2.0) "in parallel" and test printing and other facets there.

=-ref-=
https://wiki.documentfoundation.org/Installing_in_parallel
Comment 25 V Stuart Foote 2015-11-28 19:11:34 UTC
*** Bug 96085 has been marked as a duplicate of this bug. ***
Comment 26 Cor Nouws 2015-11-29 13:46:21 UTC
Just got information from the Duth ML participant: 

turning off OpenGL rendering solves all.
Windows 10 + 64 bits.

I'll post his test documents later: there are some particular details that developers may want to see for the rendering problems. (finish some other stuff first - but already wanted to share this).
Comment 27 George Pantazes 2015-11-30 05:26:03 UTC
*** Bug 95621 has been marked as a duplicate of this bug. ***
Comment 28 Cor Nouws 2015-12-01 15:21:44 UTC
*** Bug 96179 has been marked as a duplicate of this bug. ***
Comment 29 JCE 2015-12-02 13:12:16 UTC
Initially reported print problem (96179) occurs regardless of Tools-options setting for Write print and openCl -
PDF export not affected (it is actually a possible workaround)
Comment 30 Cor Nouws 2015-12-02 13:17:48 UTC
(In reply to JCE from comment #29)
> Initially reported print problem (96179) occurs regardless of Tools-options
> setting for Write print and openCl -
> PDF export not affected (it is actually a possible workaround)

Then 96179 is not a duplicate of this one.
Comment 31 V Stuart Foote 2015-12-03 17:14:36 UTC
*** Bug 96179 has been marked as a duplicate of this bug. ***
Comment 32 V Stuart Foote 2015-12-03 17:27:41 UTC
Moving this from bug 94691 meta to the bug 93529 meta as believe image printing issues are going to be an VLC/OpenGL interaction.
Comment 33 Michael Meeks 2015-12-03 17:38:22 UTC
Tomaz is working on this =)
Comment 34 juergen huebner 2015-12-04 19:38:17 UTC
*** Bug 96220 has been marked as a duplicate of this bug. ***
Comment 35 marshals 2015-12-07 11:06:35 UTC
Created attachment 121107 [details]
Document containing image with LO445 (ok) and LO503 (bad) PDF and XPS output

I can reproduce on Win10 Home 64bit and LO-5.0.3.2:

LibreOffice-94851.zip contains:

- the doc New OpenDocument Text.odt contains just an image and a line of text.

- the file win7hp 64b lo4452.pdf is what Export to PDF generates on Win7 with LO-4.4.5.2.
- the file win7hp 64b lo4452.xps is what Print to Microsoft XPS Document Writer generates on Win7 with LO-4.4.5.2.

- the file win10h 64b lo5032.pdf is what Export to PDF generates on Win10 with LO-5.0.3.2.
- the file win10h 64b lo5032.oxps is what Print to Microsoft XPS Document Writer generates on Win10 with LO-5.0.3.2.

On Win7 and Win10, the Win7/LO4452 PDF and XPS are as per the ODT.

On Win7 and Win10, Adobe Reader shows the Win10/LO5032 PDF as corrupt (a slanted image with RGB lines running across it); the Win10 XPS just has the text in it; my Epson SX400 prints just the text.
Comment 36 marshals 2015-12-10 09:59:17 UTC
(In reply to marshals from comment #35)
> On Win7 and Win10, Adobe Reader shows the Win10/LO5032 PDF as corrupt (a
> slanted image with RGB lines running across it); the Win10 XPS just has the
> text in it; my Epson SX400 prints just the text.

I should mention that I had disabled OpenCL under Options>LibreOffice>OpenCL, but the problem remained.  Otherwise, it was an unmodified fresh install of LOG-5.0.3.2 on a new install of Win10.

Should I raise a different bugzilla to cover my particular issue?
Comment 37 marshals 2015-12-10 10:04:54 UTC
(In reply to marshals from comment #36)
> I should mention that I had disabled OpenCL under
> Options>LibreOffice>OpenCL, but the problem remained.  Otherwise, it was an
> unmodified fresh install of LOG-5.0.3.2 on a new install of Win10.
> 
> Should I raise a different bugzilla to cover my particular issue?

Duh.  Scratch that.  The problem went away, but required a LO restart first.
Comment 38 Commit Notification 2015-12-11 10:51:44 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a498fad249b3a92f275f33b683f242cb8d68b7b

tdf#94851 use BGR color order in Windows

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 39 Commit Notification 2015-12-11 10:51:49 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1cc30679765ce996a009865e6bad3e5b74b96b41

tdf#94851 can't use OpenGLSalBitmap with WinSalGraphics

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 40 marshals 2015-12-11 12:02:44 UTC
(In reply to Commit Notification from comment #39)
> Tomaž Vajngerl committed a patch related to this issue.
> 
> It will be available in 5.2.0.
> 
> Affected users are encouraged to test the fix and report feedback.

thanks for the fix.  will it be available in 5.0.x?
Comment 41 Michael Meeks 2015-12-11 22:57:00 UTC
*** Bug 95562 has been marked as a duplicate of this bug. ***
Comment 42 V Stuart Foote 2015-12-12 00:28:14 UTC
*** Bug 96427 has been marked as a duplicate of this bug. ***
Comment 43 V Stuart Foote 2015-12-12 03:30:21 UTC
*** Bug 96431 has been marked as a duplicate of this bug. ***
Comment 44 Commit Notification 2015-12-12 08:34:44 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0791cf35eeaccc86b597c3c0f4b32439d2d4d189&h=libreoffice-5-1

tdf#94851 use BGR color order in Windows

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Commit Notification 2015-12-12 08:34:49 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28c2c141cb084f37d27e50a8b673206967932c2b&h=libreoffice-5-1

tdf#94851 can't use OpenGLSalBitmap with WinSalGraphics

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 46 Commit Notification 2015-12-12 11:17:28 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=917d59a84124d1022bd1912874e7a53c674784f1

tdf#94851 check SalBitmap & convert in all drawBitmap methods

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 47 Commit Notification 2015-12-12 11:46:22 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f63516df72b49e9347d90750f6d3ef3d4a1813f&h=libreoffice-5-1

tdf#94851 check SalBitmap & convert in all drawBitmap methods

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 48 Michael Meeks 2015-12-12 12:13:30 UTC
Wonderful; thanks Tomaz - and thanks for filing ! =) For 5.0.x we disabled GL by default.
Comment 49 Commit Notification 2015-12-12 16:10:33 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8227e8bef1c8c6c95627daf5023fe927605d50d2

tdf#94851 quick fix for drawBitmap

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 50 Robinson Tryon (qubit) 2015-12-13 10:18:17 UTC Comment hidden (obsolete)
Comment 51 marshals 2015-12-13 12:02:03 UTC
(In reply to Michael Meeks from comment #48)
> For 5.0.x we disabled GL by default.

are you sure?

i've just installed LO-5.0.3.2 x64 on a fresh Win10Home x64 build, and under Options > LibreOffice > View, the "Use OpenGL for all rendering" is ticked (as is Options > LibreOffice > Open CL "Allow use of OpenCL").

or did you mean some other setting?  or am i misunderstanding something?
Comment 52 Commit Notification 2015-12-14 11:13:39 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f625f1e1ff3b557fbe16c281baaf35fdb48eb048&h=libreoffice-5-0

tdf#94851 can't use OpenGLSalBitmap with WinSalGraphics

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 53 Cor Nouws 2015-12-14 18:33:04 UTC
(In reply to marshals from comment #51)
> (In reply to Michael Meeks from comment #48)
> > For 5.0.x we disabled GL by default.
> 
> are you sure?
> 
> i've just installed LO-5.0.3.2 x64 on a fresh Win10Home x64 build, and under


I think Michael meant 5.0.4.2 (and maybe 5.0.4.1, thus 5.0.4.x)
Comment 54 Buovjaga 2015-12-21 16:04:45 UTC
*** Bug 96646 has been marked as a duplicate of this bug. ***
Comment 55 Maxim Korobov 2016-01-07 17:27:43 UTC
*** Bug 96901 has been marked as a duplicate of this bug. ***
Comment 56 Buovjaga 2016-01-09 09:27:36 UTC
*** Bug 96934 has been marked as a duplicate of this bug. ***
Comment 57 Xisco Faulí 2017-10-27 11:22:42 UTC
*** Bug 94830 has been marked as a duplicate of this bug. ***