Download it now!
Bug 96934 - LibreOffice crashes when printing a jpg image
Summary: LibreOffice crashes when printing a jpg image
Status: RESOLVED DUPLICATE of bug 94851
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-07 01:07 UTC by Stephen Brent
Modified: 2016-01-09 09:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample of an odp file with 5 jpgs (723.61 KB, application/vnd.oasis.opendocument.presentation)
2016-01-07 01:09 UTC, Stephen Brent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Brent 2016-01-07 01:07:09 UTC
New problem since Windows 10 installed. Any document, written, drawing, presentation that has a jpg imaged inserted crashes when printing. The document appears fine on screen but instant crash with no error defined when printing.
These jpg's print well and cause no problems with any other software only LibreOffice.
Comment 1 Stephen Brent 2016-01-07 01:09:49 UTC
Created attachment 121757 [details]
Sample of an odp file with 5 jpgs
Comment 2 Buovjaga 2016-01-07 12:17:18 UTC
Sounds like a dupe of bug 94851

Disable (and restart LibreOffice) Tools - Options - LibO - View - Use OpenGL for all rendering

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED DUPLICATE of bug 94851, if the problem went away.
Comment 3 Stephen Brent 2016-01-07 21:51:17 UTC
I followed the procedure > no change. I reset to unconfirmed.
Comment 4 Buovjaga 2016-01-08 07:48:56 UTC
Ok, that is actually surprising :)

Could you test with a fresh build of 5.2 to see, if the crash happens with it as well: http://dev-builds.libreoffice.org/daily/master/Win-x86@62-merge-TDF/
It is installed separately, so it will not mess with your stable version.
Comment 5 Stephen Brent 2016-01-08 18:14:45 UTC
Well, I have good news. 5.2 fixed the problem & operates faster on my Windows 10 x 64 system. The menuing is also cleaner and faster to use. 
Do I keep using the 5.2 alpha or will you correct and I switch back to 5.0?

Stephen
Comment 6 Buovjaga 2016-01-08 19:02:40 UTC
(In reply to Stephen Brent from comment #5)
> Well, I have good news. 5.2 fixed the problem & operates faster on my
> Windows 10 x 64 system. The menuing is also cleaner and faster to use. 
> Do I keep using the 5.2 alpha or will you correct and I switch back to 5.0?
> 
> Stephen

Well, looking at the information in bug 94851 (if we believe this fixed it), the fix should also be in 5.0.5.

The first release candidate for 5.0.5 should be out in a couple of weeks: https://wiki.documentfoundation.org/ReleasePlan/5.0#5.0.5_release

However, there is a 32-bit daily build of 5.0.5 available: http://dev-builds.libreoffice.org/daily/libreoffice-5-0/Win-x86@62-merge-TDF/

You might install that daily build of 5.0.5 and see, if the problem is gone in it as well.

If the problem is gone, you can set this as resolved duplicate of bug 94851.
Comment 7 Stephen Brent 2016-01-08 21:39:42 UTC
I just tested the 32 bit version of 5.05 in all 3 formats > text, presentation & drawing and all is well.

I will use this version until the new 5.05 64 bit is released.

Many thanks for all of the help & interest in the problem.

Good work.

Stephen
Comment 8 Buovjaga 2016-01-09 09:27:36 UTC
Thanks :)
I will assume this to be a dupe of 94851 so changing status.

*** This bug has been marked as a duplicate of bug 94851 ***