Download it now!
Bug 95621 - PNG Images FORMATTING and Scale incorrect upon EXPORT to PDF or PRINT to PDF
Summary: PNG Images FORMATTING and Scale incorrect upon EXPORT to PDF or PRINT to PDF
Status: RESOLVED DUPLICATE of bug 94851
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-05 21:47 UTC by George Pantazes
Modified: 2015-12-04 16:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The Draw document with the problem (50.39 KB, application/vnd.oasis.opendocument.graphics)
2015-11-30 05:21 UTC, George Pantazes
Details
PDF generated with OpenGL Rendering (71.96 KB, application/pdf)
2015-11-30 05:22 UTC, George Pantazes
Details
PDF with OpenGL turned off (80.93 KB, application/pdf)
2015-11-30 05:24 UTC, George Pantazes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Pantazes 2015-11-05 21:47:05 UTC
Context: I was editing a preexisting PDF. This part was fine, loss of some formatting is expected. The only things in the document were preexisting text that seemed to be imported by making all lines their own textboxes, and there was an image signature near the bottom of the document.

Bug: Images scale incorrectly upon Export to PDF or dissappear upon Print to PDF.

There are two images in the file. The first was already in the pdf, a signature at the bottom of the page.
The second was a PNG signature I dragged into the file.
Both of these images distort and scale incorrectly, or disappear depending on my export choice. Regular filesaving behaves fine. If I tried to Export the document to PDF the images keep the same clipping bounds but the content scales up to what looks like the bottom left 1/4th of the image. Print to PDF causes the images to disappear.

I tried potentially solving the issue by bringing the images to the front, but that did nothing.
Comment 1 Buovjaga 2015-11-10 13:34:22 UTC
Can you share an example PDF or Draw file so we can test?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the file.
Comment 2 V Stuart Foote 2015-11-28 21:44:53 UTC
Suspect this to be manifestation of bug 95814

What happens if you disable the OpenGL support?  

Done from Tools -> Options -> View: and uncheck "Use OpenGL rendering for all rendering".  Then restart LibreOffice and retest.

If that corrects issue, please resolve this as duplicate of bug 94851
Comment 3 George Pantazes 2015-11-30 05:21:33 UTC
Created attachment 120891 [details]
The Draw document with the problem

This is the file generating the PDF's with the error.
Comment 4 George Pantazes 2015-11-30 05:22:31 UTC
Created attachment 120892 [details]
PDF generated with OpenGL Rendering

This is the kind of PDF demonstrating the problem. The images are scaling strangely.
Comment 5 George Pantazes 2015-11-30 05:24:14 UTC
Created attachment 120893 [details]
PDF with OpenGL turned off

After turning off the OpenGL rendering as suggested, the images rendered correctly in the PDF.
Comment 6 George Pantazes 2015-11-30 05:26:03 UTC
V Stuart Foote, you guessed what would fix it. Since turning off OpenGL fixed the PDF, I'll mark this as a duplicate of 94851.

*** This bug has been marked as a duplicate of bug 94851 ***