Bug 96901 - Crash when printing file with one image
Summary: Crash when printing file with one image
Status: RESOLVED DUPLICATE of bug 94851
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-05 08:56 UTC by Maxim Korobov
Modified: 2016-01-07 17:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example (411.00 KB, application/ms-word)
2016-01-05 08:56 UTC, Maxim Korobov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Korobov 2016-01-05 08:56:01 UTC
Created attachment 121724 [details]
Example

Stable crash on my setup when sending attached file to printer.
After 3 crashes I copy image to MSPaint and print it correctly.
Comment 1 m.a.riosv 2016-01-05 21:20:11 UTC
Not reproducible:
Win10x64
Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78

Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affect all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 2 Maxim Korobov 2016-01-06 09:54:54 UTC
I renamed user folder to user-old. New profile created.
Then I tried to print the file - crash repeated.
Comment 3 Timur 2016-01-06 17:50:08 UTC
Please check whether it's just a duplicate of Bug 94851 solved in 5.0.5.

Please confirm that you have:
1.) set Tools -> Options -> View: "Use OpenGL for all rendering" to unchecked
2.) restarted LibreOffice
Only that will disable use of OpenGL for testing.
Does your printing then include pictures/images?

If that resolves the print issue, please reset this as duplicate of bug 94851

If not, please provide details of your LibreOffice build--copied from the Help -> About LibreOffice dialog. And about your version of MS Windows--run "msinfo32.exe" and copy from the Summary panel, and the Components -> Display panel.

Thank you.
Comment 4 Maxim Korobov 2016-01-07 17:27:43 UTC
Yes, unchecking "Use OpenGL for all rendering" checkbox helps.
So I close it as duplicate.
You can see example file with image attached to the issue.

*** This bug has been marked as a duplicate of bug 94851 ***