Download it now!
Bug 96179 - Pictures inserted in Writer or calc or draw not printed
Summary: Pictures inserted in Writer or calc or draw not printed
Status: RESOLVED DUPLICATE of bug 94851
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-01 13:08 UTC by JCE
Modified: 2015-12-04 14:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test files with inserted images, before and after print (626.35 KB, image/jpeg)
2015-12-01 13:16 UTC, JCE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JCE 2015-12-01 13:08:02 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 5.0.3.2

If a file (odt, xls, draw...) includes image(PNG, JPG) the image is blank in printout.

Reproducible: Always

Steps to Reproduce:
1.Create a file with text
2.insert image
3.Print it (CTRL P)
Actual Results:  
Images are ignored whilst but room retained

Expected Results:  
No ptinted image

[Information automatically included from LibreOffice]
Locale: fr
Module: TextDocument or Calc or draw (impress not tested)
[Information guessed from browser]
OS: Windows 10 and XP-SP3
OS: 64bit and 32bit

Workarounds tested
1 revert if possible to LO 4.4
2 Painfull: Export file to non LO5 print facilities: PDF, OpenOffice, MS Word...


Reset User Profile?yes
Comment 1 JCE 2015-12-01 13:16:30 UTC
Created attachment 120925 [details]
test files with inserted images, before and after print

Attachment is a scanned image of the printed Test file.odt
Can be repeated with a calc file or a Draw file
Comment 2 Cor Nouws 2015-12-01 15:21:44 UTC
Hi Jean-Claude,

Thanks for reporting here. I expect that this is related to Tools > Options > LibreOffice > View .. use OpenGL for all rendering.
I mark as duplicate of bug 94851. 
If I'm mistaken: then please reopen and apologies!
Cor

*** This bug has been marked as a duplicate of bug 94851 ***
Comment 3 Cor Nouws 2015-12-02 13:18:18 UTC
not a duplicate of bug 94851
Comment 4 V Stuart Foote 2015-12-02 14:55:19 UTC
@JCE,

Please confirm that you have:

1.) set Tools -> Options -> View: "Use OpenGL for all rendering" to unchecked
2.) restarted LibreOffice

Only that will disable use of OpenGL for testing.

Does your printing then include pictures/images?

If that resolves the print issue, please reset this as duplicate of bug 94851

If it does not, please provide complete details of your LibreOffice build--copied from the Help -> About LibreOffice dialog. And about your version of MS Windows--run "msinfo32.exe" and copy from the Summary panel, and the Components -> Display panel.

Thank you.
Comment 5 JCE 2015-12-03 15:34:09 UTC
1- OpenCL set (default): Printing images fails
2- OpenCl disabled and LO5 Closed and reopened: printing images fails
3- OpenCl re-activated and LO5 Closed and opened: printing images fails
4- OpenCl disabled and LO5 closed and opened :              Printing OK
5- OpenCl re-activated and LO5 Closed and opened:           Printing OK

Activating/disabling several times OpenCL, each followed by close-Open LO5 seems to have cleared the bug. This bug report lost his purpose
Comment 6 V Stuart Foote 2015-12-03 17:14:36 UTC
@JCE,

Apologies for the hassle in reliably disabling OpenGL. That should resolve things for you until routines for detection of GPU model and drivers does it reliably within LibreOffice (so called blacklisting of you GPU).

I've gone ahead and set this as a duplicate of bug 94851--please reopen and set to Unconfirmed if that does not seem correct.

Please note that: 

OpenGL --Open Graphics Library-- is distinct from OpenCL --Open Computing Language-- and while the project utilizes OpenCL for parallelism of formula calculations in clac, it has no relationship to the the graphics routines--including some printing (at the 5.0.3 release) that use OpenGL (other than running on the same GPU hardware).

=-ref-=

https://en.wikipedia.org/wiki/OpenGL

https://en.wikipedia.org/wiki/OpenCL

*** This bug has been marked as a duplicate of bug 94851 ***
Comment 7 JCE 2015-12-04 14:15:11 UTC
Sorry for mixing up OpenCL and OpenGL.

All my previous attempts were performed with OpenGL activated thus misprinting mixed files, but not always.
Never got the print of exported to PDF faulty.

New tests based on OpenGl activation give the following results.
OpenGL ON : ODT file print fails
OpenGL OFF : ODT file print pass

Regargs